Puli 6.2

Pupletek, Új puppy változatok, veruiók, ISO fájlok,
Avatar
nocsak
Hozzászólások: 412
Csatlakozott: 2014.09.29. 15:01
Kapcsolat:

Re: Puli 6.2

Hozzászólás Szerző: nocsak »

Mindeközben Discordon arról agyalunk, hogy ahogy az AppImageknél megadják melyik glibc verzióhoz jó, vagy alatt készült, itt a kernelnél sem mindegy hiába huge.

Ugye ha az udevd 2.33-mas és én egy 2.36 os glibc-s és gcc-s kernellel megyek neki esélyes, hogy tele lesz hibával a dmesg..... :?

Megpróbálom leforgatni a 6.3.0-t a Pulira... meglátom azzal mi lesz....

gjuhasz
Adminisztrátor
Hozzászólások: 152
Csatlakozott: 2014.08.17. 13:52

Kernel 6.3.0

Hozzászólás Szerző: gjuhasz »

Kedves nocsak!

Sajnos hibásan működik a Puli a 6.3.0-ás kerneleddel. Valószínűleg az én beállításaim régebbiek, mert a Te verziód máshol keresi a nálam a /root/Startup/-ban előírt feladatokat. Ezáltal például:
  • Nem jön be a Quicksetup, kézzel kell indítani
  • Nem állítja be a hálózatot, kézzel elindul ugyan, de a tray ikon nem változik
  • Nem jelennek meg a drive ikonok a képernyő alján
stb.
A legújabb működő kernel nálam az ozsouth-féle 6.2.9 innen: https://forum.puppylinux.com/viewtopic.php?t=8371, bár az intel backlight link itt is hiányzik (amire a jún. 4-én feltöltött Puli 8.1-ben találtam megoldást).

Jó terelgetést!

üdv

gjuhasz
puli.png
puli.png (10.53 KiB) Megtekintve 3066 alkalommal

Avatar
nocsak
Hozzászólások: 412
Csatlakozott: 2014.09.29. 15:01
Kapcsolat:

Re: Puli 6.2

Hozzászólás Szerző: nocsak »

Kedves gjuhasz!

Azért furcsa amit írsz, mert az első képsorozat amit mellékeltem azon pontosan ez a 6.3.0 kernel ment, számomra ilyen hibáktól mentesen, de látszik is a 2. képen:
uname -rm
6.3.0 x86_64

De majd letöltöm én is újra a standard kernelt és megnézem azzal is.

Minden esetre fordítottam a pulira is 6.3.0 kernelt, azt sikeresen. Tehát majd azzal is leellenőrzöm.

---szerk.---

ugyanaz a jelenség mint az eredeti 6.3.0 kernellel, és akkor majd holnap leellenőrzöm a standarddal is.


---szerk.---


Leellenőriztem a standarddal is azzal sincs olyan hiba amit említettél, viszont az ffmpeggel is lesz egy kis munka, https linkeket pl egyáltalán nem nyit meg sem az ffplay sem az ffmpeg.
aaaa.jpg
aaaa.jpg (298.8 KiB) Megtekintve 3040 alkalommal

ticoo1
Hozzászólások: 626
Csatlakozott: 2014.10.21. 08:58

Re: Puli 6.2

Hozzászólás Szerző: ticoo1 »

Helló!

Javasolnék egy-két változtatást, ha lehet. Találtam benne hibákat, s javítottam.
Csináltam hozzá frissítő csomagokat a hibák javítására, ill. az ffmpeg telepítéséhez, minden javítás PPM-ből is elérhető.
Az egyszerűség kedvéért a puli8.1.sfs-t is újracsináltam (ha sikerült rendesen), tehát csak ki kell próbálni -- csak hibajavításokat tartalmaz!! -- működésbeli változtatásokat nem!

A fejleszthetőség kedvért tettem fel egy csomagot - libc6_2.37+ffmpeg-5.1.3-64-ti.pet, mellyel lehet egy picit előrébb lépni.
Screenshot.jpg
Screenshot.jpg (201.44 KiB) Megtekintve 3024 alkalommal
Itt vannak a csomagok: https://sourceforge.net/projects/puppys ... eszt/P8.1/




















:

gjuhasz
Adminisztrátor
Hozzászólások: 152
Csatlakozott: 2014.08.17. 13:52

Re: Puli 8.1 javítások

Hozzászólás Szerző: gjuhasz »

Kedves ticoo1!

Köszönöm a javításokat/csomagokat, este meg tudom nézni.

--------------- szerk június 7 ----------------------

A két ffmpeg csomag és az update-puli-8.1.pet tökéletesen működnek, hálás köszönet értük. Látom, hogy milyen hibá(ka)t javítottál meg, további tesztelésük folyamatban. A módosított puli8.1.sfs egyelőre nem viselkedik puli-szerűen. Nem látom pl. indokoltnak a bejelentkezési képernyő új funkcióját (ezt a Puli automatikusan végzi), de a Te verziód legalább még egy hét komolyabb tesztelést kíván.

Jó terelgetést!

Üdv

gjuhasz
puli.png
puli.png (10.53 KiB) Megtekintve 3020 alkalommal

gjuhasz
Adminisztrátor
Hozzászólások: 152
Csatlakozott: 2014.08.17. 13:52

Re: Puli 6.2

Hozzászólás Szerző: gjuhasz »

nocsak írta: 2023.06.05. 22:29 Minden esetre fordítottam a pulira is 6.3.0 kernelt, azt sikeresen. Tehát majd azzal is leellenőrzöm.
Kedves nocsak,

Fel tudnád tölteni valahová a pulira lefordított 6.3.0-ás kernelt? Előre is köszönöm.

Jó terelgetést!

Üdv,

gjuhasz
puli.png
puli.png (10.53 KiB) Megtekintve 2991 alkalommal

Avatar
nocsak
Hozzászólások: 412
Csatlakozott: 2014.09.29. 15:01
Kapcsolat:

Re: Puli 6.2

Hozzászólás Szerző: nocsak »

Kedves gjuhasz!

A nyers kernel-kit kimenet md5 és bz2 állományát megtalálod a hsz alatti aláírásomban linkelt Google Drive tárhelyemen, a kernel mappán belül a 2023-06-07-Puli-8.1_kernel6.3.0 mappában.

gjuhasz
Adminisztrátor
Hozzászólások: 152
Csatlakozott: 2014.08.17. 13:52

Puli 8.1 javítások

Hozzászólás Szerző: gjuhasz »

(Hol van már a 6.2-es Puli... ;)

Kedves ticoo1!
A módosított puli8.1.sfs egyelőre nem viselkedik puli-szerűen. Nem látom pl. indokoltnak a bejelentkezési képernyő új funkcióját (ezt a Puli automatikusan végzi), de a Te verziód legalább még egy hét komolyabb tesztelést kíván.
Kiderült, hogy az /usr/sbin/welcome1stboot által feldobott ablak okozza azt, hogy az általad módosított puli8.1.sfs "nem viselkedik puli-szerűen".
Az eredeti welcome1stboot -ot visszatéve minden tökéletesen működik. Azaz: ha egyszer, egy adott gépen be lett állítva a wifi, hang stb., és a Save (smart) opcióval léptünk ki, akkor onnantól kezdve ezen a gépen már nem kell semmit beállítani (a puli a /smartsave mappában lévő utasítások alapján mindent automatizál).
Még annyi tennivalóm van, hogy eldöntsem:
(a) adjam ki a fentiek szerint módosított "új" Pulit (persze beregisztrálva mindkét javító csomagodat a /var/packages mappába), vagy
(b) csak az ffmpeg csomagodat égessem + regisztráljam be a "régi" Puli8.1.sfs-be, a gpg -t pedig hagyjam meg az ínyenceknek a boot eszköz /packages/mappájából smartload-dal betölthető csomagként.

Mégegyszer hálásan köszönöm. A feltöltés előtt azonban még futnom kell egy pár kört, hogy az alábbiakat is megoldjam:

Kedves nocsak!

Miután a Puli8.1 összes korábbi verziója (a fenti módosításokat is) jól működött az ozsouth-féle 6.0.6 ... 6.2.9 kernelek hátán, elkezdtem tesztelni a Tőled kapott, Puli specifikus, 6.3.0-ás kernellel is.
  • Első közelítésben csak a vmlinuz, fdrv, zdrv fájlokat cseréltem le. A boot része jó volt egészen ax X megjelenéséig, de ott megakadt (a welcome1stboot verziótól függetlenül), még mielőtt a Quicksetup elindult volna és semmit nem alkalmazott a korábban elmentett gép-specifikus beállításokból. Se hálózat, se magyar billentyűzet, se hang, de pl. szöveget lehetett szerkeszteni és az adott session tartamára (egyenként) mindent be is lehetett állítani.
  • A második közelítésben kiirtottam a korábban elmentett gép-specifikus hálózati beállításokat (a hang stb maradt). Ez csak akkor eredményezett némi javulást, ha ethernet kábellel csatlakoztam (valószínűleg a Te screenshotod is így készült, de Nálad sem látszik pl. a fényerő-szabályzó ikon a tray-ben).
  • A harmadik közelítésben az első közelítést folytattam azzal, hogy a kiakadás után a menüből újraindítottam az X-et. Ennek hatására minden megjavult, bejött a Quicksetup, automatikusan felállt a korábban smartsave-elt hálózat, hang, stb., és a kerneled kiválóan teljesített.
Ez volt az az állapot, amitől boldogan álltam fel a székből (éjjel háromkor), és ahonnan ma este folytatni fogom. Amit meg kell néznem, hogy miért csak a Te 6.3.0 -ás kerneleddel jelentkezik ez a probléma (mástól nem találtam 6.3-as sorozatú kernelt, de azok most nem érdekelnek), illetve addig kell a puli fülét csavargatnom, ameddig meg nem javul és nem működik úgy mint a 6.0.6 ... 6.2.9 -esekkel.

Addig is hatalmas köszönet a segítségedért.

Jó terelgetést!

Üdv

gjuhasz
puli.png
puli.png (10.53 KiB) Megtekintve 2957 alkalommal

Avatar
nocsak
Hozzászólások: 412
Csatlakozott: 2014.09.29. 15:01
Kapcsolat:

Re: Puli 6.2

Hozzászólás Szerző: nocsak »

Üdv!

Kedves gjuhasz!

Igazán nincs mit, amúgy egy másik plusz információ az xwin szkripthez, amit nekünk is cserélni kellett az egyik DPupban mert a gyári vanilla xwinnel nem volt input egyáltalán, se billentyűzet se egér de még talán numlock se.... aztán kicseréltük s lőn világosság.... - hátha segít az ötletelésben. Amúgy a szkriptek alkalmazási sorrendje is lehet hiba oka, de azt is szerettem volna jelezni, hogy az a kernel dpup-os változata ami forrását tekintve egy és ugyanaz, hozza alapból az intel-nvidia-s hybrid gépen a /sys/class/backlight/intel_backligt linket s működik vele a brightness állítónk is. Amúgy az /etc/rc.d/rc.sysinit háza tájékán is érdemes lehet még körbeszaglászni valamint az udev configok környékén is. No de ezek csak tippek, sok szerencsét a megoldáshoz - véglegesítéshez! :)

gjuhasz
Adminisztrátor
Hozzászólások: 152
Csatlakozott: 2014.08.17. 13:52

Puli - 3.6.0 kernel

Hozzászólás Szerző: gjuhasz »

Kedves nocsak!

A probléma megoldódott. Nem a Puli és nem is a Te kerneled, hanem az fdrv volt a hunyó.

A Te 6.3.0 kerneleddel kapott vmlinuz és zdrv mellé bemókoltam egy korábbi fdrv-t, amit már a 6.1.6-os kernelnél is használtam, és ettől (legalábbis első látásra) minden rendbe jött. :D

Itt az fdrv: https://drive.google.com/drive/folders/ ... ib_t0KaJX-

Az intel backlight-ot ugyan hozzá tudnám adni a kernel paraméterekhez a boot eszköz /boot/grub/grub.cfg fájljában, de gyanítom, hogy akkor nem lesz hordozható a különféle típusú gépek között a Puli pendrájv. Emiatt egyelőre áttértem a (szintén manuális) acpi_backlight=video beállításra, tehát az ACPI video.ko driverre.

Az rc.sysinit és az xwin további vizsgálatok alatt.

Kudos.

Jó terelgetést!

Üdv

gjuhasz
Csatolmányok
puli.png
puli.png (10.53 KiB) Megtekintve 2936 alkalommal

Válasz küldése

Vissza: “Pupletek”