TeamViewer Linux-ra (portable csomag-benne a Wine-vel)

Böngészők, üzenetküldők, levelezők, stb...
willy36
Hozzászólások: 161
Csatlakozott: 2017.05.16. 18:43

Re: TeamViewer Linux-ra (portable csomag-benne a Wine-vel)

Hozzászólás Szerző: willy36 » 2019.02.24. 09:08

Köszönöm Tamás a válaszod, ezeket kerestem.
Közben gjuhasz puli progjamjaiból feltettem a wine 4.1-et https://drive.google.com/drive/folders/ ... YHGs3mfNSi
az rendben is megy, leszedtem a legújabb teamviewer.deb-et is: https://www.teamviewer.com/hu/letoltes/linux/
, ami a 14-es verzió, fel is települt wine-al majdnem, elindult a telepítés, de a végén a temp-ből nem tudja törölni az ideiglenes file-okat, gondolom az útvonal hibája miatt, ezért itt megszakad az install. Esetleg van rá megoldás? Lehet én nem vettem észre valamit, és egyszerű, mint a faék. Luigi, sajnos innen eddig tudok segíteni, én sem vagyok nagy spieler, ahogy a képen látod, nekem elindult. Csak találgatok, esetleg gjuhasztól tedd fel a wine-t, de ahogy Tamás írta, nem valószínű, hogy onnan olvas be valamit, csak próbaképp. én mindig tiszta rendszerrel próbáltam, utoljára ennyi volt a plusz.

Javítás: Elnézést mindenkitől elbambultam és a Linux.os verziót tettem be, közben végig a win verzió volt a fejemben...
a Windows-os link: https://www.teamviewer.com/hu/letoltes/windows/
A hozzászólást 2 alkalommal szerkesztették, utoljára willy36 2019.02.24. 12:45-kor.

NTamas
Hozzászólások: 1551
Csatlakozott: 2014.06.19. 13:36

Re: TeamViewer Linux-ra (portable csomag-benne a Wine-vel)

Hozzászólás Szerző: NTamas » 2019.02.24. 12:07

willy36 írta:
2019.02.24. 09:08
Közben gjuhasz puli progjamjaiból feltettem a wine 4.1-et https://drive.google.com/drive/folders/ ... YHGs3mfNSi
az rendben is megy, leszedtem a legújabb teamviewer.deb-et hozzá: https://www.teamviewer.com/hu/letoltes/linux/
, ami a 14-es verzió, fel is települt wine-al majdnem, elindult a telepítés, de a végén a temp-ből nem tudja törölni az ideiglenes file-okat, gondolom az útvonal hibája miatt, ezért itt megszakad az install. Esetleg van rá megoldás?
Kedves willy36, egy dolog azért eszembe ötlött, ahogy a topic bevezető írásában is említettem már 2016-ban, ezek kombinált a pet és sfs csomagok ugye már eleve tartalmaznak egy, a programhoz beállított wine-t, mivel ezen csomagok ún. kvázi portable csomagok, ennek bizonyításához elég, ha csak UExtract-al kibontod pl. a 9-es pet csomagot, és a kibontott pet könyvtárban az opt-ban lévő teamviewer könyvtáron belül belépsz a tv_bin alkönyvtárba, és ott meg fogod találni a wine könyvtárát, és annak minden alkotó elemét, közte a wine-hez kellő, és a programokat is tartalmazó drive_C alkönyvtárat, azon belül a TeamViewer könyvtárat és abban pedig a Windowsos TeamViewer program fájljait.
Kép

Normális esetben a puppy-ba telepítendő Wine csomag részek nem ily módon kerülnek be a rendszerbe, hanem egyik részük az /usr/share/wine/-be kerül, meg a /usr/lib/wine könyvtárba, illetve az /usr/bin-be és az /usr/share/applications könyvtárba is bekerülnek a megfelelő wine fájlok. A drive_c könyvtár pedig -az oda és azon belül a Program Files-be telepített Windowsos progikkal együtt- alapesetben a /root/.wine könyvtárba kerül be a wine program telepítésekor.
Kép

Ezekből jól látható, hogy a Wine-t is tartalmazó 9-es teamviewer.pet telepítéskor valójában egy portable -minden egybe- csomag kerül a gépre az /opt könyvtárba, ami saját wine-vel bír. Erre írtam annó, hogy az ilyen wine-vel kombinált csomagokat csak akkor telepítsük fel a gépre, ha azon még nincsen telepített wine, mert a kettő könnyen összeakadhat, és működésbeli problémák jöhetnek elő.

Ami a 14-es deb teamviewer fájlt illeti, nos, mint ezt is írtam már, ebben már nincsen! wine, ez már csak sima TeamViewer program, aminek a futtatásához szükségeltetik a gépen egy Qt5.6 csomag megléte, telepítése. De ezt magad is láthatod, ha UExtract-al kibontod a kérdéses 14-es deb fájlt, nem fogsz benne wine-s fájlokat találni, -ezt már amúgy a csomag mérete is jelzi- és a kibontott deb fájlban van egy control nevű fájl, abban ott van az új 14-es TeamViewer program teamviewer_14.1.9025_i386.deb csomagjának a depends/függőség felsorolása is.
------------------------------------------------------------------------
Package: teamviewer
Maintainer: TeamViewer GmbH <service@teamviewer.com>
Homepage: http://www.teamviewer.com
Version: 14.1.9025
Architecture: i386
Section: non-free/net
Priority: optional
Depends: libc6 (>= 2.17), libdbus-1-3, libqt5gui5 (>= 5.5) | qt56-teamviewer, libqt5widgets5 (>= 5.5) | qt56-teamviewer, libqt5qml5 (>= 5.5) | qt56-teamviewer, libqt5quick5 (>= 5.5) | qt56-teamviewer, libqt5dbus5 (>= 5.5) | qt56-teamviewer, libqt5webkit5 (>= 5.5) | qt56-teamviewer, libqt5x11extras5 (>= 5.5) | qt56-teamviewer, qml-module-qtquick2 (>= 5.5) | qt56-teamviewer, qml-module-qtquick-controls (>= 5.5) | qt56-teamviewer, qml-module-qtquick-dialogs (>= 5.5) | qt56-teamviewer, qml-module-qtquick-window2 (>= 5.5) | qt56-teamviewer, qml-module-qtquick-layouts (>= 5.5) | qt56-teamviewer
Recommends: ttf-liberation | fonts-liberation
Replaces: teamviewer5, teamviewer6, teamviewer7, teamviewer8, teamviewer9
Conflicts: teamviewer5, teamviewer6, teamviewer7, teamviewer8, teamviewer9, teamviewer-host
Installed-Size: 60564
Description: Remote control and meeting solution.
TeamViewer provides easy, fast and secure remote access and meeting solutions
to Linux, Windows PCs, Apple PCs and various other platforms,
including Android and iPhone.
TeamViewer is free for personal use.
-------------------------------------------------------------------
Kép

Ráadásul jól látható a képeken, hogy az új Teamviewer csomag is már az /opt-ba települ be, és ha ott már van egy régebbi, vagy akár a kombinált pet-ből való telepített Teamviewer könyvtár, akkor abba bizony bele fog rondítani, és ez gondok forrása lehet.
Épp ezért az új. teamviewer_14.1.9025_i386.deb csomag telepítése előtt a gépen lévő összes, régi Teamviewer telepítésből származó könyvtárat, fájlokat el kell a gépről távolítani, és az új program megfelelő futtatásához a Qt 5.6 csomagot telepíteni kell, ami önmagában majd 300MB! És pont emiatt nem mindegyik új puppy verzió tartalmazza azt!

willy36
Hozzászólások: 161
Csatlakozott: 2017.05.16. 18:43

Re: TeamViewer Linux-ra (portable csomag-benne a Wine-vel)

Hozzászólás Szerző: willy36 » 2019.02.24. 12:38

Hű, köszönöm így jobban átlátom az egészet, és kezdem érteni a logikáját. nagy köszönet érte.
Viszont elnézést a nagy félrevezetésért, de a Win verziót próbáltam a wine alatt feltenni, nem a debiant :) Ezért Mea Culpa. De így kiderült a deb file tartalma is. Tanulságos volt, mit írtál, számomra

luighy
Hozzászólások: 39
Csatlakozott: 2018.05.02. 11:24

Re: TeamViewer Linux-ra (portable csomag-benne a Wine-vel)

Hozzászólás Szerző: luighy » 2019.02.24. 14:38

Köszönöm hogy próbáltál segíteni.
Megpróbálok egy friss os-t a meglévő mellé feltenni.

janugsa
Hozzászólások: 379
Csatlakozott: 2014.06.28. 00:17

Re: TeamViewer Linux-ra (portable csomag-benne a Wine-vel)

Hozzászólás Szerző: janugsa » 2019.02.24. 15:23

Itt található a TeamViewer Bionicpup64-hez (Xenialpup64-en nem indult el). Csak az elindítást próbáltam, használatát nem.
http://distro.ibiblio.org/puppylinux/pe ... -bionic64/
A pet fájl 22 MB, telepítése közben letölt és telepít a Qt5 fájlokat,
(érdekes, mert még ilyen megoldást nem láttam).
Én Bionicpup64 8.0 puppyn próbáltam, itt van:
http://murga-linux.com/puppy/viewtopic. ... 44#1004969

Van magyar változatai a bionicpup64-nek ticoo1-től, pár hónappal régebbiek. Ezeken nem próbáltam ki a TeamViewer elindulását.
https://sourceforge.net/projects/puppys ... onicpup64/
Screenshot.jpg
Screenshot.jpg (42.52 KiB) Megtekintve 471 alkalommal

luighy
Hozzászólások: 39
Csatlakozott: 2018.05.02. 11:24

Re: TeamViewer Linux-ra (portable csomag-benne a Wine-vel)

Hozzászólás Szerző: luighy » 2019.02.28. 12:50

NTamas írja:
Épp ezért az új. teamviewer_14.1.9025_i386.deb csomag telepítése előtt a gépen lévő összes, régi Teamviewer telepítésből származó könyvtárat, fájlokat el kell a gépről távolítani, és az új program megfelelő futtatásához a Qt 5.6 csomagot telepíteni kell, ami önmagában majd 300MB! És pont emiatt nem mindegyik új puppy verzió tartalmazza azt!
1.
Hogyan kell (illetve honnan) a Qt 5.6 csomagot telepíteni? (Alábbiakból talán kiderül mi nem világos nekem.)

2. a függőségek listázásakor ezt dobja ki (miután a teamviewer honlapról a teamviewer_14.1.18533_amd64.deb -et telepítettem ):
File /opt/teamviewer/tv_bin/script/libdepend has these missing library files:
libfontconfig.so.1 libfreetype.so.6 libSM.so.6 libXrender.so.1 libXdamage.so.1 libXext.so.6 libXfixes.so.3 libXinerama.so.1 libXrandr.so.2 libXtst.so.6
File /opt/teamviewer/tv_bin/TeamViewer has these missing library files:
libQt5X11Extras.so.5 libQt5DBus.so.5 libQt5WebKitWidgets.so.5 libQt5WebKit.so.5 libQt5Quick.so.5 libQt5Qml.so.5 libQt5Widgets.so.5 libQt5Gui.so.5 libQt5Network.so.5 libQt5Core.so.5
File /opt/teamviewer/tv_bin/teamviewer-config has these missing library files:
libQt5Quick.so.5 libQt5Qml.so.5 libQt5Gui.so.5 libQt5Core.so.5
3.
A puppy csomagkezelo meg mindenféle libqt5* cuccot felajanl.

4.
Nincs olyan telepítési mód ahol a függőségeket is telepíti automatikusan? Nekem voltak olyan emlékeim mintha ilyet már láttam volna. Persze ez lehet disztro függő. Márcsak azért is kérdem mert a függőségeknél mintha nemcsak qt könyvtárak lennének :
File /opt/teamviewer/tv_bin/script/libdepend has these missing library files:
libfontconfig.so.1 libfreetype.so.6 libSM.so.6 libXrender.so.1 libXdamage.so.1 libXext.so.6 libXfixes.so.3 libXinerama.so.1 libXrandr.so.2 libXtst.so.6
Annyit hozzá kell tegyek hogy a skamilinux-ról letöltöttem a
Xenialpup64_7.5_HU_Pmoon_K4.6.3.iso
es frugal módban "telepítettem".
Ez tehát az alap.

Bocs a sok felvetés miatt.
Ha a valaki iránymutatást ad megköszönöm :-)

Mindenesetre a "frugal"-os telepítés hihetetlenül egyszerű Skami videója adta az infót hogy megpróbáljam, köszönet érte! :P

NTamas
Hozzászólások: 1551
Csatlakozott: 2014.06.19. 13:36

Re: TeamViewer Linux-ra (portable csomag-benne a Wine-vel)

Hozzászólás Szerző: NTamas » 2019.02.28. 20:19

luighy írta:
2019.02.28. 12:50
1.Hogyan kell (illetve honnan) a Qt 5.6 csomagot telepíteni? (Alábbiakból talán kiderül mi nem világos nekem.)
2. a függőségek listázásakor ezt dobja ki (miután a teamviewer honlapról a teamviewer_14.1.18533_amd64.deb -et telepítettem ):
File /opt/teamviewer/tv_bin/script/libdepend has these missing library files:
libfontconfig.so.1 libfreetype.so.6 libSM.so.6 libXrender.so.1 libXdamage.so.1 libXext.so.6 libXfixes.so.3 libXinerama.so.1 libXrandr.so.2 libXtst.so.6
File /opt/teamviewer/tv_bin/TeamViewer has these missing library files:
libQt5X11Extras.so.5 libQt5DBus.so.5 libQt5WebKitWidgets.so.5 libQt5WebKit.so.5 libQt5Quick.so.5 libQt5Qml.so.5 libQt5Widgets.so.5 libQt5Gui.so.5 libQt5Network.so.5 libQt5Core.so.5
File /opt/teamviewer/tv_bin/teamviewer-config has these missing library files:
libQt5Quick.so.5 libQt5Qml.so.5 libQt5Gui.so.5 libQt5Core.so.5
3.
A puppy csomagkezelo meg mindenféle libqt5* cuccot felajanl.
Például innen, a hivatalos weboldaláról.
https://download.qt.io/archive/qt/5.6/5.6.0/
qt-opensource-linux-x64-5.6.0.run 15-Mar-2016 13:38 661M
https://download.qt.io/archive/qt/5.6/5 ... -5.6.0.run

A.run kiterjesztésű driver és egyéb fajta telepítő fájlokat a Linux és Puppy Linux alá egyszerűen a fájl futtatásával lehet feltelepíteni, de előtte a fájlnak futási jogot kell adni. Puppyban ez úgy megy, hogy a letöltött.run végződésű fájlra állsz a rox-ban, majd nyomsz egy jobb egérgombot. Ekkor feljön egy helyi menű, abból alul ott a fájl jogosultságát megváltoztató menüpont, arra rákattintva adsz a fájlnak futási jogot. Ekkor az eddig még feketével látszódó fájl a Rox-ban zöld színűre vált át, ezzel is jelzi a Rox-fájlkezelő, hogy egy, már futtatható fájlal van dolgod. Innentől már sima rákattintással tudod telepíteni a kérdéses állományt. DE!
Ez a komplett Qt5.6 csomag mindent tartalmaz, egy csomó olyan dolog is van benne, pl.demo és példaprogram fájlok, amiket amúgy a legritkább esetben használsz majd, és emiatt nem ezt a komplett Qt5.6 telepítőt érdemes leszedni, már csak a mérete miatt sem.
Ha tudod, márpedig tudod, hiszen Te is megírtad, hogy a kérdéses szoftver mely Qt-5.6 állományokat igényli a működéséhez, ekkor célszerű először a használt puppy oprendszerben lévő csomagkezelőt használni, és beszerezni a szükséges fájlokat akár egyesével, ha pl. a csomagkezelő így ajánlaná fel, vagy egy, a komplett QT5.6-nál kisebb, ún csak a futtatáshoz szükséges binárisokat magában hordozó akát .deb, akár .pet, vagy .sfs fájl formátumban és jóval kisebb méretben.

Nekem most egy Precise Puppy fut a gépen, és ennek a csomagkezelőjén tudom megmutatni, hogyan is kell a szükséges Qt binárisokat beszerezni a futtatott rendszer csomagkezelőjéből. Az ne tévesszen meg, hogy a Precise Puppy csomagkezelője még egy régebbi QT4-es verziót ajánl fel letöltésre, ezen Puppy verzióhoz elvileg ez való, igaz rá lehet tenni nagyobb verziójú QT4-es csomagot is.
Kép
Tehát beírod a xenial puppy csomagkezelőjébe, hogy Qt5 és az ki fog adni valamilyen találatot, vagy fájlonként kell leszedned a szükséges Qt5 elemeket, vagy esetleg fel fog ajánlani egy kisebb, de csak a szükséges binárisokat tartalmazó mini telepítő csomagot, ami a mérete okán nem is olyan mini lesz.
(nálam a példaképen azért szerepel csak Qt és nincs mögötte verziószám, mert tudom, hogy a Precise-re eleve nincsen Qt5-ős csomag letölthető)

A xenial puppy csomagkezelőjéből kijelölt fájlokat a csomagkezelő telepíti, ha esetleg talál hozzá még szükséges függőségi fájlokat, azt úgy is jelezni fogja, és akkor letöltöd azokkal együtt a kijelölt fájlt, és a csomagkezelő a függőségeket -már amit megtalál- is telepíteni fogja.

Ha a csomagkezelőből nem tudsz minden szükséges fájlt leszedni, akkor bizony azokat kézzel kell a netről beszerezni, ezt hívjuk mi függőség vadászatnak,nem könnyű, de annál időrablóbb művelet.
Ha szerencséd van, az egyes puppy verziók saját netes tárolóiban is lelhetsz ilyen Qt5 csomagot, pl. a tahr-puppyhoz innen szedhetsz le egy Qt5-ös csomagot, elvileg ez még a xenialhoz is jó lehet.
https://distro.ibiblio.org/puppylinux/p ... ages-tahr/
qt5-5.5.1-i386.sfs 2016-Mar-26 11:55:56 (295.0 MB)
https://distro.ibiblio.org/puppylinux/p ... 1-i386.sfs
Ráadásul ezt még telepítened sem kell, mert ez egy sfs fájl, egyszerűen csak felcsatolod a puppyhoz, amikor meg nem kell már, lecsatolod, és ennyi.
luighy írta:
2019.02.28. 12:50
4.
Nincs olyan telepítési mód ahol a függőségeket is telepíti automatikusan? Nekem voltak olyan emlékeim mintha ilyet már láttam volna. Persze ez lehet disztro függő. Márcsak azért is kérdem mert a függőségeknél mintha nemcsak qt könyvtárak lennének :
File /opt/teamviewer/tv_bin/script/libdepend has these missing library files:
libfontconfig.so.1 libfreetype.so.6 libSM.so.6 libXrender.so.1 libXdamage.so.1 libXext.so.6 libXfixes.so.3 libXinerama.so.1 libXrandr.so.2 libXtst.so.6
Azért nem hozza le a letöltött deb fájl a telepítése után a kellő függőségeket, mert a deb fájlt nem a csomagkezelőn keresztül kerested meg, és töltötted le, hanem a program weboldaláról, így maximum csak ki fogja írni, -ahogy nálad is történt- hogy milyen még szükséges függőségi fájlok szükségesek még a program működéséhez.
Ahogy elnézem ahhoz a xeniál puppy verzióhoz még jócskán kelleni fog egyéb függőségi fájl is, látva a hibaüzi szövegét.
Ezen szükséges fájlokat szintén először a rendszer csomagkezelőjéből kell egyenként telepíteni, mert így, ha van az adott hiányzó függgőségi fájlnak egy saját kiegészítő függősége is, úgy azt a csomagkezelő le fogja neked hozni, és a fájllal együtt telepíteni fogja.
Ezt az egyik hiányzó fájlon keresztül mutatnám be, az általad beírt listában szerepel ez a hiányzó állomány:
libfontconfig.so.1

Beírrod a fáljnevet az oprendszered csomagkezelőjébe, és az fel is fog hozni találatot, lásd a példaképen nálam ezt a Precise puppyban mutatva.
Kép
Ha nincs a fájlnak külön függőségi igénye, akkor egy sima letöltő ablakot fogsz kapni, lásd a képen.
Kép
Ekkor letöltöd, és telepíted a kérdéses fájlt, majd elmész a rendszeredbe a /root/.packages könyvtárba, és ott megkeresed a most letöltött állományt, lásd a képen.
Kép
Ezt a fájlt egy szövegszerkesztőben -én a Geany-t használom erre- megnyitva látni fogod, hogy az előbb feltelepített (deb)fájl milyen állományokat és hova tett fel a rendszeredre, és ha jól megnézed, az általad megadott függőségi hiányokban szereplő libfontconfig.so.1 is telepítésre került.
Kép
Az összes többi szükséges függőségi fájlt hasonlóképp tudod beszerezni a rendszered csomagkezelőjéből

Ha netán a csomagkezelőből nem érhető el valamely függőségi fájl, akkor azt a netről kell majd beszerezned, mondjuk a Google-t használva segítségül.
Kép
Csak ilyenkor számolni kell azzal a ténnyel, hogy még ha a netről be is tudod szerezni azt a hiányzó függőségi fájlt, de annak a fájlnak is lehetnek ám még saját függőség igényei, amit meg nem biztos, hogy a netről a kapot linkről be fogsz tudni szerezni.
Ekkor kell használni külön programot, -vagy a .deb fájlokban benne lévő control fájl elolvasni- hogy kiderítsd annak a fájlnak a saját kellő függőség igényét, és azt is be kell majd szerezni a netről.

luighy
Hozzászólások: 39
Csatlakozott: 2018.05.02. 11:24

Re: TeamViewer Linux-ra (portable csomag-benne a Wine-vel)

Hozzászólás Szerző: luighy » 2019.02.28. 21:48

Köszönöm NTamas! :D
Tanulságos a dolog.

Lehet hogy hasznos lehet kísérletezni a függőségek "kézzel" történő feloldásával...

Ha jó értem a csomagkezelő alapból képes a megfelelő függőségek feloldására gondolom ennek az a feltétele hogy valami repóból elérhető legyen a csomag (meg a függőségei), vagy van még egyéb dolog is esetleg? A leírtak alapján logikus lenne a csomagkezelő használata, szóval miért nincsenek ezek a modulok repókban? Hogy van ez?

Kipróbáltam és érdekes a gjuhasz féle teamwiewer (pulihoz) nem indul a xenial alatt, ugyanaz a hibaüzenet ami volt korábban. Mindegy ezt csak "érdekesség képpen" írom. Ezt könnyen ki tudtam próbálni.

Most lehet hogy mégis majd a bionic marad mert az tűnik a leggyorsabb megoldásnak.
Megpróbálok egy frugal telepítést, meglátom...

NTamas
Hozzászólások: 1551
Csatlakozott: 2014.06.19. 13:36

Re: TeamViewer Linux-ra (portable csomag-benne a Wine-vel)

Hozzászólás Szerző: NTamas » 2019.02.28. 22:49

luighy írta:
2019.02.28. 21:48
Ha jó értem a csomagkezelő alapból képes a megfelelő függőségek feloldására gondolom ennek az a feltétele hogy valami repóból elérhető legyen a csomag (meg a függőségei), vagy van még egyéb dolog is esetleg? A leírtak alapján logikus lenne a csomagkezelő használata, szóval miért nincsenek ezek a modulok repókban?
Az egyes puppy verziókba a csomagkezelőben a verzióhoz passzoló alaptárolók vannak elsődlegesen kijelölve, ezekben sok minden van, de volt már olyan, hogy egyes kisebb függőségi fájlok mégsem kerültek bele, illetve a tárolókat karbantartók ezeket valamiért törölték. Ez utóbbi leginább akkor szokott előfordulni, ha a fájllal valami gond van, problémát okozott, és ezért kivették a tárolóból, friss verzió meg még nem lett betéve helyette.
Ilyenkor máshonnan, más tárolóból, vagy a netről kell ezen fájlokat beszerezni.
De olyan is előfordult már, hogy egy program telepítésekor valamiért -nem tudni miért- a csomagkezelő nem találta meg a letölteni kívánt program egy kellő függőséget, ugyanakkor, ha a függőségfájl nevét ezután kézzel beírtad a csomagkezelőbe, úgy már érdekes mód mégis megtalálta, és lehozta azt a függőségi fájlt, ez többször előfordult már velem.
Mivel leginkább deb fájlokban vannak a tárolókban a programok, néha pet formátumban is, ezért én a deb és a pet formában leszedet programot ki szoktam bontani, és a deb fájlban benne lévő control nevű szöveges fájlban nézek utána a kellő függőségeknek, ebben a fájlban eddig még mindig be voltak jegyezve a kellő függőségi fájlok nevei, így azok keresése a név birtokában már viszonylag könnyen ment. Sajnos a pet csomagokban nem minden esetben közlik a program függőség igényét, így ott ezeket kideríteni már kissé nehezeb feladat.
Nálad azért volt gond, mert a TeamViewert nem a puppy tárolójából szedted le, hanem a program weboldaláról, és mint ilyenkor megszokott, ekkor figyelni kell a program weboldalán megadott külön függőségi listát, és azon fájlokat a puppy csomagkezelőjéből,(ha ott elérhetőek egyáltalán) vagy más, Ubuntus tárolóból kell pótolni.
Továbbá, a program fő függőségén kívül még fellépett nálad egyéb függőségi igény is, ez pedig azzal magyarázható, hogy az említett puppy verzió -meg a többi is- nem egy Ubuntu méretű program, így ezekben sok olyan fájl nincs is meg, ami pl. az Ubuntu-ban alapból benne van.

luighy
Hozzászólások: 39
Csatlakozott: 2018.05.02. 11:24

Re: TeamViewer Linux-ra (portable csomag-benne a Wine-vel)

Hozzászólás Szerző: luighy » 2019.03.10. 21:01

Sziasztok,
még mindig a Teamviewerrel bajlódok...

Gondoltam felteszem a
Xenialpup64_32_HU_Big_K4.6.3.iso 2018-12-16 1.2 GB
https://sourceforge.net/projects/puppys ... o/download

Ebben van wine előtelepítve és majd az alá teszem a Teamviewer-t.
(A bionicpuppy -val is próbálkoztam de nem tudtam a teamviewert működőképes állapotba hozni. Pl. a natív teamviewer elindult de nem csatlakozott a távoli gépre, míg a mobilomról ugyanazon a hálózaton tudtam csatlakozni dehát a mobilon -érintő képernyőn- csinálni valamit a távoli gépen az nem egy egyszerű dolog. A wines teamviewer telepítés végigment de az meg indításkor hibával elszállt.)

Gondoltam akkor másik puppettal próbálkozok.

Tehát a Xenialpup64_32_HU_Big_K4.6.3.iso frugalban megy, nem tettem vele gyakorlatilag semmit csak a winfile akartam indítani.
Ezt a hibát dobta.
Tud valaki tippet adni mi a baj? :mrgreen:
(Akinek van működőképes konfigurációja gondolok a teamviewerra ami frugalban mehet hasznos lenne mert azzal esetleg tudnék dolgozni.)

root# wine
Usage: wine PROGRAM [ARGUMENTS...] Run the specified program
wine --help Display this help and exit
wine --version Output version information and exit
root# wine --version
wine-3.18
root# wine winfile
0025:err:hid:PNP_AddDevice Cannot parse Report Descriptor
0025:err:plugplay:handle_bus_relations AddDevice failed for driver L"WineHID"
0025:err:ntoskrnl:IoCreateDriver failed to insert driver L"\\Driver\\WineHID" in tree
0025:err:hid:PNP_AddDevice Cannot parse Report Descriptor
0025:err:plugplay:handle_bus_relations AddDevice failed for driver L"WineHID"
0025:err:ntoskrnl:IoCreateDriver failed to insert driver L"\\Driver\\WineHID" in tree
0025:err:hid:PNP_AddDevice Cannot parse Report Descriptor
0025:err:plugplay:handle_bus_relations AddDevice failed for driver L"WineHID"
0025:err:ntoskrnl:IoCreateDriver failed to insert driver L"\\Driver\\WineHID" in tree
0025:err:hid:PNP_AddDevice Cannot parse Report Descriptor
0025:err:plugplay:handle_bus_relations AddDevice failed for driver L"WineHID"
0025:err:ntoskrnl:IoCreateDriver failed to insert driver L"\\Driver\\WineHID" in tree
0025:err:hid:PNP_AddDevice Cannot parse Report Descriptor
0025:err:plugplay:handle_bus_relations AddDevice failed for driver L"WineHID"
0025:err:ntoskrnl:IoCreateDriver failed to insert driver L"\\Driver\\WineHID" in tree
0025:err:plugplay:try_add_device Building report descriptor failed, removing device
0025:err:ntoskrnl:IoCreateDriver failed to insert driver L"\\Driver\\WineHID" in tree
0025:err:hid:PNP_AddDevice Cannot parse Report Descriptor
0025:err:plugplay:handle_bus_relations AddDevice failed for driver L"WineHID"
0025:err:ntoskrnl:IoCreateDriver failed to insert driver L"\\Driver\\WineHID" in tree
0025:err:hid:PNP_AddDevice Cannot parse Report Descriptor
0025:err:plugplay:handle_bus_relations AddDevice failed for driver L"WineHID"
0025:err:ntoskrnl:IoCreateDriver failed to insert driver L"\\Driver\\WineHID" in tree
0025:err:hid:PNP_AddDevice Cannot parse Report Descriptor
0025:err:plugplay:handle_bus_relations AddDevice failed for driver L"WineHID"
0025:err:ntoskrnl:IoCreateDriver failed to insert driver L"\\Driver\\WineHID" in tree
0025:err:ntoskrnl:IoCreateDriver failed to insert driver L"\\Driver\\WineHID" in tree
0025:err:hid:PNP_AddDevice Cannot parse Report Descriptor
0025:err:plugplay:handle_bus_relations AddDevice failed for driver L"WineHID"
0025:err:ntoskrnl:IoCreateDriver failed to insert driver L"\\Driver\\WineHID" in tree
0025:err:hid:parse_descriptor Unknown (bTag: 0x0, bType: 0x0)
0025:err:hid:parse_descriptor Unknown (bTag: 0x0, bType: 0x0)
0025:err:hid:parse_descriptor Unknown (bTag: 0xe, bType: 0x0)
0025:err:hid:parse_descriptor Unknown (bTag: 0x0, bType: 0x3)
0025:err:hid:parse_descriptor Unknown (bTag: 0x0, bType: 0x0)
0025:err:hid:parse_descriptor Unknown (bTag: 0x0, bType: 0x0)
0025:err:hid:parse_descriptor Unknown (bTag: 0x0, bType: 0x0)
0025:err:hid:parse_descriptor Unknown (bTag: 0x0, bType: 0x0)
0025:err:hid:parse_descriptor Unknown (bTag: 0x0, bType: 0x0)
0025:err:hid:parse_descriptor Unknown (bTag: 0x0, bType: 0x0)
0025:err:hid:parse_descriptor Unknown (bTag: 0x1, bType: 0x0)
0025:err:hid:parse_descriptor Unknown (bTag: 0x0, bType: 0x0)
0025:err:hid:parse_descriptor Unknown (bTag: 0x0, bType: 0x0)
0025:err:hid:parse_descriptor Unknown (bTag: 0x0, bType: 0x0)
0025:err:hid:parse_descriptor Unknown (bTag: 0x0, bType: 0x0)
0025:err:plugplay:try_add_device Building report descriptor failed, removing device
0025:err:ntoskrnl:IoCreateDriver failed to insert driver L"\\Driver\\WineHID" in tree
0025:err:hid:PNP_AddDevice Cannot parse Report Descriptor
0025:err:plugplay:handle_bus_relations AddDevice failed for driver L"WineHID"
0025:err:plugplay:try_add_device Building report descriptor failed, removing device
wine: cannot find L"C:\\windows\\system32\\winfile.exe"
Screenshot(1).png
Screenshot(1).png (1.18 MiB) Megtekintve 174 alkalommal

Válasz küldése

Vissza: “Internet”