Puppy 383

Pupletek, Új puppy változatok, veruiók, ISO fájlok,
NTamas
Hozzászólások: 1621
Csatlakozott: 2014.06.19. 13:36

Re: Puppy 383

Hozzászólás Szerző: NTamas » 2019.10.04. 13:05

Szia!
Az SMTube programnak eleve vannak függőségei, ezek a használt oprendszertől is függenek.(értsd , hogy a kellő függőségekből maga a rendszer mit tartalmaz alapból, és mit kell még hozzá beszerezni)

Az SMTube-SMPlayer párost a Murga fórumon a Norgo nick nevü felhasználó pátyolgatja, volt már rá hivatkozás a mi fórumunkban is.
A régebbi puppy rendszerekhez való függőségi lista ezen a weboldalon olvasható:
http://murga-linux.com/puppy/viewtopic. ... 200#890200

qt-4.8.6
libqtwebkit-4.9.4
gstreamer0.10-plugins-base_0.10.36
libgstreamer-plugins-base0.10-0_0.10.36
libgstreamer0.10-0_0.10.36
ca-certificates_20111211
libpng14-14-slackware

Ahogy jöttek az újabb verziójú puppyk, nőttek a rendszerben meglévő elemek verziószámai is, pl. a QT csomagból ma már a QT-5 az alap, így norgó is az újabb verziójú -alkatrészekhez- alakítgatja a programját.
Alapvetően két vonal van:
a még élő QT-4 es
és a QT-5-ös vonal.

Továbbá az SMPlayerből van shared és statikus verzió, utóbbi azt jelenti, hogy pl. egy statikus SMPlayer csomag beépítve tartalmazza a Qt és a többi szükséges lib függőségeket, míg a shared nem, ez a shared megoldás a rendszerbe beépített függőségek meglétére alapozza a működését.

A jelzett modernizált puppy 3831 verzió már egy modern csomag, ami, ha jól tudom, már a QT5-ös verzióra épült, így neked a shared verziók közül a QT5-ös csomagok lesznek a megfelelőek.

Pl. az SMtube version 19.6.0 - smtube-19.6.0-qt5-i686.pet (oprendszerbe telepített,shared qt-5.6.1 + a kellő függőségi libek megléte kell hozzá)
SMplayer version 19.5.0:(oprendszerbe telepített,shared qt-5.6.1 + a kellő függőségi libek megléte kell hozzá)
smplayer-19.5.0-qt5-i686.pet
smplayer-19.5.0-qt5-x86_64.pet

A statikus verziók közül meg ez lehet jó neked:
smplayer-19.5.0-s-i686.pet 13.429 k (a csomagnézben szereplő -s- megkülönböztetés jelzi a statikus csomagot)
https://smokey01.com/norgo/slacko/570/570.php

Ugyanez vonatkozik a Kodi-ra is, nem minden Kodi csomag tartalmazza alapból a működéséhez kellő függőségeket, evileg az sfs kialakítású Kodi csomagoknak tartalmaznia kellene de én pl. már találkoztam olyan Kodi.sfs csomaggal is, amit hiába csatoltam fel, függőségi hiányra panaszkodva nem indult el.
------------------------------------------------------------------------------------------------------------------------------
A mostani fórumos puppy építő tagoknak van egy külön tárolóhelyük, onnan is leszedhetőek a kellő dolgok.
https://sourceforge.net/projects/puppys ... es/SmTube/
Eleve mindkét csomag ún. shared verzió, tehát a programokhoz kellő függőségeket a rendszernek eleve tartalmaznia kell!
https://sourceforge.net/projects/puppys ... /SmPlayer/
Itt vannak vegyesen shared és statikus csomagok is, sajnos a fájlnevek meg lettek variálva, -miért is?- és a statikus csomagokra maximum a fájlok mérete utalhat! Továbbá az itt elérhető verziókban csak kettőnek a nevében szerepel a QT5 megkülönböztetés, így csak reménykedni lehet, hogy a többi csomag a QT4.8.6 csomagot is tartalmazza beépítve.
(ha már felrakunk valamit egy tárolóra, akkor miért nem a jól bevált, megszokott névvel tesszük azt, és miért kell a csomagneveket megvariálni?)

Keszi86
Hozzászólások: 14
Csatlakozott: 2019.09.22. 10:38

Re: Puppy 383

Hozzászólás Szerző: Keszi86 » 2019.10.04. 14:21

Na egyedül ez a verzió indult el de nem működik. :/ Érdekes dolog még, hogy felraktam a Libre Office 4.6.1.2 hu verziót, nincs menü bejegyzés X reboot után sem.
Csatolmányok
IMG_20191004_144916.jpg
IMG_20191004_144916.jpg (1.55 MiB) Megtekintve 323 alkalommal

janugsa
Hozzászólások: 419
Csatlakozott: 2014.06.28. 00:17

Re: Puppy 383

Hozzászólás Szerző: janugsa » 2019.10.04. 15:03

Ha xp tömörítésű pet fájlt akarsz precise puppyra telepíteni ez kell először:
http://www.murga-linux.com/puppy/viewto ... fca53e2494

Innen az smtube-19.6.0 és az smplayer-19.5.0-i686 kell :
https://smokey01.com/norgo/slacko/630/630.php

Mpv player is kell:
https://drive.google.com/file/d/1kipePC ... sp=sharing

Kell Qt-4.8........ valamelyik sfs ( én 4.8.2 vel próbáltam)
https://drive.google.com/file/d/1T0jA-K ... sp=sharing

Fontos: smplayert át kell állítani mpv motorra ( a képen)
Képenyő kép.jpg
Képenyő kép.jpg (145.97 KiB) Megtekintve 318 alkalommal

Keszi86
Hozzászólások: 14
Csatlakozott: 2019.09.22. 10:38

Re: Puppy 383

Hozzászólás Szerző: Keszi86 » 2019.10.04. 16:13

Köszönöm szépen, kipróbálom! :)

NTamas
Hozzászólások: 1621
Csatlakozott: 2014.06.19. 13:36

Re: Puppy 383

Hozzászólás Szerző: NTamas » 2019.10.04. 18:51

janugsa írta:
2019.10.04. 15:03
Kell Qt-4.8........ valamelyik sfs ( én 4.8.2 vel próbáltam)
Ne vidd már be az erdőbe, eleve talán először tisztázni kéne, milyen QT rendszer van abban a puppy3861 oprendszerben, alapból!
Én úgy emlékszem, hogy QT5-el készült el ez az új puppy, abba meg minek egy régebbi QT4-es verziót tenni? - tessék már megmondani?
Eleve azt kellene kideríteni, és ha netán egy QT4-el készült el a puppy, akkor az általam az előbb fent, és a teáltalad is belinkelt ugyanazon Murga fórumos weboldalról kell a szükséges fájlokat leszedni, ha QT-5-el készült az a puppy, akkor meg a QT-5ős verziókat kell használni.
Az SMTube-ból van mindkét fajta, QT4-es és QT5-ös shared verzió, -a QT5-ös fájlneve fentebb olvasható- az SMPlayer-ből shared csomag szintén van mindkét QT-hez, egyedül a statikus SMPlayer-ből van csak QT4-es verzió, ott van fenn a Murga-s weboldalon, azt kell használni. Úgy tudom, hogy Norgó még nem csinált a legújabb SMPlayerből statikus QT5-ös csomagot, de lehet, rosszul tudom, a honlapján meg kell nézni.
Mindkét QT verziójú shared SMTube-hoz kellenek függőségek, ezeket az előbb már jeleztem, de újra leírom:

libqtwebkit-4.9.4-i686.pet(8.2MB)
gstreamer0.10-plugins-base_0.10.36
libgstreamer-plugins-base0.10-0_0.10.36
libgstreamer0.10-0_0.10.36

kelleni fog még két lib fájl is:
libssl és az openssl,
ebből valamelyik tartalmazza a libcrypto fájlt is, ez a youtube miatt kell.(ebből a két fájlból az oprendszeredhez illő verziót kell beszerezni a csomagkezelőből.)

kelleni fognak a certificat fájlok is:
ca-certificates_20140223_all.pet
ca-certificates-2015.04.26.pet
ca-certificates-2016-11-30.pet
ca-certificates-2019-03-08.pet

Ha mégis QT4-el készült a puppy, -márpedig a kérdező első laptopos képén látható, hogy ebben a puppy verzióban alapból egy QT 4.8.5-ös verziójú, valszeg a teljes csomag van beépítve- - akkor elég hozzá a belinkelt Murga weboldalról letölthető qt-4.8.6-i686.pet(14MB)(ez nem teljes QT-4.8.6 csomag csak az van bennr, ami feltétlen kell a shared típusú SMTube és SMPlayerhez)

(Az eredeti, teljes Qt4.8.2-i686.pet és/vagy sfs csomag egyenként 45MB méretű!)
(A QT5-ös csomag meg ettől jóval nagyobb méretűek, még az abból készült sfs is.)

Én a Precise puppykhoz QT4-et használok, -alapesetben a teljes QT-4.8.2.pet van telepítve(45MB)- és az előbb leírt függőségi fájlok, és a kiegészítő 14MB-os qt-4.8.6-i686.pet csomag feltelepítése után simán működik nálam az SMTube progi.
Kép

ticoo1
Hozzászólások: 492
Csatlakozott: 2014.10.21. 08:58

Re: Puppy 383

Hozzászólás Szerző: ticoo1 » 2019.10.07. 16:02

Kedves " Keszi86 "!

Kicseréltem a Grub4Dos-t, mert sajnos ami eredetileg benne volt az nem jó. Nem írja be rendesen a menu.lst-ben a frugálba telepített (könyvtárba másolt) puppy elérési útját (sajnos sok puppy-ban van így). Most már rendesen megcsinál mindent.

Mivel SMTube-t akarsz használni, ezért beletettem, de én VLC-t javaslok hozzá, illetve mplayer-t (beépítve mindkettő), mert az SMPlayer-rel, ha "előrébb tekersz", akkor esetenként meghó.... :mrgreen: Egyszerre akár több videó is elindítható, mint a képen, 3 lejátszó egyszerre, vegyesen vlc-mplayer egy p4-1.7-es proci-val és 1 GB ram-mal, de van swap (2 GB), a puppy CD-ről fut.

Természetesen az SMPlayer-t is telepítheted.(smplayer...pet , esetleg mpv amit fentebb írtak, a többi már benne van.)

3831-Pmoon-27.9.2-v2.iso a neve.

Itt van: https://sourceforge.net/projects/puppys ... p-3.8.3.1/

Képek:
Képenyő kép.jpg
Képenyő kép.jpg (85.05 KiB) Megtekintve 255 alkalommal
smtube.jpg
smtube.jpg (71.17 KiB) Megtekintve 255 alkalommal

Keszi86
Hozzászólások: 14
Csatlakozott: 2019.09.22. 10:38

Re: Puppy 383

Hozzászólás Szerző: Keszi86 » 2019.10.10. 13:44

Nem is tudom mit mondjak ticoo1. :) Nagyon nagyon szépen köszönöm. :D Így ismét kipróbálom majd az mx linux grub customizerjében konfigurálva frugalként.

Keszi86
Hozzászólások: 14
Csatlakozott: 2019.09.22. 10:38

Re: Puppy 383

Hozzászólás Szerző: Keszi86 » 2019.10.11. 22:52

Na ma nyílt lehetőségem a próbára, de sajnos továbbra sem működik frugal módban mx linux alatt. :(

gyalu
Hozzászólások: 3
Csatlakozott: 2019.10.12. 10:12

Re: Puppy 383

Hozzászólás Szerző: gyalu » 2019.10.12. 10:14

Segítséget kérek, mit nem csinálok jól?
Letöltöttem a „HuBi-pup32-9_Firefox_vlc_K-3.14.56_NoPae_t3.iso” -t abban a reményben, hogy az öregecske Lifebookba élete leheljek egyszerűbb feladatokra alkalmassá téve.
A CD-re kiírt anyag szépen bebootol és fut rendben a Live verzió. Mivel a régi gép optikai olvasója már halott, ezért a jelenleg is használt Packard Bell EasyNote TK gépemen a Live verzióval próbáltam USB-s boot eszközt készíteni. Hat különböző pendrive, fat16, fat 32, ext3, ext4 mindegyikkel végig próbáltam, mind bootable beállítással. Eredmény ugyanaz, partíció elszáll és semmi nem ismeri fel az újrapartícionálásig. Természetesen, nem is bootol. Miután végig próbáltam az összes variációt, azaz a pendrive-okat különbözőképpen formázva és nem jutottam eredményre, kínomban kölcsönkértem egy külső DVD olvasót és egyenesen a Lifbookra indítottam a Live verziót. Elindult, tett mindent amit elvártam, a sebessége is elfogadhatónak tűnt, így a hdd-re telepítést választottam, feladva az USB-s ügyet. Az installálás hibaüzenet nélkül lefutott, ám azóta a vinyót nem látja a gép. Remélem, egy újra particionálás után az is menni fog, mint a pendrive-ok.
A kérdés tehát, mit csinálok rosszul?

NTamas
Hozzászólások: 1621
Csatlakozott: 2014.06.19. 13:36

Re: Puppy 383

Hozzászólás Szerző: NTamas » 2019.10.12. 11:16

Annyiszor kértük már,
ha segítséget kérsz a fórumban a minimum az, hogy halálpontosan megadod a használt eszköz típusát, típusszámát a hozzátartozó betűkkel egyetemben.
Mert így:
... az öregecske Lifebook ...
ebből nem derül ki semmi, annyi igen, hogy valószínűleg egy IDE merevlemez lehet abban a laptopban.
Mielőtt bármit is csinálsz, mivel most a külső dvd olvasóról fut a Puppy, ezért a futó Live Puppyban indítsd el a Rendszer-gparted alkalmazást és nézd meg, és ha sikerül, fotózd le nekünk, mit mutat a program a laptopban lévő merevlemezről.
... így a hdd-re telepítést választottam, ...
Milyen módon, a teljes merevlemezre telepítettél, vagy csak Frugall módban, mert nem mindegy az sem.

Válasz küldése

Vissza: “Pupletek”