Smplayer

Audió és videó vágó, szerkesztő, lejátszó programok, kodekek
janugsa
Hozzászólások: 403
Csatlakozott: 2014.06.28. 00:17

Re: Smplayer

Hozzászólás Szerző: janugsa » 2019.06.23. 10:18

Sourceforge smtube 19.6.0 petek nem jók, nem lehet telepíteni őket.
Csak ha kibontom, belelépek és az ott levő mappából petet készítek.
Vagy talán ha a Slacko630, Slacko700 nevet átnevezéssel kitörlöm a petből

willy36
Hozzászólások: 179
Csatlakozott: 2017.05.16. 18:43

Re: Smplayer

Hozzászólás Szerző: willy36 » 2019.06.24. 14:53

Köszi az infót !
Akkor törlöm az smplayereket. Sajnálom, hogy hibásan sikerült letöltenem, de a klasszikusan mindig megfelelő helyekről szedtem le, ahonnan a többit is előtte.

NTamas
Hozzászólások: 1590
Csatlakozott: 2014.06.19. 13:36

Re: Smplayer

Hozzászólás Szerző: NTamas » 2019.06.24. 15:54

Nem kell törölni őket, az újabb, -a precise-nél fissebb- puppy verziók simán telepítik őket.
A gond a régi verziós xz tömörítőkkel van, ha ezt frissítik, akkor a régi puppy verziókban is működnek az újab tömörítési móddal készült pet-ek.
Vagy ha nem frissítik a tömörítőt, akkor marad a pet-kibontom-újragyártom módszer, ahogy ezt már ebben a topicban 2018-ban is leírtam, olvass, lapozz vissza egy oldalt.
Tehát elég csak egy szöveges fájlt elhelyezni az smplayer-smtube-k mellé, amiben röviden vázolod a lényeget.
(amúgy a murga-s smplayer.smtube oldalom már régóta -kb. a 14-es verziótól- jelzik a gzip és xz tömörítésű csomagokat, igaz, az utóbbi időben erről már leszoktak, hiszen már az újabb tömörítéssel készült pet csomagok is kibonthatóak a frissítéssel, illetve az újabb puppy verziókkal)

NTamas
Hozzászólások: 1590
Csatlakozott: 2014.06.19. 13:36

Re: Smplayer

Hozzászólás Szerző: NTamas » 2019.06.24. 18:09

Kép

Kép

Sajnos, a Precise alapú puppy verziókon nem fog működni ez az újabb tömörítési xz formula, ugyanis az ehhez szükséges függőségek: xz-utils (5.2.2-1.2) és az liblzma5 (5.2.2-1.2) futásához már a libc6 (>= 2.17) file kell, és a Precise puppykban meg csak a libc6 (2.15) verziójú fájl van, így ezen puppykra max. csak ezen fájlok tehetőek fel:
(innen tölthetőek:https://debian.ues.edu.sv/debian/pool/main/x/xz-utils/)
liblzma5_5.1.1alpha+20120614-2+b3_i386.deb
xz-utils_5.1.1alpha+20120614-2+b3_i386.deb
Ezekhez még megfelelő a Precise puppykban lévő 2.15-ös verziójú libc6.
Ha még ehhez feltesszük ezt a pet csomagot is:
xzpet_installpkg-20160911-precise.pet
(http://www.murga-linux.com/puppy/viewtopic.php?t=108173)
akkor a közepes tömörítésű xz-s pet csomagokat már tudjuk telepíteni, de a modernebb, lásd az SMplayer 19.5.0 / SMtube 19.6.0 pet csomagokat már nem! És nem a pet csomagok a hibásak!!! Hanem a Precise puppy verziónk a régi! Sajnos!
Az újabb, 2.17-2.19-es libc6-ot használó modernebb puppy verziókkal ilyen gondunk már nem lesz, azokra simán feltehető a fentebb már beírt verziójú, az újabb tömörítést biztosító -xz-utils (5.2.2-1.2) és az liblzma5 (5.2.2-1.2)- fájlok.
Tehát a régi Precise puppyk alatt már csak egyetlen mód maradt, az új, xz-s tömörítésű pet csomagokat előbb ki kell bontani, majd a kibontott könyvtárból a rendszerünkben lévő tömörítő fájlokat használva új pet csomagot kell gyártani, úgy ahogy ezt már a 2018-as hozzászólásban is jeleztem.
(és ott sem a pet csomagokkal volt a baj!!!- hiába adott hibaüzi képet a pet telepítő!)
A telepítős pet csomagok eleve nem lehetnek rosszak, hibásak, mert ha kibontod őket, és a kibontott könyvtárból új pet telepítőt gyártasz, azt simán telepítheted. Ha a csomag eleve hibás lenne, a kibontott, és újragyártott pet-et sem tudnád telepíteni! De tudod....ergo marad a régi puppy verziókon a kibontom-újragyártom módszer.
(Persze a Murga fórumon a Morgó gondolhatna erre, és a Precise puppy verziókhoz való csomagokat eleve a régi metódus szerint csinálhatná! - Bár az is igaz, hogy már nem nagyon csinál Precise -SMplayer_SMtube- verziókat sem.....)

willy36
Hozzászólások: 179
Csatlakozott: 2017.05.16. 18:43

Re: Smplayer

Hozzászólás Szerző: willy36 » 2019.06.24. 20:19

Köszönöm Tamás, akkor ha úgy látjátok visszateszem, csak nem akartam hibásat fent hagyni...
utólagos engedelmeddel, egy text file-ba betettem az elérési linket a leírásodnak, megoldásként

janugsa
Hozzászólások: 403
Csatlakozott: 2014.06.28. 00:17

Re: Smplayer

Hozzászólás Szerző: janugsa » 2019.06.25. 07:28

Sourceforge SMTUBE 19.6.0 petek nem jók, nem lehet telepíteni őket.
Csak ha kibontom, BELELÉPEK és az ott levő mappából petet készítek.

Vagy ha kibontás nélkül a -Slacko630, -Slacko700 nevet átnevezéssel kitörlöm a pet nevéből. Ez a legegyszerűbb.
Az a hiba, hogy a belső mappa neve nem egyezik a pet nevével, a pet nevéhez hozzá lett írva a -Slacko630 illetve a -Slacko700.

Nem precise puppyt használok. Több típust használok.

willy36
Hozzászólások: 179
Csatlakozott: 2017.05.16. 18:43

Re: Smplayer

Hozzászólás Szerző: willy36 » 2019.06.25. 09:06

Kedves janugsa !
Köszönöm a segítségedet, újra frissítettem az SmTube és SmPlayer-eket, mindet újra letöltöttem és feltettem a konkrét oldalakról.
Remélem, hogy így jók lesznek, ha mégsem ,akkor törlöm az egészet, nem szeretnék kényelmetlenséget okozni ezzel másoknak, főleg azoknak, akik nem értenek hozzá annyira.

janugsa
Hozzászólások: 403
Csatlakozott: 2014.06.28. 00:17

Re: Smplayer

Hozzászólás Szerző: janugsa » 2019.06.25. 09:36

Kipróbáltam Dpup Stretch puppyn , smtube és smplayer sikeresen telepítve.
Köszönöm.

NTamas
Hozzászólások: 1590
Csatlakozott: 2014.06.19. 13:36

Re: Smplayer

Hozzászólás Szerző: NTamas » 2019.06.25. 13:29

janugsa írta:
2019.06.25. 07:28

Vagy ha kibontás nélkül a -Slacko630, -Slacko700 nevet átnevezéssel kitörlöm a pet nevéből. Ez a legegyszerűbb.
Az a hiba, hogy a belső mappa neve nem egyezik a pet nevével, a pet nevéhez hozzá lett írva a -Slacko630 illetve a -Slacko700.

Nem precise puppyt használok. Több típust használok.
Kedves Janugsa.
Innentől kicsit off-lesz, meg kissé hosszú is lesz, de az idézetben általad leírtak nem igazán fedik a valóságot.
Legalább is az én tapasztalásom ez ügyben teljesen más!

A norgo által készített Smplayer és Smtube pet csomagok nevében nem szerepel a Slackware megnevezés!
smplayer-19.1.0-qt5-i686.pet
smplayer-19.5.0-qt5-i686.pet
smtube-19.6.0-qt5-i686.pet
smplayer-19.1.0-qt5-s-i686.pet
smplayer-19.5.0-i686.pet
smtube-19.6.0-i686.pet
És a kibontott csomagok könyvtárneveiben sem szerepel!
A fentebb felsorolt pet csomagokban sem a pet nevében, sem a kibontott könyvtárnévben nincsen Slackware megnevezés!

Egyetlen esetben van egy -s- név a pet csomagban, ebben: smplayer-19.1.0-qt5-s-i686.pet, amit ha kibontasz, a kibontott könyvtárnévben is ott van az -s- megnevezés. smplayer-19.1.0-qt5-s-i686
Kép


Mivel én csak qt486-os, és a Precise-n futó i686-os pet csomagokat tudom használni, egy gépem maradt már csak, és ez nem a legfickósabb masina, így az ezen futó három Precise puppyhoz is ezeket tudom csak használni, és ezeket néztem is meg.
Innen szedtem le a kísérlet alanyait.
Kép
Kép
Ebben a formában nem telepíthető fel egyik pet csomag sem hibaüzit dob a telepítő.
A pet csomagokat kibontva, és azokból a rendszer által új pet csomagokat készítve viszont már rendben telepíthetőek.
A kibontáskor jól látszik, hogy a pet csomagok könyvtárneveiben nincsen oprendszer -Slackware- név.
Kép
Ha pedig a kibontott könyvtárat és az abban lévő pet.specs fájlt megnézzük, látható, hogy a Slackware név nem a pet nevében van, hanem a Kompatibilis oprendszer(disztró) pontban szerepel csak, így semmi köze, befolyása nincsen a pet csomag telepíthetőségére, nem emiatt nem telepíthető ezen eredeti, a webről letöltött pet csomag!
Kép
Kép

Ha pedig a már kibontott könyvtárból magunk készítünk egy saját pet csomagot, ott a pet készítés ablakában is jól látható, hogy a Slackware név csak a Kompatibilis disztró rovatban szerepel, máshol nem.
Kép
Megtehettem volna, hogy kiveszem a Slackware nevet a Kompatibilis rovatból, és a helyére egy Precise-t írok, de a próba kedvéért benne hagytam, és így gyártottam le a saját pet csomagot, lásd az eredményét.
Kép
Kép
Kép
Kép
Természetesen az így legyártott, és a Slackware nevet a Kompatibilis rovatban meghagyó új pet csomag hibátlanul feltelepíthető a Precise puppyra, és simán működőképes!
Itt éppen a Jégvarázs2 előzetesét nézem vele.
Kép

Természetesen ezt végigjátszottam az Smplayer-el is, itt az eredménye. (ugyanaz, mint az Smtube esetében, siker...)
Kép
Kép
Kép
Az így legyártott új Smplayer is simán telepíthető, és működőképes, a Kompatibilis rovatban lévő Slackware név ellenére.(ez is bizonyítja, hogy a kompatibilis rovatba beírt Slackware név nincs befolyással a készítendő pet telepíthetőségére!

Az ilyen módon újragyártott pet csomagokat nemsokára felteszem ide, a csomagot kibontva benne van a két újragyártott, és a Precise alatt(de, szerintem más puppy alatt is) telepíthető pet, illetve a gyártáshoz felhasznált könyvtárak is!
Kép
link kicsit később!
Update.
Letöltő link:
3.tar.gz

Eljátszottam a pet kibontást, és a benne lévők megnézését egy Qt5-ös -általam ezen a puppy rendszeren nem használható- pet csomaggal is, a tapasztalatok megegyeznek a qt4-es verzióknál látottakkal.
Kép

NTamas
Hozzászólások: 1590
Csatlakozott: 2014.06.19. 13:36

Re: Smplayer

Hozzászólás Szerző: NTamas » 2019.06.25. 14:20

Update.
A Murga weboldalról letöltött SMplayer-SMtube pet csomagok kibontását én még ezzel végeztem el.
UExtract v2.7 by SFR'2013
De ettől a verziótól már van frissebb verzió is, és az is működik a Precise-k alatt is.
uextract-3.32.pet

Válasz küldése

Vissza: “Multimédia”