YTFE

Audió és videó vágó, szerkesztő, lejátszó programok, kodekek
janugsa
Adminisztrátor
Hozzászólások: 563
Csatlakozott: 2014.06.28. 00:17

Re: YTFE

Hozzászólás Szerző: janugsa »

TCH
Először is köszönöm hogy készítetted az YTFE-t. Régi, gyenge gépeken nélkülözhetetlen, ha youtube-ot akarunk nézni.
A playlistákat mindig el tudtam indítani, de voltak olyanok ahol 2, néha 3 videó lejátszása után visszatért a playlista 1 számára és így végtelenítve játszotta az első 2-3 számot.
Viszont most nem tudom ezt előidézni. Most jó!!!!! Az 1.13.0 verziókat használom.
Érdekes, hogy az előző hozzászólásomnál is az 1.13.0 verziót használtam és akkor még tapasztaltam a „hibát“.

tch
Hozzászólások: 12
Csatlakozott: 2021.11.30. 17:29

Re: YTFE

Hozzászólás Szerző: tch »

Nincs mit, én örülök, ha valaki használja.

Ilyet én sosem tapasztaltam még playlisteknél, de ilyenkor sokat segít, ha átdobod az emilcímemre (programban bent van), hogy mely playlisteknél jött ez elő. Bár ha ilyen történik, akkor ott a YT kell, hogy visszaadjon hibás listát a 2., 3. elem után. Ez magyarázná azt is, hogy miért volt egyszer jó az 1.13-asban, egyszer meg nem.

Amúgy a másik probléma kapcsán (az ignorált formátumok nem tűnnek el a legördülőből) mondom, hogy kijött az 1.14.0: https://hup.hu/node/177816
És ebben erre is van most már lehetőség, hogy az ignorált formátumok eltűnjenek-e a legördülőből, vagy ne, hogy kézzel még ki lehessen őket választani.

A múltkor a hupon valaki megreklamálta, hogy régi gépen sokat (3-6%) zabál alapjáraton program (https://hup.hu/node/177510#comment-2765317), ezen is próbáltam javítani, remélem most már kevesebbet fog enni.

janugsa
Adminisztrátor
Hozzászólások: 563
Csatlakozott: 2014.06.28. 00:17

Re: YTFE

Hozzászólás Szerző: janugsa »

Tegnap leállt az YTFE, szinte lefagyott tőle a gép.
Emiatt új verzió jelent meg.
https://hup.hu/node/177893
A régi root/.ytfe mappából a a players fájl kivételével mindent töröltem. Lehet hogy nem kellene törölni, inkább beállítom újra.
Az új YTFE-t kicsomagolni, futtathatóvá tenni és elindítani, ha szükséges újra beállítani.

janugsa
Adminisztrátor
Hozzászólások: 563
Csatlakozott: 2014.06.28. 00:17

Re: YTFE

Hozzászólás Szerző: janugsa »

Megjelent az YTFE 1.15.1 verzió. Kis hibajavítások a változás.
https://hup.hu/node/178249
Ahogy én használom nem tapasztaltam változást.

Az YTFE yt böngésző és lejátszó külső médialejátszóval.
Ezáltal gyenge, régi gépeken nagyon jól használható.
Például ha a firefoxal a videó szaggat, helyette ezt használva biztosan nem fog szaggatni. Sőt talán még jobb felbontásban is nézheted.
Van más hasonló, például az SMTube, mely youtube-dl vagy yt-dlp letöltéskezelőt használ
pythonnal. De minél gyengébb a gépünk annál hosszabb lesz a feldolgozási idő.
Az YTFE is tudja youtube-dl és a yt-dlp-t, de mást is választhatunk. A jelet közvetlenül feldolgozva gyorsabban indítja a videókat ( kivéve talán az első videó).
Nem kell telepíteni. A scriptet kicsomagolni, futtathatóvá tenni, és elindítani.
Linuxnál 3 verzió van, i686 gtk2, 64bit gtk2, 64bit qt5. Ez utóbbihoz qt5 és libqt5pas.so.1.2.6 is kell.
http://oscomp.hu/?games/sh/Y

A külső lejátszó mpv , ha ez nincs akkor vlc. Mplayer, smplayer vagy gnome-mplayer is jó, de ezekhez players nevű fájlt kell szerkeszteni (régebben írtam róla).
Például ilyen laptopon használom (22éves) cpu 550MHz celeron III, ram 256MB, oprendszer puppy slacko 5.8.10, lejátszó mplayer és 360p felbontás.

Én ezeket a beállításokat használom gyenge gépen, piros jel a változtatás :
Képenyő kép(3).jpg
Képenyő kép(3).jpg (46.92 KiB) Megtekintve 520 alkalommal
Erősebb gépeken meg ezeket változtathatom (a Screen with, Screen height-------a képernyő megfelelő méretét veszi a határértéknek-----a qt5 verzióban nem működik):
Képenyő kép.jpg
Képenyő kép.jpg (48.36 KiB) Megtekintve 520 alkalommal
A második fülön csak a letöltést változtatom (harmadik fülön nem változtatok):
Képenyő kép(1).jpg
Képenyő kép(1).jpg (61.61 KiB) Megtekintve 520 alkalommal

janugsa
Adminisztrátor
Hozzászólások: 563
Csatlakozott: 2014.06.28. 00:17

Re: YTFE

Hozzászólás Szerző: janugsa »

Pár napja én nem tudom elérni az oscomp.hu-t.
De elérhető kettő YTFE verzió (32bit és 64bit) az alábbi címeken:
http://oscomp.hu/depot/ytfe_direct/1.15 ... ux_i686.xz
http://oscomp.hu/depot/ytfe_direct/1.15 ... _x86_64.xz
Letölteni, kibontani, futtathatóvá tenni.
Én futtathatóvá így teszem:
jobb klikk a fájlra, ott kiválasztom a Tulajdonságokat, ott a Végrehajtás alatt mindhárom kockát kipipálom és Bezár.

Online manual:
http://oscomp.hu/ytfeman/

tch
Hozzászólások: 12
Csatlakozott: 2021.11.30. 17:29

Re: YTFE

Hozzászólás Szerző: tch »

Közben meggyógyult az oscomp és közben lett egy új verzió is, mert a google kinyírta a régi frontendeket az új trutymócipherükkel. Olvastam, hogy Qt5 alatt nem megy a képernyő méreteivel való limitálás, de nekem ment, nem sikerült reprodukálnom a hibát.

Részletek itt: https://hup.hu/node/179030

janugsa
Adminisztrátor
Hozzászólások: 563
Csatlakozott: 2014.06.28. 00:17

Re: YTFE

Hozzászólás Szerző: janugsa »

Kipróbáltam YTFE v1.16.0 verziót több puppyn.
Azon a puppyn nem szaggatott a youtube, melyen megtalálta a nodejs fájlt.
Nincs a puppykban node. Gondoltam ez kell beléjük.
Két puppyba (32 és 64 bitesek) beleraktam, azután mindkettő jó lett egy kis szimlinkezés után.

Így cselekedtem:
Az YTFE itt található:
http://oscomp.hu/?games/sh/Y
Node 32 bit 4 MB :
https://nodejs.org/dist/v0.10.3/node-v0 ... x86.tar.gz
Node 64 bit 6MB:
https://nodejs.org/dist/v0.12.0/node-v0 ... x64.tar.gz
Ezek régiek, de kisebb méret miatt ide jó.
Letöltöttem, kibontottam, megkerestem benne a node fájlt, szimlinket készítettem hozzá
nodejs névvel. A mappából pet fájlt készítettem. Telepítettem az elkészített fájlt a puppy-ba.

Ha már futtattam az ytfe programot, akkor a root mappában lévő .ytfe rejtett mappa tartalmát töröltem - ha van benne players fájl, akkor azt ne -, töröltem a tmp mappában levő ytfe fájlt.
Elindítottam az ytfe programot, beállítottam.

Szimlinket így készítünk: jobb egérgombbal katt a node fájlra, ott a linkelést választjuk,
kijavítjuk nodejs-re. Szimlink.

tch
Hozzászólások: 12
Csatlakozott: 2021.11.30. 17:29

Re: YTFE

Hozzászólás Szerző: tch »

Közben a kugli újított, szóval én is újítottam: https://hup.hu/node/179149
Megkerültem a QuickJS hiányosságát, szóval most már azzal is megy, ami egy régi gépen jó, mert egy nagyságrenddel kevésbé bloatabb, mint a Node.js.

Qt5 alatt vannak még bajok a képernyőmérettel? Hanyas Qt5 lib van fent?

willy36
Hozzászólások: 212
Csatlakozott: 2017.05.16. 18:43

Re: YTFE

Hozzászólás Szerző: willy36 »

Szia !
Köszönjük szépen a nép nevében, ilyenek mindig jól jönnek :)

tch
Hozzászólások: 12
Csatlakozott: 2021.11.30. 17:29

Re: YTFE

Hozzászólás Szerző: tch »

Nincs mit. Viszont már az 1.17.0 release-e után kibukott még egy "bug" (igazából a kugli szórakozott), amit most javítottam; lehet tölteni az 1.17.1-et.

Válasz küldése

Vissza: “Multimédia”