Pr5.7.1JPRetroMini kiadások, most egy '18 szept. magyar

Pupletek, Új puppy változatok, veruiók, ISO fájlok,
Avatar
csipesz
Hozzászólások: 574
Csatlakozott: 2014.06.24. 11:02
Tartózkodási hely: Isaszeg

Re: 3 féle Pr5.7.1JPRetro mini kiadás - +egy nagyobb...

Hozzászólás Szerző: csipesz » 2017.07.27. 20:57

meglesem hamarosan, tetszik a tálcaikon.

Avatar
KuLuSz
Hozzászólások: 411
Csatlakozott: 2014.06.17. 21:19

Re: 2 féle Pr5.7.1JPRetro mini kiadás - +egy nagyobb...

Hozzászólás Szerző: KuLuSz » 2017.11.07. 11:22

csipesz írta:
2017.05.20. 14:06
szeretném megkérdezni Kulusz kollégát, mivel õ már ügyködött ilyesmikben: nem tudna-e úgy módosítani egy remasterpup2 (GUI-s) szkriptet, hogy az úgy végezze a dolgát, hogy max tömörítési rátával dolgozzon?
nemtom 6 hónap távlatából jelent-e valamit , de megnyitottam a szkriptet, amiben ennyi áll a tömörítésről :
#120512 01micko: set compression
COMP=""
mksquashfs -help &>/tmp/mk #refuses to grep from stdout
grep 'xz' /tmp/mk &>/dev/null
[ "$?" = "0" ] && COMP="-comp xz"
ARCH="`uname -m`"
[ "$(uname -m|grep ^i)" ] && ARCH="`uname -m|cut -c3,4`"
case "$ARCH" in
86)AOPT="-Xbcj x86" ;;
*)AOPT="" ;; #todo add other arches
esac
rm /tmp/mk
COPTIONS=""${COMP}" "${AOPT}""
#end set compression
ez első körben annyit néz meg hogy a "mksquashfs" parancs képes-e tömöríteni egyátalán xz -ben, második lépésben pedig azt vizsgálja hogy a kernel milyen architecturán fut , ez azért kell a szkriptnek mer a mksquashfs ugy tömöríti a cuccot hogy megfelelő legyen az "x86" -os rendszerhez.

A mksquashfs parancsban pedig ilyen dolgokat lehet beállítani :
Miscellaneous options:
-root-owned alternative name for -all-root
-noInodeCompression alternative name for -noI
-noDataCompression alternative name for -noD
-noFragmentCompression alternative name for -noF
-noXattrCompression alternative name for -noX

Compressors available and compressor specific options:
gzip (no options) (default)
xz
-Xbcj filter1,filter2,...,filterN
Compress using filter1,filter2,...,filterN in turn
(in addition to no filter), and choose the best compression.
Available filters: x86, arm, armthumb, powerpc, sparc, ia64
-Xdict-size <dict-size>
Use <dict-size> as the XZ dictionary size. The dictionary size
can be specified as a percentage of the block size, or as an
absolute value. The dictionary size must be less than or equal
to the block size and 8192 bytes or larger. It must also be
storable in the xz header as either 2^n or as 2^n+2^(n+1).
Example dict-sizes are 75%, 50%, 37.5%, 25%, or 32K, 16K, 8K
etc.
Ez pedig ha jól fordítom akkor az architetura megadásával , szűrők nélkül tömörít a legjobban , tehát ez a max tömörítés, amit a szkript csinál "elvileg".
-<(].K.u.L.u.S.z.[)>-
---------------------------------------
Általában megtalálható vagyok az Angol irc csevegőn vagy a Discordon KuLuSz néven.

Avatar
csipesz
Hozzászólások: 574
Csatlakozott: 2014.06.24. 11:02
Tartózkodási hely: Isaszeg

Re: 3 féle Pr5.7.1JPRetro mini kiadás - +egy nagyobb...

Hozzászólás Szerző: csipesz » 2017.12.17. 23:10

köszi a válaszod - volt egy ilyen sejtésem nekem is...

Avatar
csipesz
Hozzászólások: 574
Csatlakozott: 2014.06.24. 11:02
Tartózkodási hely: Isaszeg

Re: Pr5.7.1JPRetroMini kiadások, most egy '18 szept. magyar

Hozzászólás Szerző: csipesz » 2018.10.03. 13:30

Hát csak nem nyughattam, ezt a cuccot is előkaptam egy kis revízióra, és született egy nagyon elvetemült, magyarul induló, a korábbi palemoon helyett Seamonkey 2.20-assal, openbox ablakkezelő helyett lwm ablakkezelővel bíró, 125 Mb-os precízretró(JP) puppy. - Mért pont a Seamonkey 2.20? - Mert elindul egy Pentium 3-ason is, ugyanakkor egyelőre, míg a gugli meg a jutúb ki nem talál megint valami "forradalmit" a kompatibilitásnak a legújabb böngészőkre való szűkítésére - addig ez lejátssza a jutúb videókat és kezelni képes a guglidrájvot is. A firefox 3.6-ost már kisakkozták a "halálraítéltek" közé, pedig rohadtgyors volt...
Még az lwm ablakkezelőről pár szót: Az asztalon nem tart felbukkanó menüt, tehát csak az lxpanel tálcasarki startmenüjére vagyunk szorulva, de a pinboard-ot nem bántja, az asztalra továbbra is bármit kihúzhatunk; Az ablakok kezelése sem szokványos, de egy-két nap alatt megszoktam: egyetlen gomb az ablak bal felső sarkában, amivel bezárod az ablakot; minimalizálni(tálcára pihenni küldeni) egy jobbegérklikkel az ablak fejlécén tudtok. Maximalizálni - legalábbis egérklikkel nem tudunk - hogy van-e rá billentyűparancs - még nem tájékozódtam... - végül, az lvm ablakkezelő egy saját, piros színű egérkurzor-témával bír, ami személy szerint nekem nagyon bejött...
Letöltőlink:
https://drive.google.com/file/d/1yr2nW0 ... sp=sharing
kinézet(ez az egyetlen kinézet van már csak, a témákon, sőt egyes betűfontokon is spóroltam, hogy az előirányzott 125 megás izó-méret megvalósulhasson):
Screenshot_2018-10-03_11_39_27.jpg
Screenshot_2018-10-03_11_39_27.jpg (34 KiB) Megtekintve 695 alkalommal

keszgreg
Hozzászólások: 26
Csatlakozott: 2019.02.13. 10:37

Re: Pr5.7.1JPRetroMini kiadások, most egy '18 szept. magyar

Hozzászólás Szerző: keszgreg » 2019.03.15. 05:40

Gyors nagyon ez a kis rendszer csak kár hogy a youtube videók nem mennek fullscreenbe.

NTamas
Hozzászólások: 1542
Csatlakozott: 2014.06.19. 13:36

Re: Pr5.7.1JPRetroMini kiadások, most egy '18 szept. magyar

Hozzászólás Szerző: NTamas » 2019.03.15. 13:49

Csak egyet nem értek, abban a HP Compaq Presario CQ56 laptopban egy ATI Mobility Radeon™ HD 4250 videóvezérlő van, ami eleve többet tud, mint a laptop megjelenítőpaneljének a 1366 x 768 felbontása.
Ebből kifolyólag simán meg kell tudnia jelenítenie -még akkor is, ha csak 256MB, a rendszermemóriából elvett memóriát használ az Ati- a youtube-s videókat is teljes képernyőn, már ha a használt/próbált puppy linuxban megfelelő videódriver van hozzá feltelepítve.

ATI Radeon™ HD 4250 Drivers & Support
https://www.amd.com/en/support/graphics ... on-hd-4250
Linux x86-os driver: AMD Catalyst™ 13.1 Proprietary Linux x86 Display Driver
Revision Number: 13.1, File Size: 102 MB Release Date: 1/21/2013
Download: https://www2.ati.com/drivers/legacy/amd ... x86_64.zip
-Automated installer and Display Drivers for Xorg 6.9 to Xserver 1.12 and Kernel version up to 3.4-
(Tehát a csipesz féle 3.2.48-as kernelü Retro Mini-hez simán használható ez a driver.)

keszgreg
Hozzászólások: 26
Csatlakozott: 2019.02.13. 10:37

Re: Pr5.7.1JPRetroMini kiadások, most egy '18 szept. magyar

Hozzászólás Szerző: keszgreg » 2019.03.17. 12:18

Feltelepítettem egy Palemoon 28.2.2 magyart, tökéletesen működik. Youtube is full screenbe, drive is.

Avatar
Asterix
Hozzászólások: 467
Csatlakozott: 2015.07.11. 08:55

Re: Pr5.7.1JPRetroMini kiadások, most egy '18 szept. magyar

Hozzászólás Szerző: Asterix » 2019.04.09. 02:39

Üdv!
Nem "retró" , de elég mini !

Precise-Min Linux Kernel: 3.14.56PAE

http://murga-linux.com/puppy/viewtopic.php?t=115843

Tettem hozzá magyarítást, nvidia drivert, a legújabb Palemoont (https://sourceforge.net/projects/lxpup/ ... /browsers/ meg egy SMPlayert és jól müxik !

NTamas
Hozzászólások: 1542
Csatlakozott: 2014.06.19. 13:36

Re: Pr5.7.1JPRetroMini kiadások, most egy '18 szept. magyar

Hozzászólás Szerző: NTamas » 2019.04.10. 01:57

Szia, Asterix!
Gondolom, Te ezt a Precise-Min Linux Kernel: 3.14.56 puppyt egy mai gépen próbáltad ki, mert nálam egy ősrégi P4-es gépen ugyan elindult mindkét iso, -a telepítés a megszokott frugall - könyvtárba telepítés(iso-ból a megfelelő fájlok átmásolva a könyvtárba, és a grubmenübe a megfelelő bejegyzés) de csak addig jutott el mindkét iso-nál a betöltés, amíg a nyomtató és egyéb hardvereket kellett volna neki betölteni, na ekkor megállt a tudomány mindkét esetben!
Némi morgás után jobban megnéztem ezt a két iso-t, mindkettőben a fő.sfs igen kis méretűre le lett fogyasztva, ez pedig az álmoskönyv szerint nem jót jelent!
Be is igazolódott, a fő.sfs-ben szinte semmi driver nincs!!! - egyedül a “Nouveau” mint videó driver, és pár wifi driver van és ennyi, a többi driver a zdrive.sfs-ben van, de ott sem túl sok. Van még egy sfs, ez az adrive.sfs, ebben van mindkét iso-nál a Light-49 webböngésző.
Kép
Kép

Namost a betöltéskor az adrive.sfs simán, elsőnek betöltődik, utána a fő.sfs tölt be, majd a zdrive.sfs-nek kéne betöltenie, hogy legyen vezetékes hálózati driver, hangdriver stb, na de idáig már nem jut el, simán megáll a betöltés, és semmi, hiába kezdem újra, ugyanez történik.
Miután kimérgelődtem magam ezen az új szokáson, hogy többféle sfs fájl is van az iso-ban a fő sfs mellett, elkezdtem kissé lehiggadni, és gondolkozni, mi lenne ha..... És ezt tett is követte, a két plusz sfs-t kimásoltam két könyvtárba, és azokban az adrive.sfs-t simán átneveztem zdrive.sfs-re míg az eredeti zdrive.sfs-t meg adrive.sfs-re neveztem át, és a két átnevezett sfs fájlt visszamásoltam a frugall könyvtárba a fő sfs mellé. Ezzel az egyszerű trükkel azt értem el, hogy most az adrive.sfs tölt be elsőnek, és ebben már nem a webböngésző van, hanem a lib könyvtárban lévő drivercsomagok, ezek betöltése után tölt be a fő.sfs majd megy tovább a rendszer betöltődése, jön a kritikus rész, a nyomtató hozzáadása, és láss csodát, most már nem állt meg a betöltés, hanem simán továbbment, és jött az asztal betöltése, ami szintén simán végbement, igaz, a “Nouveau” driver elsőre nem a megfelelő felbontást állította be, de sebaj, mivel az xorgwizard még ezekből nem lett kioperálva, így azt elindítva lecseréltem a “Nouveau” drivert a régi puppykban is meglévő nv driverre, és ez már a megfelelő monitor frekvencia értékeket állította be, a felbontást meg később beállítottam a nekem kellő 1280x1024-re.
Szóval ez az újfajta egy iso-ban több sfs régi gépeknél néha inkább hátrány, mint előny. Hátrány, mert néha nem tud valamiért betöltődni a zdrive.sfs-ben lévő lib drivercsomag, és ilyenkor már a betöltés is megállhat, mint ahogy ez nálam is megtörtént. ha meg mégis továbbmenne, és betöltődne az asztal, akkor nincs vezetékes hálókártya drivered, és hangdrivered, mert az első indításkor még nem enged sfs-t a rendszerhez felcsatolni, csak ha már csináltál egy mentésfilét. de abban meg nem lesz se hálókártya, sem hangkártya drivered.
Viszont ezzel az sfs átnevezéssel kifogtam ezen a mini-nek mondott régi-új precise-n, és már az első indításor volt hálózatom(vezetékes, nem wifi) és volt betöltött hangdriver is, így az alsa varázsló élből adott hangot, és a network varázsló is tudott netet gyártani.
Kép
Kép
Apropó, network varázsló, ebben az új mini-precise-ben lévő netvarázslóban mindössze két lehetőséged van a netgyártásra, a szokásos SNS és a Wifi-hez a Peasy wifi csomag. Ebből is látszik, hogy a készítő nagyon ráment a minimalizálásra, még jó, hogy legalább ez a két csomag megfelelően működik. Mivel már volt hangom, jó lett volna kipróbálni egy hangkeltőt is, de előbb a csomagkezelőt frissítettem fel, ráfért arra is a frissítés.
Ezután telepítettem egy Audacious-t a csomagkezelőből, és kissé rémültem figyeltem, mennyi cuccot is hoz le a csomagkezelő, több, mint 30MB-nyi anyagot!
Szóval a készítő kigyomlált mindent az eredeti puppyból, csak nem értem hogy miért, mert az odáig ok, hogy a kigyomlálással meg a fő sfs fálj megkurtításával helyet nyert, de minek is? - a fő sfs fájl kb. 70MB méretű, és a puppyból is kigyomlált minden fontosat, most, ha akarok valamit telepíteni, akkor tehetem én azokat vissza, és kínlódhatok még a + függőségekkel is! Nonszensz dolog! Ezért nem tudom megérteni, és elfogadni ezeket a mini puppykat, mert ha valamit is akarsz velük kezdeni, mondjuk rendesen használni a megszokott programjaiddal, azonnal gondokba ütközöl!
Kép
Kép

Persze a megkurtított rendszer alap memória foglalása így eleve alacsonyan tartható, lásd a képen.
Kép

A nagyobbik, 128MB-os iso-ban (én ezt szedtem le) van egy U-light-48-as webböngésző is beépítve, ami alapból képes youtube videókat játszani, és azonnal volt hangja is a videónak, ez mondjuk pozitívumnak vehető.
Kép
Kép

Az már nem annyira pozitív, hogy a videólejátszáshoz nekünk kell visszatenni minden ahhoz való, kivett dolgot, és függőséget, programot, és bizony ezzel jó nagy bosszúságot és időveszteséget okoz nekünk eme új-régi precise puppy készítő.
Még szerencse, hogy a csomagkezelőből a nagyrésze pótolható, de volt olyan dolog is, amit a saját raktáramból kellet bele tenni, -pl. a videókártyámhoz való nvidia drivert -ezt az nvidia-glx-173.14.39-k3.14.56_6.0.5_PAE.pet csomagot- de most legalább már van normális videólejátszás.(igen, jól látod, ez egy tahrpuppy-6.0.5-öshöz való nvidia driver, de ide is betehető, és kifogástalanul is működik vele ez a puppy verzió)
Kép
Kép
Kép
Kép

Működik a legutolsó smtube verzió is, a hozzá szükséges függőségek telepítése után, igaz a default lejátszó itt a gnome-mplayer lett, mert az smplayert kukáztam. Meguntam az örökös adomány-ra való üzeneteit, meg az ezután következő érthetetlen lejátszási gondjait, így maradt a jól bevált mplayer lejátszó, és a gnome-mplayer is, ezek legalább rendben működnek.
Kép


Feltettem még egy terminalban futó rádió programot,
Kép
és pár apró dolgot javítottam, cseréltem, alakítottam, míg végre estére így nézett ki a desktop.
Kép

Lehet vele böngészni, zenét hallgatni a neten, és saját zenét és saját videókat nézni, illetve netes videó streamet és a webböngészőben youtube videókat nézni, az smtube is megy rajta, feltettem még rá egy 2016-os Szoftmaker Free Offfice csomagot, a mentésfájlom mérete 740MB, ebből 223MB a szabad méret, szóval most már jól használhatónak tűnik a cucc.

Avatar
Asterix
Hozzászólások: 467
Csatlakozott: 2015.07.11. 08:55

Re: Pr5.7.1JPRetroMini kiadások, most egy '18 szept. magyar

Hozzászólás Szerző: Asterix » 2019.04.10. 02:25

Üdv!
Jól gondoltad NTamas, a modern gépen egy 8GB-os usb "pendrájon" próbáltam ki. Igen, észrevettem a csúnya kibelezést, de a hardvereket felismerte, net, hang lett! A PPM2-t frissítettem mert az SMPlayerhez sok függőséget kellet pótolni, a Palemoonhoz kerestem egy hu.xpi fájlt. Libgtk3,QT5..,Pupradio együtt 380-400 MB. Általában 2 GB mentésfájlt készítek.
De úgy tűnik a kernel cserélhető....
Musher0 conky-ját még nem próbáltam ki.

Válasz küldése

Vissza: “Pupletek”