YTFE

Audió és videó vágó, szerkesztő, lejátszó programok, kodekek
willy36
Hozzászólások: 220
Csatlakozott: 2017.05.16. 18:43

Re: YTFE

Hozzászólás Szerző: willy36 »

Köszi, a Discordon megosztottam...
Megkérhetlek, hogy a scriptet is betennéd egy közvetlen eléréssel, mert páran csak az egy klikkel boldogulnak. pl. vannak külföldiek is, meg egyszerű halandók.
Előre is köszi és a munkád is.

tch
Hozzászólások: 56
Csatlakozott: 2021.11.30. 17:29

Re: YTFE

Hozzászólás Szerző: tch »

Upsz, bocsesz, nem vettem észre, hogy írtál. Nem csekkolom mindig a fórumot és nem voltam feliratkozva rá, de ezt most pótoltam, még egyszer sorry.

Milyen scriptre gondolsz, amit be kéne tenni? A yt-dlp-t? A programnak nincs szüksége a yt-dlp-re, magától is ki tudja bányászni a direct video linkeket a YT-ből és odaadni a lejátszónak, vagy épp letölteni. Másrészt a program nem csak a yt-dlp-t tudja használni, hanem a youtube-dl-t is, hogy ha valami gixer lenne a stream-ekkel...de amióta külső JS interpreter is használható, azóta nem volt. Nincs szükség egyikre sem, csak meghagytam az opciót.

Vagy más scriptre gondoltál?

Egyéb: Kiadtam az 1.19.0-ás verziót, egy apró "fix"-szel, meg pár kényelmi újítással.

tch
Hozzászólások: 56
Csatlakozott: 2021.11.30. 17:29

Re: YTFE

Hozzászólás Szerző: tch »

Kiadtam az 1.19.1-es verziót, benne sok bugfix-szel és végre van Mac támogatás is.

Az oscompon meg lett RSS, szóval fel lehet rá iratkozni és hírt kapni a program új verzióiról.

tch
Hozzászólások: 56
Csatlakozott: 2021.11.30. 17:29

Re: YTFE

Hozzászólás Szerző: tch »

Kiadtam az 1.19.2-es verziót, benne egy db bug fix-szével, ami az előző verzióban került bele.

NTamas
Hozzászólások: 1874
Csatlakozott: 2014.06.19. 13:36

Re: YTFE

Hozzászólás Szerző: NTamas »

tch írta: 2023.11.10. 00:23 Kiadtam az 1.19.2-es verziót, benne egy db bug fix-szével, ami az előző verzióban került bele.
Kedves Fejlesztő!
Az előző verziód -2023.oktober.30- is ugyanezeket a hibákat produkálta nálam egy Hirsute puppy linux verzión, mint a most közzétett cucc. Mindkét esetben ezt töltöttem le, és próbáltam ki.(ytfe.linux.i686.gtk2)
A fájlnak futtatási jogot adva elindul ugyan, de a terminalos képben egy errort említ, lásd a képen.
0hiba.png
0hiba.png (35.35 KiB) Megtekintve 1877 alkalommal
Az ok-re kattintva elindul ugyan a programod, de egy youtube videó címet megadva neki, és kiválasztva a kellő videó felbontást annak mpv lejátszása elindul ugyan, de magát a videó fájlt már nem képes letölteni, noha a yt-dlp is telepítve van. A második képen látható hibaüzi ablakot nézve ezt én egy python hibának vélem, a puppy rendszerben egy 32 bites 3.9-es python van, amivel minden más rendben működik, lásd pl. az ugyancsak python-t használó feltelepített Kodi-19.1 is jól megy vele. Bár egyes újabb kodi addonoknál szintén előjön ez a python hiba, jellemzően azoknál, amik már kodi-20-ra lettek átírva, ott bizonyos python utasítások már nem működnek a rendszeremben meglévő 3.9-es pythonnal. Szerintem itt is ez lehet a gond, bár nem vagyok otthon a python-ban, de a kodi-ban jelentkező python hibák hasonlóak mint a te progidban a fájl letöltésekor most kapott python hibaüzi. Szóval jó lenne, ha azt is odaírnád a letölthető cuccok linkjei mellé, hogy milyen python verzió kell minimálisan a használatához.(mert nem minden puppy linuxban egyszerű a python verzió cseréje.(ha felteszek rá újabbat, esetleg(biztos) a régi programjaim nem fognak menni vele. Ez a fájl letöltésekor kapott hibaüzenet képe.
0hiba2.png
0hiba2.png (291.24 KiB) Megtekintve 1877 alkalommal
A hátsó terminal ablakban látható, hogy elindult a youtube videó lejátszása az mpv lejátszóval, amit pár másodperc után be is zártam, de ugyanezen videó letöltésekor már az ablakban látható python hibaüzi fogad.

tch
Hozzászólások: 56
Csatlakozott: 2021.11.30. 17:29

Re: YTFE

Hozzászólás Szerző: tch »

Helló,

A terminálba kiírt hibával nem kell foglalkozni, ártalmatlan, nekem is írogatja fél évtizede, de nem tudok mit kezdeni vele, ez valahol az LCL és a GTK2 között van, nem a programban. De nem csinál semmit.

A program használatához semmilyen Python nem kell, mert a programnak nincs szüksége a yt-dlp-re/youtube-dl-re ahhoz, hogy le tudja tölteni/át tudja adni az MPV-nek/VLC-nek a közvetlen stream linkeket. Ezt csak bennehagytam, mint opciót, hogy ha a google épp átvariálna valamit, akkor amíg nem reagálok rá, addig fallbacknak lehet használni a yt-dlp-t/youtube-dl-t.

A Prefs-ben a Formats fülön az "Obtain formats" opciót át kéne kapcsolni "Internally"-ra, a Tools fülön pedig a "Video URLs passed to player" és "Video URLs passed to downloader" opciókat "Direct stream link, extracted from the page"-re. Ugyanitt a "External JavaScript interpreter" mire van állítva, milyen JS interpretert használsz? nodejs, qjs, mujs?

Több részlet itt és itt.

Engem inkább az az access violation error zavar az elején, hogy vajon az mitől lehet...

Le tudnád fotózni a Prefs három fülét, ha megkérlek?

tch
Hozzászólások: 56
Csatlakozott: 2021.11.30. 17:29

Re: YTFE

Hozzászólás Szerző: tch »

Hopsz, most vettem észre a kis ablakban, hogy no known JS interpreter found. Telepíteni kéne egyet, bármilyet, ami meg tud küzdeni a YT trutymócipherével. A nodejs tuti megy, a qjs elvileg viszi, csak be kell kapcsolni a dátumok átformázását, a mujs-t így hirtelen nem tudom.

janugsa
Adminisztrátor
Hozzászólások: 618
Csatlakozott: 2014.06.28. 00:17

Re: YTFE

Hozzászólás Szerző: janugsa »

Néhány puppy linuxon nálam is feltűnt már régóta az „access violation“.
De nem szóltam, mivel Ok után minden működött, kilépéskor is feltűnt akkor
Abort után kilépett. Régebbi puppyk voltak. Például a Dpup Stretch 7.5.

Más.
v 1.19.2 32bit vagy 64 bit.
Ha beállítom a ---By this sting: (best) ----akkor nem lesz 18 vagy 22 -es paraméter.
v 1.19.0 jó.
Képenyő kép.jpg
Képenyő kép.jpg (46.39 KiB) Megtekintve 1627 alkalommal
Képenyő kép(1).jpg
Képenyő kép(1).jpg (71.54 KiB) Megtekintve 1627 alkalommal

tch
Hozzászólások: 56
Csatlakozott: 2021.11.30. 17:29

Re: YTFE

Hozzászólás Szerző: tch »

Nem a string alapú kiválasztás miatt tűnik el a 18-as/22-es formátum, hanem azért, mert be van pipálva a "Filter ignored formats from list" és az 1.19.1-ben bele lett rakva, hogy a 0 méretű stream-eket (nem elérhetőek) ignorálja és a "best" stream valamiért 0-ás méretűként van "begyűjtve", pedig nem az. Ezt ki kell majd derítenem, hogy miért; valószínűleg a YT máshol tartja a méretét a JSON-ben, mint a többiekét...

Update: A "best" tényleg nem tartalmaz contentLength-et...zseniális. Hotfixnek annyit tudok tenni, hogy a "fullos" videóknál (azaz, amikben hang és videó is van, nem külön stream-ból jön), ne szűrje ki, ha 0 a méret.

Ez az access violation dolog sokkal jobban zavar; ez csak az első indításkor/leállításkor jelentkezik, vagy mindegyiknél? Van olyan rendszered, ahol ezt reprodukálni tudod? Ha igen, akkor segítenél nekem megint egy kis tesztelésben?

janugsa
Adminisztrátor
Hozzászólások: 618
Csatlakozott: 2014.06.28. 00:17

Re: YTFE

Hozzászólás Szerző: janugsa »

Ahol előfordul, ott mindig.

Teszteljünk.

Válasz küldése

Vissza: “Multimédia”