Pen-Puppy

Pupletek, Új puppy változatok, veruiók, ISO fájlok,
willy36
Hozzászólások: 191
Csatlakozott: 2017.05.16. 18:43

Re: Pen-Puppy

Hozzászólás Szerző: willy36 »

Hali !
minden puppy-t erről a penről és beállítással telepítek, továbbra is így gondolod?
de, kipróbálom másik pendrive- al, hogy kizárjam a hibalehetőséget

pfeco
Hozzászólások: 165
Csatlakozott: 2014.08.09. 21:24

Re: Pen-Puppy

Hozzászólás Szerző: pfeco »

A képernyő kiírása szerint mem található a puppy_mokshapup_3.0.sfs fájl.
A hiba oka lehet a nem megfelelő isolinux.cfg fájl vagy az initrd.gz fájl.

Az initrd.gz fájl szerkesztéséhez alkalmazhatók az alábbi egyszerű scriptek.
Kicsomagolás után a létrejött könyvtárba edit-initrdgz bemásoljuk az initrd.gz fájlt
majd elinditjuk a kibont-initrd.sh fájlt.
Az initdir könytárban a DISTRO_SPECS fájl ellenőrzéseés esetleges szerkesztése után
a csomagol-initrd.sh fájl létrehozza az új initrd.gz fájlt.
edit-initrdgz.tar.gz
(297 bájt) Letöltve 49 alkalommal.

pfeco
Hozzászólások: 165
Csatlakozott: 2014.08.09. 21:24

Re: Pen-Puppy

Hozzászólás Szerző: pfeco »

Focalpup64 minimál alfa teszt változata pen-re JWM és ArktisWM ablakkezelővel
arktiswm-04.jpg
arktiswm-04.jpg (128.81 KiB) Megtekintve 1517 alkalommal
Letölthető innen:https://drive.google.com/open?id=14WhO4 ... 9PMGMWgJ6G

ArktisWM ablakkezelő
Letölthető innen:https://drive.google.com/open?id=1bXGNJ ... A2vkTCi7dF
Forumszál:http://murga-linux.com/puppy/viewtopic.php?t=112471

NTamas
Hozzászólások: 1712
Csatlakozott: 2014.06.19. 13:36

Re: Pen-Puppy

Hozzászólás Szerző: NTamas »

Igaz, én nem usb kulcson próbáltam ki ezt a verziót, hanem a hagyományos frugall módon, külön könyvtárba telepítve a megfelelő fájlokat, de a meglepetésem mégis nagy volt. Azonkívül, hogy rendben bejött (ez volt az egyik pozitív meglepetés) a kezdőoldal, -a kisteljesítményű videókártya miatt csak 1024x768 felbontásban- a főmenüt átnézve valóban minimal dolgok vannak csak benne. Annyira minimal, hogy pl. a pmusic, aminek kellene lennie az audió lejátszónak, na, az meg sem mukkan, pontosabban pmusic stream radió része lekeresi a csatornákat, csak éppen néma, mint a hal!
Az integrált Intel HD audió részt alapból (ez volt a másik pozitív meglepetés) felismeri, a tesztre megvan a jobb és baloldali próba is -van sistergés rendesen, ahogy kell- és utána van a megszokott kutyaugatás hang. DE!
Nincs a rendszerben mplayer motor, nincs benne ffmpeg sem!
Így már érthető, hogy szegény pmusic miért nem adott hangot!
A rendszerben mndössze csak egy aplay bináris van, valszeg ez játssza le a kutyaugatás hangot az alsa tesztnél. De semmi többet!
Tehát az amúgy is szűkös benntmaradt programok közül a pmusic helyből elvérzik, alapszinten használhatatlan!

Ugyanígy problémás a cd író program is, számos függőség hiányzik hozzá!
Kép
Amúgy az ffmpeg hiánya pont a képet jobban megnézve vált bizonyossá, sebaj, van csomagkezelő, irány oda, lefrissítettem az adatbázisát, meglepően gyorsan végzett, ami egyet jelenthet, igen kevés dolog lehet benne, vagy kevés dolgot lehet elérni a használatával. Mindegy, töltsük le az ffmpeg-et.
Na, itt jött a negatív meglepetés, (persze előtte terminalban is megnéztem, ffmpeg seholsincs a rendszerben) a hiányzó ffmpeg, és a hozzá kellő, és a függőségekhez kellő egyéb dolgok (libavcodeck és a többiek sorban) kerekem 100MB-nyi tartalmat tettek ki!
Kép

Így már érthető, hogy miért ilyen karcsú ez az iso- sebaj töltsük le a cuccokat, a 100MB-nyi függőség meglepően gyorsan lejött, és hiba nélkül felment a rendszerre. (a check nem talált több függőséghiányt) Ezután vissza a pmusic-ba, és csodák csodája, azonnal volt hangja a pmusicnak, éppen a Petőfi rádióval próbáltam ki, szépen zenélt, ahogy kell.
Kép

Akkor egy másik próba, szedjük le az audacious programot és azok függőségeit, számos puppy ezen vérzett el, ez nem, ez lehozott mindent, sőt! a midi fájlok lejátszásához még egy 6MB-s GM SoundFont sf fájlt is lehozott, és telepítette. Ezt eddig egyetlen egy puppy verzió sem tette meg! - ezeket a SoundFont sf fájlokat eddig minden puppy verziónál nekem kellett kézzel, utólag feltelepíteni.
Ez volt a harmadik meglepetés. A csomagkezelőből való telepítés után az Audacious már rendben tette a dolgát. Játsza rendesen a midifájlokat,
Kép
és az mp3 fájlokat is.
Kép

Az 1 GB fizikai memória ellenére, vagy inkább pont amiatt van a merevlemezemen egy 2GB-os swap partíció is, amit egyébiránt a rendszer induláskor rendben észrevesz, és szépen használatba is vesz. Viszont a pmusic futása közben nem túlzottan vette a rendszer igénybe a gépet, lásd a htop képen is, a külön swap partíciót pl. nem is használta ki. És a 284MB memóriahasználat is igencsak elfogadható.
Kép

Vannak további negatívumok is, nincs az alaprendszerbe előre feltelepítve képnéző program, még jó, hogy legalább egy mtpaint program és a hozzávaló képmentő azért még belefért, így tudtam ezt a pár képet hozni. Viszont az alapértelmezett programok táblázatában számos olyan program neve van beírva, ami nincs is benne alapból a rendszerben, erre azért oda kellett volna figyelni. Továbbá, a már említett ffmpeg teljes hiányát sem ártott volna megemlíteni, és azt sem, hogy mplayer motor és/vagy az mpv motor sincs benne alapból. És hát a csomagkezelő hasonlóan a Bullseyepuphoz, itt sem túl jól teljesít, számos programot hiába keresek benne, nincs, vagy nem találja meg elsőre azt a csomagkezelő, és ez nem túl bíztató dolog. Sokat kell ügyesedni vele, míg pl. összejön a fentebb említett cd író programhoz a hiányzó függőségek beszerzése és telepítése, ha nehezen is, de megodható.
Kép

Értem én, hogy alfa program, meg miegyéb, de azért azt már csak elvárhatja az ember, ha van egy összeállítás, akkor az abban lévő dolgok azért már hibátlanul működjenek, vagy legalább elinduljanak, és ne a leendő felhasználónak kelljen pl. a hiányzó függőségeket beszereznie. Majd még próbálgatom később is, hiszen a webböngészőkből is a legújabbakat fel kéne rá tenni, de egyelőre más dolgom miatt leszedtem a cuccot a gépről.

pfeco
Hozzászólások: 165
Csatlakozott: 2014.08.09. 21:24

Re: Pen-Puppy

Hozzászólás Szerző: pfeco »

NTamas írta
Értem én, hogy alfa program, meg miegyéb, de azért azt már csak elvárhatja az ember, ha van egy összeállítás, akkor az abban lévő dolgok azért már hibátlanul működjenek, vagy legalább elinduljanak,
Köszönöm az észrevételeket valóban eltúloztam a karcsúsítást,
ezért javítva elkészítettem a következő Focal64,Bullseye64,Bullseye32 9.1.0 Lite verzióit.
FFmpeg,pburn,pmusic,pulseaudió-t tartalmazza és alap JWM ablakkezelővel.
Nincs benne:
-webböngésző
-videólejátszó
-szövegszerkesztő
ezért csak egy puppy alap ami saját igény szerint alakítható bővithető vagy remasterelhető.
focalpup64-lite.jpg
focalpup64-lite.jpg (69.16 KiB) Megtekintve 1287 alkalommal
Letölthető innen:https://drive.google.com/open?id=14WhO4 ... 9PMGMWgJ6G

NTamas
Hozzászólások: 1712
Csatlakozott: 2014.06.19. 13:36

Re: Pen-Puppy

Hozzászólás Szerző: NTamas »

Kis helyesbítést engedj meg, a -nincs benne szövegszerkesztő- az az Office programra vonatkozik, szerencsére a geany az alapból benne van. :)

Szóval, ha az előző próbát a karcsú Focal64 verzióval végeztem úgy illik, hogy a tesztett ismét azzal a verzióval végezzem, most már a kibővített verzióval.

Ahogy eddig, most is simán bejött a desktop, -1024x768, a régi videókarim miatt- rendben felismerte a hardvereket, legnagyobb örömömre az Intel HD Audiót is, és az időközben elhalálozott ps2-es Genius vezetékes egér helyébe lépő, Logitech rádiós egeremet is,(usb kulcson van a Logitech meghajtója, a puppy simán felismerte és kezeli) egyetlen kis furcsa dolog volt, az első indítás után nem akarta menteni a beállításokat, nem dobta fel a kis save ablakot, ezt csak a következő újraindításnál tette meg, azóta ezzel sincs gond, menti rendesen a beállításokat. (most sem usb kulcson tesztelem, hanem a gépen, frugall módban, külön könyvtárban van a Focal64)
Mivel ez már egy feljavított, bővített verzió, ezért most kevesebb munka volt vele, a csomagkezelő frissítése után azonnal nekiláttam a nálam szokásos programok (az előző tesztben említettek) feltelepítéséhez, ezek gond nélkül felmentek, rendben működnek is, ezért további programokkal kínáltam meg a cuccost. most a grafikus szekció is kapott pár alkalmazást, illetve a már megígért böngésző próbát is megtettem, a Firefox 75 került fel a csomagkezelőből, a nyelvi kiegészítéssel egyetemben, valamint egy Transmission is került rá. A FF meglepően rendben működik, így ez lett a fő webböngésző. A már említett újabb verziójú VLC meg annyira bevált nálam, hogy a tesztet félbehagyva egész este azon moziztam, így most írom csak meg a teszt eredményét, pár képpel kiegészítve.

Kép

Kép

Kép

A végeredmény: nekem bevált a kis gépemen, (fenn marad a gépen!) csak ajánlani tudom másnak is a kipróbálását, és külön nagy köszönet pfecó-nak, hogy vette a fáradságot az alfa verzió továbbgondolására.

Utóirat.
A képeken is látható, hogy nálam a conky háttere egy ideig fekete, ez a gyenge videókarim miatt van, egy idő után azonban átvált nálam is áttetszőre, ez tehát nem hiba, ez csak az én hardver gyengeségem miatti tünet, tehát nem szoftverhiba!

NTamas
Hozzászólások: 1712
Csatlakozott: 2014.06.19. 13:36

Re: Pen-Puppy

Hozzászólás Szerző: NTamas »

A Firefox kép az előbb valamiért lemaradt, pótolom.
Kép

Megy a csomagkezelőből feltelepíthető Audacity program is, csak ezt kissé trükkösen kell feltenni:
1. a csomagkezelőből telepítjük magát a programot automata módban, ez felteszi magát a programot, és annak az egyetlen (a csomagkezelőben látszó) függőségi fájlját.
Kép

2. A csomag telepítése után a program még nem fog elindulni, mert további függőségi (gtk3-hoz kellő + fájlok) hiányban szenved, amit a csomagkezelőből sajnos kézzel, egyénileg kell majd telepíteni, nem gond mert megoldható a dolog. Ezeket a fájlokat kell még hozzá feltenni: a wxWidgets-ből a három libwxgtk fájlt, a .dev fájlokat már nem feltétlen szükdséges telepíteni.
Kép

ha felment a rendszerre a három még szükséges függőség file:
libwxgtk-media3.0-gtk3-0v5_3.0.4+dfsg
libwxgtk-webview3.0-gtk3-0v5_3.0.4+dfsg
libwxgtk3.0-gtk3-0v5_3.0.4+dfsg
akkor már simán el fog indulni az előzőleg feltelepített Audacity programunk is.
Kép
(és itt a képet nézve a figyelmesebb szemlélő már láthatja azt, hogy az előbb említett fekete hátterű conky most már nálam is átváltott áttetsző módba)

Arra azért figyeljünk oda, ha még más programot is tervezünk a rendszerre telepíteni a csomagkezelőből, hogy abból nem minden kellő fájl fog lejönni a csomagkezelő automata módjában, van, hogy kézzel kell még lehozni, és telepíteni a még szükséges függőségi fájlokat. Sajnos én ezt tapasztaltam, hogy ez miért van, nem tudom, de erre érdemes odafigyelni.

NTamas
Hozzászólások: 1712
Csatlakozott: 2014.06.19. 13:36

Re: Pen-Puppy

Hozzászólás Szerző: NTamas »

Kép

Ez a lentebb linkelt VLC verzió (pet és sfs) kimondottan a csomag nevében is jelzett 64 bites FocalPup64_9.1.0_Lite puppy verzióhoz készült! - ehhez a puppy verzióhoz való néhány függőségi fájlok is a csomag részei, akárcsak a 6MB-s GM SoundFont sf fájl is,(timgm6mb-soundfont_1.3-3_all.deb) így a telepített VLC-vel azonnal (a lejátszó beálításában a sound file hozzáadása után) lejátszhatunk midi fájlokat is.
Kép
(a képen látható, hogy nálam a vlc csomagokban lévő 6MB-os timgm6mb-soundfont helyett egy másik, kibontva már 142MB-os mérettel bíró fluid-soundfont-gm_3.1-5.1_all.deb soundfont(FluidR3_GM.sf2) fájl van alkalmazva, betehettem volna ezt is, de ezzel igencsak megnőtt volna a vlc csomagok mérete. Akinek esetleg mégis kellene, -mert ezzel azért jobban szólnak a midi fájlok- az a fluid-soundfont-gm_3.1-5.1_all.deb fájlra keressen rá a csomagkezelőben, vagy a netről is leszedhető ugyanez a fájl.)

A verzióspecikikus fájlok miatt a pet csomagot ezért csak a jelzett puppy verziót használók telepítsék, más 64 bites puppyt használók esetleg az sfs fájlal tehetnek egy próbát.
Mivel csak egyetlen 64 bites puppy fért már fel a kis gépemre, ezért más 64 bites puppy verzión nincs letesztelve a VLC csomag, ezt kéretik figyelembe venni!
Az igaz, hogy a VLC weboldalán, és a 32 bites Bullseye puppy csomagkezelőjében már ott van, és tölthető a program vlc_3.0.10-1-x86-os verziója is, de a 64 bites FocalPup64_9.1.0_Lite puppy csomagkezelőjében még ez a vlc_3.0.9.2-1-x86_x64-os verzió van meg jelenleg is, most néztem meg, még nem elérhető benne sajnos az újabb verzió. De addig ez is nagyon megfelel, nálam meglepően jól teljesít.

vlc_3.0.9.2-1-x86_x64_FocalPup64_9.1.0_Lite.pet
https://yadi.sk/d/U52NHLl5Uv9mBg
vlc_3.0.9.2-1-x86_x64_FocalPup64_9.1.0_Lite.sfs
https://yadi.sk/d/TYAYB3YvbkpsdA

pfeco
Hozzászólások: 165
Csatlakozott: 2014.08.09. 21:24

Re: Pen-Puppy

Hozzászólás Szerző: pfeco »

GroovyPup64-Lite

Készülőben az Ubuntu Groovy-Gorilla Puppy teszt alfa verziója.
Milyen alapprogramok legyenek beépítve?
groovypup64-lite.jpg
groovypup64-lite.jpg (70.65 KiB) Megtekintve 954 alkalommal

NTamas
Hozzászólások: 1712
Csatlakozott: 2014.06.19. 13:36

Re: Pen-Puppy

Hozzászólás Szerző: NTamas »

Hát, hogy ne kerülj abba a helyzetbe, ami a Focalpup64-nél volt, egy friss ffmpeg, a hozzávaló libav codeckkekkel, és egy friss vlc sem ártana bele, és talán egy mplayer motor/és vagy mpv sem ártana bele, az mplayer gui nélkül.
Arra már lehet építkezni, az Office és webböngésző progik amúgy is a felhasználószintű szabadon választott kategória, alapszinten viszont simán elég bele egy jól belőtt geany is. Ja, és akkor már a cups se maradjon ki, (a focal64-ben most éppen a cups_2.3.1-es verzió érhető el a csomagkezelőből) nem árt, ha benne van, és nem utólag kell vacakolni a telepítéssel. És még egy dolog, ha már benne van netán az mtPaint program is, nem ártana hozzá feltenni annak a képmentő parancsfájlját sem! - ezt a kis fájlt szinte mindenki kihagyja, nem tudni, miért, te inkább tedd bele. Egy képnéző progi sem árt hozzá, a Focal64-ben bevált a Viewnior_1.6 verzió. Ha netán benne hagyod az alap Pburn cd/dvd író programot, akkor azoknak a függőségeit is építsd bele, ne utólag kelljen azokat levadászni, lásd a fentebbi Focalpup-nál lévő ilyen témájú képet.
A Qt keretprogram a mostani puppykban már az 5-ös szériából van választva, ha netán a vlc telepítésekor nem menne fel, úgy nem ártana azt esetleg egészében külön telepíteni, sok új program igényli a meglétét. A Pulseaudiót meg úgy ahogy a módosított Focal64 Lite-ben is megoldottad.
Kb. úgy hirtelen ennyi ugrik be....
-------------------------------------------------------
https://packages.ubuntu.com/groovy/
-------------------------------------------------------

Válasz küldése

Vissza: “Pupletek”