Inkscape

Képszerkesztő, konvertáló programok, minden, ami grafika
azami
Hozzászólások: 1014
Csatlakozott: 2014.06.20. 20:25

Inkscape

Hozzászólás Szerző: azami »

Elég sok Puppletben megtalálható, és még lehet sokan használják is :idea: :D
Megjelent az Inkscape-könyv,és annak hazai fogadtatása:
http://inkscape.hu/az-inkscape-konyv-fo ... a/#more-98

Letöltés: http://inkscape.hu/letoltesek/

Avatar
csipesz
Hozzászólások: 596
Csatlakozott: 2014.06.24. 11:02
Tartózkodási hely: Isaszeg

Re: Inkscape

Hozzászólás Szerző: csipesz »

most ezekkel meg mi van :o ???
Screenshot_2014-11-11_13_19_50.jpg
Screenshot_2014-11-11_13_19_50.jpg (17.8 KiB) Megtekintve 3062 alkalommal
Biztos' lefagyasztotta a weboldalt az elkepeszto szamu erdeklodo :D ...

Avatar
csipesz
Hozzászólások: 596
Csatlakozott: 2014.06.24. 11:02
Tartózkodási hely: Isaszeg

Re: Inkscape

Hozzászólás Szerző: csipesz »

Jol van, megy mar!

gjuhasz
Hozzászólások: 88
Csatlakozott: 2014.08.17. 13:52

Inkscape 0.91

Hozzászólás Szerző: gjuhasz »

Sziasztok,

Hátha valakit érdekel:

Feltöltöttem az inkscape-0.91p.pet fájlt ide: http://www.smokey01.com/gjuhasz/sfs/

A Puli és a tahrpup 6.0.2 CE alatt tesztelve. Más pupletekkel talán megy, de pl. a Slacko 5.6 hoz még hiányoznak csomagok. Itt a murgás fórumszál: http://www.murga-linux.com/puppy/viewto ... 084#839084

Még masszíroznom kell egy kicsit, mert az lxml csomagot kéri, amikor a Help-et hívom, vagy extrákat szeretnék letölteni. Attól még (szerintem) így is megéri kipróbálni. Sokkal nagyobb, mint a 0.48-as elődje, de ennyivel többet is tud.


Jó terelgetést!

Üdv

gjuhasz
A hozzászólást 1 alkalommal szerkesztették, utoljára gjuhasz 2015.04.29. 17:09-kor.

NTamas
Hozzászólások: 1655
Csatlakozott: 2014.06.19. 13:36

Re: Inkscape

Hozzászólás Szerző: NTamas »

Én úgy vettem ki az inkscape_0.91-es ubuntu-s leírásából, hogy ezeket a függőségeket igényli a futásához.
ruby, libxml-xql-perl, python-numpy, and python-lxml

Én most az innen -weboldal link- származó inkscape_0.91.0+37~ubuntu12.04.1_i386.deb (27.2 MiB) -os Precise-hez való deb csomaggal teszek egy próbát, hátha elindul az 571 precise puppy alatt...

Nos, nem indult el, -ez mondjuk eleve várható is volt - és ezt a szép, hosszú hiánylistát generálta magának:
***
libgtkmm-2.4.so.1 libatkmm-1.6.so.1 libgdkmm-2.4.so.1 libpangomm-1.4.so.1 libcairomm-1.0.so.1 libgiomm-2.4.so.1 libglibmm-2.4.so.1 libgsl.so.0 libgslcblas.so.0 libMagick++.so.4
***
Szóval ezeket nem fogom egyenként levadászni, ami a röhej ebben, hogy a deb csomagot kibontva ott van benne a controll file, ami szépen tartalmazza a föggőségeket, íme:

Package: inkscape
Version: 0.91.0+37~ubuntu12.04.1
Architecture: i386
Maintainer: Inkscape developers <inkscape-devel@lists.sourceforge.net>
Installed-Size: 96778
Depends:
python (>= 2.7.1-0ubuntu2), libaspell15 (>= 0.60.7~20110707), libatkmm-1.6-1 (>= 2.22.1), libc6 (>= 2.11), libcairo2 (>= 1.10.0), libcairomm-1.0-1 (>= 1.6.4), libfontconfig1 (>= 2.8.0), libfreetype6 (>= 2.2.1), libgc1c2 (>= 1:7.1), libgcc1 (>= 1:4.1.1), libgdk-pixbuf2.0-0 (>= 2.22.0), libglib2.0-0 (>= 2.24.0), libglibmm-2.4-1c2a (>= 2.32.0), libgnomevfs2-0 (>= 1:2.17.90), libgomp1 (>= 4.2.1), libgsl0ldbl (>= 1.9), libgtk2.0-0 (>= 2.24.0), libgtkmm-2.4-1c2a (>= 1:2.24.0), libgtkspell0 (>= 2.0.10), libjpeg8 (>= 8c), liblcms2-2 (>= 2.2+git20110628-2), libmagick++4 (>= 8:6.6.9.7), libpango1.0-0 (>= 1.22.0), libpangomm-1.4-1 (>= 2.27.1), libpng12-0 (>= 1.2.13-4), libpoppler-glib8 (>= 0.18), libpoppler19, libpopt0 (>= 1.14), libsigc++-2.0-0c2a (>= 2.0.2), libstdc++6 (>= 4.6), libwpd-0.9-9, libwpg-0.2-2, libx11-6, libxml2 (>= 2.7.4), libxslt1.1 (>= 1.1.25), zlib1g (>= 1:1.1.4)
Recommends: aspell, imagemagick, libwmf-bin, perlmagick, python-numpy, python-lxml, python-uniconvertor
Suggests: dia | dia-gnome, ruby, libgnomevfs2-extra, libsvg-perl, libxml-xql-perl, transfig, pstoedit

Csak azt nem értem, ha már a nyomorult deb csomag készítője -*** nem rád értettem gjuhász!- nem a te pet-es csomagodra, hiszen az valószínűleg egy gyári deb-csomagból készülhetett, de Te már abba betetted azokat a függőségeket, ami kellhet hozzá!- ilyen precisen beleírta, mi kell a művének megszólaltatásához, mi a bánatért nem mellékeli ezeket a telepítő deb csomagban beletéve, a megfelelő linux könyvtárba beletéve, szóval tele van a hócipőm a függőségvadászattal!!!
Nem igaz, hogy egy csomag készítő nem tudná összeszedni, - eleve ő tudja a legjobban mi is kell a művéhez, mit is használ az!!!- és mellékelni a csomagjához ezeket a szükséges függőségeket, mert az odáig oké, hogy van az Ubuntu-ban csomagkezelő, és az majd összeszedi ezeket a függőségeket, ha megtalálja, mert a fentebb is jelzett ubuntu tárolóban nincsenek függőségi csomagok!!! És ha nem Ubuntura telepítem, hanem másmilyen linux-ra, ami képes deb csomagot telepíteni, de a függőségeket már nem fogja magától lehozni nekem, és itt sajnos már megint az egyenkénti függőségvadászat lép érvénybe, és ezzel már torkig vagyok!!!

És én még szerencsésnek is mondhatnám magamat, hogy az én precise 751 lite puppy verziómhoz csak a fentebb leírt *közti* hiánylistát generálta, a többi függőség az már valahogyan a rendszerbe került valamikor. Ráadásul abból is sok minden nem az alap precise 571 puppy-val érkezett, hanem utólag települt fel, más program hozadékaként!
Na, ezért útáltam meg régebben is a linux-ot és ezért hagytam abba a vele való foglalatoskodást, majd most később újra nekifogtam, a puppy okán, de ismét a régi problémák jönnek elő újra, és ez elborzaszt újfent. Nem igaz, hogy a puppy-ba nem lehetne beépíteni egy normális csomagkezelőt, főleg akkor, ha az a puppy verzió már képes deb csomagokat is telepíteni! Csak éppen a kellő függőségeket nem tudja az Ubuntu-s tárolókból összeszedni hozzá!! Már ha ott egyáltalán vannak ilyenek, mert jelen esetben úgy néz ki a dolog, hogy nincsenek is ilyenek fenn, abban az Ubuntu-s tárolóban!

És tulajdonképpen ezért lesz-van most válságban a puppy-k fejlesztése, mert a régi út már járhatatlan, a régi öreg alapprogramok elavultak, az újakhoz, főleg a deb, rpm csomagok telepítéséhez a régi csomagkezelő már kevés, és ez így már nem sokáig mehet, valamit lépni kell, ezért is értem meg azami fórumtársunk lelkesedését az MX linux-al kapcsolatban, abban legalább egy normális csomagkezelő van!

Jellemző a Puppy precise csomagkezelőjére, hogy az ubuntu-precise tárolóból semmilyen függőséget nem talált meg még a régebbi, 0.48-as verzió telepítéséhez sem, látni látja, olvassa a controll fájlban, hogy mi kellene, de azokat nem találja, itt a kép róla.
http://kepfeltoltes.hu/view/150408/111_ ... es.hu_.png
Ha viszont felveszem a puppy precise tárolót, ott már az inkscape.0.48.3.1 verzió telepítéséhez már megtalálja az ott lévő függőségeket, és azokat a csomagellenőrző szerint telepítette is, egyébiránt a függőségek összmérete 77 Mega lett, ez eléggé elgondolkodtató, és jól látszik hogy az új deb file ezeket eleve nem tartalmazza. Itt a kép róla, ezeket a függőségeket találta meg a régebbi, 0.48-as verzióhoz.
http://kepfeltoltes.hu/view/150408/112_ ... es.hu_.png
Természetesen most már nálam is elindult a program, a régebbi 0.48-as verzió. Az újat meg nem mertem rátelepíteni, mivel az inkscape_0.91.0+37~ubuntu12.04.1_i386.deb (27.2 MiB) deb file az a fentebb említett Ubuntu-s tárolóból lett letöltve, ahonnan meg a Puppy csomagkezelője nem fog megtalálni semmilyen függőséget sem, mivel ott ilyenek nincsenek. És az újhoz még több függőségi csomag kell, mint a régihez, ezért egyenlőre marad a régebbi verzió.
http://kepfeltoltes.hu/view/150408/113_ ... es.hu_.png

Utóirat

A fentebb ***-al tett megjegyzésemhez még annyit kell hozzátenni, hogy gjuhász szintén hasonlóan gondolkodhatott, mint én, ezt bizonyítja az is, hogy az őáltala készített pet csomagban, azon belül is a lib alkönyvtárban viszont már ott vannak a szükséges függőségek, ami azt jelzi, hogy gjuhász fórumtársunk is hasonló problémákkal kerülhetett szembe, mint én, és ezért a saját pet-es telepítőjébe már előzékenyen beépítette a függőségeket. Ime a kép róla.
http://kepfeltoltes.hu/view/150409/114_ ... es.hu_.png

Mivel a kérdéses progiból nekem a 0.48-as van fenn leírtam, hogy miért, ezért most utólag próbát teszek a gjuhász féle új pet csomaggal, mindjárt kiderül, megy e a Precise Puppy 571 Lite verzión is.
Na, meg is vagyok, feltelepült, de ezt az egy függőséget hiányolta, ezt kell még beszereznem hozzá, íme a hiányzó függőség képe.
http://kepfeltoltes.hu/view/150409/115_ ... es.hu_.png
Ezen függőség feltelepítése után sem indult el nálam az új 0.91-es verziójú inkscape, így marad a már bevált inkscape-0.48-as verzió.

Avatar
KuLuSz
Hozzászólások: 506
Csatlakozott: 2014.06.17. 21:19

Re: Inkscape

Hozzászólás Szerző: KuLuSz »

NTamas írta:Nem igaz, hogy egy csomag készítő nem tudná összeszedni, - eleve ő tudja a legjobban mi is kell a művéhez, mit is használ az!!!- és mellékelni a csomagjához ezeket a szükséges függőségeket, mert az odáig oké, hogy van az Ubuntu-ban csomagkezelő, és az majd összeszedi ezeket a függőségeket, ha megtalálja, mert a fentebb is jelzett ubuntu tárolóban nincsenek függőségi csomagok!!! És ha nem Ubuntura telepítem, hanem másmilyen linux-ra, ami képes deb csomagot telepíteni, de a függőségeket már nem fogja magától lehozni nekem, és itt sajnos már megint az egyenkénti függőségvadászat lép érvénybe, és ezzel már torkig vagyok!!!
Szándékosan nincs belerakva a függőség. Miért ? Azért mert 1 függőséget több program is használhat , és ha 1-nél több program használja azt az 1 nyomorult függőséget akkor a másik program már nem fog elindulni . Tudom ehhez sok idő kell mire megérted , de időnk mint a tenger . Ennek a megoldása az hogy vagy telepíted a synapticot és azzal telepítgetsz a puppyban , vagy megtanítod a puppycsomagkezelőt a függőségvadászatra , ami elvileg már működik is, viszont lehet hogy nincs benne az összes letöltési tükör azaz repo. Nyilván ha megértettük amit az előbb írtam , abból adódik a következő probléma hogyan törlök 1 olyan programot és/vagy függőséget ha más program azt használja ?
-<(].K.u.L.u.S.z.[)>-
-----------------------------------------------
Elérhetőségeim: Angol irc csevegő, (reg mentes) Discord, YouTube

NTamas
Hozzászólások: 1655
Csatlakozott: 2014.06.19. 13:36

Re: Inkscape

Hozzászólás Szerző: NTamas »

KuLuSz írta:...adódik a következő probléma hogyan törlök 1 olyan programot és/vagy függőséget ha más program azt használja ?
A Precise Puppy csomagkezelője ezt simán megoldja, nem kell egy program, de az használja pl. a python.akármi fájlt, erre mit csinál a csomagkezelő?
A packages list-ben leírt telepített filéket simán letörli, és tehetem vissza azt a bizonyos python filét, ha használni akarok másik programot, aminek szintén kell az a bizonyos python fájl.
Így jártam a RadioTray-el, a Bleacbit-el, és még sorolhatnák jópár programot. Ezek között vegyesen voltak pet-es csomagok, illetve a csomagkezelő által telepített programok, amik mellé a csomagkezelő letelepítette a függőségeket is, programtörlésnél meg simán kitörölte a függőségeket is, majd ártatlan pofával feldobott egy ablakot, hogy ez és ez a függőség lehet, hogy kelleni fog, ha szerencsém van, akkor nem kell őket újratelepíteni, mármint a csomagkezelő által letörölt függőségeket. Soha nem volt szerencsém, mert mindig az kellett, amit a csomagkezelő túlbuzgósága okán simán kivágott, és nem nézte az meg, hogy másik programnak is kellene ugyanez a függőség. Akkor minek a csomaglista, ha törlésnél a csomagkezelő nem veszi figyelembe, hogy másnak is kellene az éppen letörölt függőségi fájl?
Hol lehet a Puppy csomagkezelőjében ezt beállítani, mert én eddig ilyen beállítási elemet nem találtam, amivel meg lehetne gátolni, hogy akár még a rendszerfilékből se töröljön ki olyat, -python stb, ami másnak kellhet.
Tudom, használjak remasztert, de ha arra teszek fel progikat, majd törlök, ugyanezt produkálja nálam a puppy csomagkezelője.

Avatar
KuLuSz
Hozzászólások: 506
Csatlakozott: 2014.06.17. 21:19

Re: Inkscape

Hozzászólás Szerző: KuLuSz »

Ez a gond a csomagkezelővel ... ubinál maga a synaptic figyeli a függőségeket , hogy melyik proramhoz mi tartozik , így csak a felesleges dolgokat törli a rendszerből. A puppy-nál ez nincs megoldva. Ezért érdemesebb SFS-ben megcsinálni a programokat , és azokat nem telepíteni , hanem csak felcsatolni a rendszerben. Így mindegyik program(SFS) különálló lesz egymástól. Szóval ha ezt az elvet követjük kapni fogunk 1 olyan rendszert mint a lazy-pup.
-<(].K.u.L.u.S.z.[)>-
-----------------------------------------------
Elérhetőségeim: Angol irc csevegő, (reg mentes) Discord, YouTube

gjuhasz
Hozzászólások: 88
Csatlakozott: 2014.08.17. 13:52

Re: Inkscape

Hozzászólás Szerző: gjuhasz »

Sziasztok,

A hiányzó csomagokat csak eggyel régebbi python alatt találtam meg, de végülis sikerült egy szokatlanul ronda, de hatásos módon működésre bírni az inkscape 0.91-et.
Az inkscape indító szkript átkapcsol a 2.6-os pythonra, majd kilépéskor vissza az alapértelmezett 2.7-re.

Feltöltöttem ide: http://www.smokey01.com/gjuhasz/sfs/. Tesztelve a Pulival illetve VirtualBox alatt a tahrpup 6.0.2 CE -vel. Egyelőre nem omlott össze, pedig eléggé meggyötörtem.
Ha valakinek jobb ötlete van, esetleg tudna egy 2.7-es pythonos fordítást csinálni tahrpup CE-hez az lxml+numpy kombóból, annak meghálálnám.
Mondjuk egy friss, magyar nyelvű LazPaint-6.4.1 pet csomaggal... ;)

Jó terelgetést!

Üdv

gjuhasz

gjuhasz
Hozzászólások: 88
Csatlakozott: 2014.08.17. 13:52

Re: Inkscape

Hozzászólás Szerző: gjuhasz »

gjuhasz írta:...végülis sikerült egy szokatlanul ronda, de hatásos módon működésre bírni az inkscape 0.91-et...
Aki véletlenül :oops: nem Pulival, hanem pl. tahrpup 6.0.2 CE alól használná az Inkscape 0.91-et, annak a kedvéért újra feltöltöttem, egy kis módosítással.
A /root/my-applications/bin mappában lett egy futtatható kis links nevű szkript:

Kód: Egész kijelölése

#!/bin/sh
exec defaultbrowser "$@" 2>/dev/null
Ez azért kell, mert a szegény régi python (webbrowser.py) nem képes megtalálni a mai browsereket (de pl a links-et igen), így a fenti ál-régiböngésző kapcsol át az épp aktuális defaultbrowserre.
Azért ide tettem, mert a /root/my-applications/bin mappa a keresőútvonal-lista (search path) vége felé van és az itteni links fájl így nem zavar be az "igazi" links megnyitásába (ami ugyebár alapértelmezett böngésző a Puliban).
Ha valakinek így sem sikerülne a Segítség menüben az Inkscape kézikönyv megnyitása, akkor nevezze át a fenti szkriptet netscape :o névre.

Javaslom ezt a trükköt bevetni máshol is , ahol régi python üzemel.

Jó terelgetést!

Üdv

gjuhasz

Válasz küldése

Vissza: “Grafika”