seamonkey

Böngészők, üzenetküldők, levelezők, stb...
ticoo1
Hozzászólások: 546
Csatlakozott: 2014.10.21. 08:58

Re: seamonkey

Hozzászólás Szerző: ticoo1 »

Köszi az infót, de szerintem cseréld le a glibc-t. :mrgreen:

NTamas
Hozzászólások: 1710
Csatlakozott: 2014.06.19. 13:36

Re: seamonkey

Hozzászólás Szerző: NTamas »

Jó vicc, adjál olyan glibc verziót, ami a Precise puppyval teljesen kompatibilis, és nem omlaszja össze azt!
A Precise tárolójában nincs ilyen glibc verzió,
Kép
amúgy ez nem az első ilyen dolog, amikor a Precise-be épített 2.15-ös glibc-nél magasabb verziószámú glibc-et igénylő program nem indul el a Precise alatt.
Végül figyelmedbe ajánlom nocsak ezirányú fórumbejegyzését, ahol ő újabb gibc verzióvak kísérletezve simán megborította a saját rendszerét!
Nyakra-főre nem lehet csak úgy glibc-et cserélgetni!

ticoo1
Hozzászólások: 546
Csatlakozott: 2014.10.21. 08:58

Re: seamonkey

Hozzászólás Szerző: ticoo1 »

Szia!
De van megoldás, pl.UPre és a többi. Sajnos "nocsak" azon bejegyzését olvastad, ami régi! Most írtam róla, itt:
viewtopic.php?f=7&t=787&p=8329#p8329

NTamas
Hozzászólások: 1710
Csatlakozott: 2014.06.19. 13:36

Re: seamonkey

Hozzászólás Szerző: NTamas »

Nem a kérdésemre válaszoltál, amit írtál, azt is olvastam, de ez egyáltalán nem megoldás a csak Precise-t futtatni képes gépekre!!!
Nyilván akinek a gépe képes a Bionic, Upup verziók futtatására, annak a magasabb glibc verziószámú rendszerek miatt eleve nem lesz gondja az új Seamonkey verzióval sem!
De akik még csak a régi Precise-t tudják csak futtatni a régi gépeiken nekik viszont igencsak problémát fog okozni ez a váltás a Mozilla project részéről, amit amúgy simán elhalaszthattak volna az újabb, általuk említett átmeneti 2.53 verziók kihozásáig.
Szóval amit Ti kitaláltatok újabb puppy verziókat,azok egyáltalán nem a régi gépekhez valók, azokhoz ezek a verziók eleve nem lesznek jók!
De ezt amúgy Ti is jól tudjátok!

NTamas
Hozzászólások: 1710
Csatlakozott: 2014.06.19. 13:36

Re: seamonkey

Hozzászólás Szerző: NTamas »

Amúgy meg amit írtál:
... Abban is sikerült egyességre jutnunk, hogy alapértelmezésben a K-4.6.3-as Pae és 64 bites kernelt fogjuk a továbbiakban használni, mivel ezen kernelek illeszkednek legjobban a régebbi eszközeinkhez. De, mivel a rendszer „Huge“ kerneles (mint minden modern puppy), ezért természetesen bármely más huge kernel is használható, csak a „vmlinuz és a zdrv_...sfs“ párost kell cserélni (a zdrv_...sfs-t természetesen az adott puppy-nak megfelelően át kell nevezni!). ...
ez egyáltalán nem segíti azon valóban régi gépeket használókat, akik masináikon csak egy Precise-t tudnak már csak futtatni, de a gépük még ettől eltekintve jól használható. Velük simán kibabráltatok a mindenáron való 64 bit és a magasabb kernelek nomeg a huge kernel őrület okán.

ticoo1
Hozzászólások: 546
Csatlakozott: 2014.10.21. 08:58

Re: seamonkey

Hozzászólás Szerző: ticoo1 »

Még mielőtt tovább lépünk, itt van ez:

https://sourceforge.net/projects/puppys ... libc-2.17/

Elvileg a precise busybox-szával összecseng, de nyilván először live módban próbál ki. A HuBi-pup32 akár K-3..-tal is megy rendesen, de teszek fel egy iso-t.

gjuhasz
Hozzászólások: 99
Csatlakozott: 2014.08.17. 13:52

Re: seamonkey

Hozzászólás Szerző: gjuhasz »

NTamas írta:
2019.09.10. 10:42
Jó vicc, adjál olyan glibc verziót, ami a Precise puppyval teljesen kompatibilis, és nem omlaszja össze azt!
A Precise tárolójában nincs ilyen glibc verzió, amúgy ez nem az első ilyen dolog, amikor a Precise-be épített 2.15-ös glibc-nél magasabb verziószámú glibc-et igénylő program nem indul el a Precise alatt.
Végül figyelmedbe ajánlom nocsak ezirányú fórumbejegyzését, ahol ő újabb gibc verzióvak kísérletezve simán megborította a saját rendszerét!
Nyakra-főre nem lehet csak úgy glibc-et cserélgetni!
Sziasztok,

Huhh, nagyon gyorsan jönnek a hozzászólások, azalatt is jött kettő, amíg ezt írtam.
Próbálkoztatok valami ilyesmivel?

$ LD_LIBRARY_PATH=.

Ezzel az adott futtatható fájl mappájában keresi a libeket először és csak utána a standard helyeken. A seamonkey-nek tetsző glibc-t be lehet tenni a seamonkey mappába, a régi glibc maradhat ott, ahol bevált a többi alkalmazás számára.

Vigyázat! Csak a seamonkey-t kell így indítani egy szkriptből, különben ezután a változtatás után a TÖBBI alkalmazás is a saját mappájában kezdi a libek keresését!

Bocs, ha a fenti tanáccsal összeomlasztanám bárkinek a rendszerét. Nem vagyok Linux gépközelben, a munkahelyemen nem próbálhatom ki. A Puli Precise változatán megtenném gond nélkül... :)

Jó terelgetést!

Üdv

gjuhasz
A hozzászólást 1 alkalommal szerkesztették, utoljára gjuhasz 2019.09.10. 12:00-kor.

Avatar
KuLuSz
Hozzászólások: 526
Csatlakozott: 2014.06.17. 21:19

Re: seamonkey

Hozzászólás Szerző: KuLuSz »

1 adott gépen nem azért indul el 1 rendszer mert precise csomagokból épült, hanem a kernel miatt képes elindulni, azaz kompatibilis a géppel...

gjuhasz az LD_LIBRARY_PATH nemhiszem hogy ilyen egyszerüen megenné az új libc verziót , minimum kell hozzá 1 ldconfig parancs ami betölti a megadott új elérési utat ...
(ha ennyivel meg lehetne oldani a libc cserét, akkor nagyon boldogak lennénk) nocsak-al már próbáltuk mindenhogy megadni ezt, sehogy sem sikerült .
-<(].K.u.L.u.S.z.[)>-
-----------------------------------------------
Elérhetőségeim: Angol irc csevegő, (reg mentes) Discord, YouTube

Avatar
KuLuSz
Hozzászólások: 526
Csatlakozott: 2014.06.17. 21:19

Re: seamonkey

Hozzászólás Szerző: KuLuSz »

mellesleg a cserélhető huge kernelek között van 3-as nopae verzió is, lehet érdemes lenne tenned 1 próbát NTamas
http://distro.ibiblio.org/puppylinux/huge_kernels/
-<(].K.u.L.u.S.z.[)>-
-----------------------------------------------
Elérhetőségeim: Angol irc csevegő, (reg mentes) Discord, YouTube

gjuhasz
Hozzászólások: 99
Csatlakozott: 2014.08.17. 13:52

Re: seamonkey

Hozzászólás Szerző: gjuhasz »

Kulusz, biztos igazad van, de nem tudom kipróbálni.

Ha kell ldconfig, akkor valószínűleg elég az ld.so.cache-t frissíteni:

ldconfig -v

Jó terelgetést!

Üdv

gjuhasz

Válasz küldése

Vissza: “Internet”