Dpup Stretch

Egyéb operációs rendszerekkel kapcsolatos leírások, infók, hírek
willy36
Hozzászólások: 81
Csatlakozott: 2017.05.16. 17:43

Re: Dpup Stretch

Hozzászólás Szerző: willy36 » 2017.11.30. 19:56

Tamás és azami, köszönöm ezt a kis értekezletet, sokat léptem előre ezzel a "kis" lökettel :)
A hozzászólást 1 alkalommal szerkesztették, utoljára willy36 2017.11.30. 19:59-kor.

NTamas
Hozzászólások: 1424
Csatlakozott: 2014.06.19. 12:36

Re: Dpup Stretch

Hozzászólás Szerző: NTamas » 2017.11.30. 21:03

Akkor még egy kis löket....

A Dpup Stretch-ben tesztelgettem a Chromium böngészőt, és megakadt a szemem egy kissé harsány PC World-ös cikken, ezen:
... Ezt se felejtsd el, ha a Chrome-ról a Firefox Quantumra váltanál ...
Kicsit morgok magamban miközben a cikket olvasom, hogy minek is váltsak én most a Quantum Firefox-ra a maga majd 300Megás telepítés utáni méretével az amúgy sem egy helytakarékos cucc, és gyakorlatilag mi is az előnye? - jó tud több szálon dolgozni, na ezt a többiek is tudják, van egy beépített képmetszője, nagy ügy, sokkal kezelhetőbbek erre a célra a puppykban megszokott, kicsi és ügyes programok, ráadásul azok kezelése jobban kézreállóbb.
Azt mondják gyors, de hiszen a Chromium sem egy lassú böngésző, a különbség meg nem ér meg annyit, hogy egy behemóttal több legyen a gépemen, így is már 2.2GiB méretű a személyi mentésfájlom, a merevlemezen meg egyre kevesebb a hely. Biztonságosabb, így hírdetik a Firefoxot az ismertetőjében, hát lehet, de a többiek sem egy sok lyukas ementáli sajtra emlékeztetőek e téren, viszont a Firefox most kissé hazavágta a megszokott kiegészítőit, és ez igen csúnya húzás volt tőle, így aki a megszokott, és bevált dolgait akarná használni, lehet hogy lesz olyan kiegészítője, amit cserélnie kell majd. Persze ez idővel kialakul majd, és a kiegészítők terén is helyreállhat a megszokott rend, de tény, lesz/van olyan jól bevált kiegészítő, amitől (a rendszerben történt változtatások miatt) búcsúzni kényszerülünk.
Ezzel szemben a Chrome, Chromium meg nem szenved hiányt kiegészítőkben, alkalmazásokban.
A Firefox, talán engesztelésül emiatt most bedobta a köztudatba a Momentum nevű igen jópofa kiegészítőjét, ezzel a beépülővel (idézem) gyönyörű háttérképre, motivációs idézetre, időjárásra, órára és a napi fókuszunkra cseréli az új lapot a Firefox-ban. Hmm... ez nem is olyan rossz. A Momentum personal dashboard kiegészítőnek az elkövetőit ezen a weboldalon ismerhetjük meg: https://momentumdash.com/about - és ezen az oldalon azért azzal is szembesülnünk kell, hogy a szoftver többet tudó, Plus verziójára bizony csak fizetés ellenében térhetünk majd át. Nem egy nagy összeg a ($2.50/month) kifizetendő pénz, de mindenki döntse el magában, hogy szüksége van e a fizetős Plus verzió szolgáltatásaira.
Az alapverziót egyébbként Firefox-ra és Chrome-ra is le tudjuk innen tölteni, és ha ez így van, márpedig így van, akkor a Dpup-ban működő Chromium-ra is rá lehet ezt varázsolni, itt a Chrome internetes áruházbeli link, ahonnan ezt a jópofa beépülöt leszedhetjük magunknak:
https://chrome.google.com/webstore/deta ... ejjkokdgca
És így néz ki a Chromium böngésző nálam a feltelepített Momentummal.
Kép
A telepítéskor egy nevet kér majd, ezen a néven fog minket üdvözölni, és kér még egy E-mail címet is, de ezt most még nem kötelező megadni, enélkül is működik az alapszoftver. A cuccot beállítani a balodalt alul látható kis fogaskerék ikonnan lehet, ha rábökünk az egérrel, egy ilyen beállító ablak nyílik meg nekünk.
Kép
Még nekem is új a dolog, de talán már van közöttünk olyan Firefox Quantumot használó fórumtagunk, aki ebben a beállításokban segítséget tud esetleg adni, előre is köszönjük neki a plusz infókat.

azami
Hozzászólások: 935
Csatlakozott: 2014.06.20. 19:25

Re: Dpup Stretch

Hozzászólás Szerző: azami » 2017.12.01. 19:21

Az Ntamás által ajánlott Dpup-on ment a vlc chrome páros, a skami által belinkelten sajnos egyik nem.
(Hp laptop,64 bit, intel i3 cpu, intel vga 5500)

NTamas
Hozzászólások: 1424
Csatlakozott: 2014.06.19. 12:36

Re: Dpup Stretch

Hozzászólás Szerző: NTamas » 2017.12.01. 21:04

Na, ez egy jó hír, gondolom már rád fért egy kis sikerélmény, olvasva a másik topicban írt nem túlzottan sikeres új puppy verzió telepítését...
Amúgy ebben az általam belinkelt verzióban -telepítés után a csomagkezelőt azonnal frissíteni!- a csomagkezelő a letölthető Chromium 61 webböngésző debianos telepítője mellé nem hozta le automatikusan annak a nyelvi fájlját, mondjuk ezen kissé meglepődtem, és emiatt a letöltött Chomium 61-es böngésző eddig angolul kommunikált, mint azt a fentebb lévő képen is látni.

Maga az eredendően angol nyelvű Dpup Stretch verzió is egészen sikeresen magyarítható ezzel a régi, bevált pet csomaggal: langpack_hu_120328.pet

Na, de ha már sikerült az oprendszert majdnem teljesen magyar nyelvűre átalakítani, akkor nehogy a Chromium angolul dumáljon már nekem!
Még élénkem emlékszem arra, hogy nemrégiben a Tomas Matejicek féle debianos Slax Linux 9 kipróbálásakor annak a csomagkezelőjében ugyanez a debianos Chromium böngésző volt letölthető, azzal a különbséggel, hogy ott a böngészőhöz tartozó nyelvi fájlok nemzetek szerint fel voltak darabolva, így lehetővé vált a csak magyar nyelvi fájlt letölteni a Chromiumhoz. Persze annak a csomagkezelője sem hozta le automatikusan a nyelvi fájlt, de ezt akkor be tudtam annak, hogy erősen béta verzióról volt szó.

Viszont a Radky féle Dpup már a2-es besorolású, így joggal remélhettem, hogy itt már a csomagkezelő a webböngészővel együtt lehozza annak nyelvi fájlját is, annál inkább mert itt már egy darab! nyelvi fájlról van szó! - és ezt nem lett volna nagy művészet a függőségek okán lehozni, na mindegy, emlékezve az előbb említettekre, most a csomagkezelőben rákeresten a file nevére, és lőn, van nyelvi fájl, gyorsan le is hoztam.
A képen -középen-a már letöltött nyelvi fájl látható.(ezt kell megkeresni, és letölteni a magyarrá váltáshoz)
Kép
A külön letöltött nyelvi file telepítése után a böngészőben is be kell állítani, hogy milyen nyelvet preferáljon
a Chromium, majd egy újraindítás után már magyarul fog kommunikálni velünk a Chromium webböngésző.
Jól látható a következő képen, hogy a böngésző már a hibaüzit is, és a beállító ablakot is ékes magyar nyelven adja elő.
Kép

Persze azért egyes, csak angol nyelvű programok esetében még marad az angol nyelv, -lásd a képen a Momentum esetében is- de ha már sikerült is -ha nem is egészen- magyar nyelvezetre átállítani az OS-t, akkor azon programok esetében -mint most pl. a Chromium- ahol rendelkezésre áll a programhoz a magyar nyelvi kiegészítés, fájl, érdemes azt leszedni, és alkalmazni.

NTamas
Hozzászólások: 1424
Csatlakozott: 2014.06.19. 12:36

Re: Dpup Stretch

Hozzászólás Szerző: NTamas » 2017.12.02. 18:28

Sziasztok, vagy itt a fórumban, vagy a főoldalon, a chaten jegyezte meg egy fórumtársunk, hogy a Dpup Stretch-re nem megy fel a wine csomag, nem működik nála. Eléggé elgondolkoztató a dolog járjunk kicsit utána. Természetesen az általam használt, és mára már jócskán felbővített 32 bites Radky Dpup Stretch féle isó ból készített puppy a vizsgálódás alapja, a gyári csomagkezelőben van ugyan valami wine féleség, de finoman szólva.....
Kép
Kép
A képen is látható, hogy a csomagkezelő tartalma igencsak szegényes, van ugyan benne valami wine nevezetű dolog, de annak a mérete 170 valahány kbájt, szóval nem komplett cucc, és a csomagkezelő egyetlen filét említ meg függőségnek, ami szintén kisméretű file, szóval ez nem túl biztató kezdet. A csomagkezelő által felhozott debian fájlok között van ugyan egy kb:170MB-nyi méret fájl, talán az lenne az igazi, hozzá tartozó wine függőség, de ezt a csomagkezelő nem is ajánlja fel-nem hozza fel, mint függőséget, szóval ez így kicsit savanyú.....hagyjuk is a dolgot, és gondolkozzunk kicsit. Az ok, hogy ez a Dpup verzió elvileg debian alapra, csomagokra épít, de ettől még ez egy puppy verzió, és mint ilyen, kutya kötelessége futtatni, működtetni a régi, bevált puppy-s csomagokat is. Szóval, akkor tegyünk rá egy már bevált puppy-wine csomagot, és lássuk mire megy vele a Dpup Stretch.
Csak halkan jegyzem, meg, hogy a kép jobb alján nem véletlenül van ott a már nálam működő, Windowsos RadioSure lejátszó program kicsinyített képe! :D

Mivel a csomagkezelőből való Wine telepítést elvetettem, maradt a másik lehetőség, a pet csomagból való Wine telepítés, én ezt a csomagot használtam fel hozzá, mivel ez nálam eddig is jól teljesített.
wine-1.5.15-i686.pet
Csak ezt a fájlt használtam fel, de van még ehhez tartozó doc és dev pet csomag is, aki akarja, az ezeket is felteheti, itt van a linkjük,
wine_DEV-1.5.15-i686.pet
wine_DOC-1.5.15-i686.pet
bár én most nem használtam fel ezeket a dev és doc pet csomagokat, mert ezek nélkül is működik nálam a Wine, az alap(wine-1.5.15-i686.pet) pet csomaggal.

Szóval, feltelepítettük a pet csomagból a wine-t és az így fog beépülni a puppy főmenüjébe.
Kép
Ezek után essünk neki a wine beállításának, és kattinsunk rá a képen is látható menűbejegyzésben a wine config-ra, mire a wine-config program kérdéseket fog feltenni nekünk, az első kérdése, hogy feltelepítjük e a net-kereteket használó windowsos programokhoz szükséges mono csomagot,
Kép
én erre a Mégse gombra ütve válaszolva kihagytam ennek a csomagnak a feltelepítését, egyrészt mert kevés volt a helyem a merevlemezen,(az említett mono csomag több, mint 100Mega!) másrészt tudtam, hogy nekem csak pár windowsos program fog a gépre felkerülni, és ezek nem igénylik a net-keretprogram támogatást.
A második kérdése a wine config-nak ez volt,(azért az rém érdekes, hogy az első kérdést még angol nyelven intézte hozzánk, míg a második kérdést már magyarul tette fel a program!)
Kép
nos, ezt a gecko csomagot viszont én lazán feltelepítettem, mert ez szinte mindíg kelleni fog, és a működő netről pillanat alatt lehúzta, és feltette a gecko telepítő csomagot a wine config, majd ezután pár pillanat múlva feldobott egy ablakot, amiben megkapjuk a wine már jól ismert, és megszokott beállító ablakát.
Kép
A beállító ablakon belül a felső füleken lépkedve először is nézzük meg a wine logóját, hogy ellenőrizni tudjuk valóban a kiszemelt wine verzió települt fel nekünk.
Kép
Ezek után a füleken váltsunk át Hang fülre,
Kép
és ott katintsunk rá a Teszt hang kockára, ekkor egy rövid hang szignált fogunk hallani, ha rendben megvan a hang, akkor itt jobbra alul kattintsunk rá az Alkalmaz gombra is, majd ezután váltsunk át a felső füleken a Meghajtók fülre, és elvileg ezt fogjuk látni.
Kép
Nos, itt lesz egy kis tennivaló, kattintsunk rá az Automata felismerés gombra, és ezt kell látnunk ezek után,
Kép
ha a képen látható módon a program rendben felismeri a root és a gyökér meghajtót, akkor végeztünk is az alap beállítással, bezárhatjuk a wine-config ablakot, és nekiállhatunk a wine-s programjaink feltelepítésének.

Én ezt a telepítést egyben letudtam oly módon, hogy a már bevált precise puppy-n lévő Wine-ből áthoztam azokat a windows-os programokat, amiket itt is használni kívántam, természetesen a Dpup főmenüjébe való bekerüléshez szükséges desktop filéket és ikonokat a megfelelő helyre be kellett másolnom, és ennyi, ezután a desktop ikonokat az asztalra is kihúzva már innen is elindíthatóak lettek a megszokott windowsos programjaim.
Ezen fórumos beírás közben a háttérben szólt a zene, amit a RadioSure program szolgáltat azóta is, rendületlenül. Időközben ráadásul a netről bővült is a program adatbázisa! A feltelepített és nálam működő programok képei
Kép
Kép
Kép
Kép
A Aeromap PC programot pedig újra regisztráltam a neten keresztül, sikeresen, sajnos ehhez a programhoz most még nem jött újabb frissítés, de a régi is jól használható azért, Szóval én így oldottam meg a Dpup Stretch wine telepítést.

willy36
Hozzászólások: 81
Csatlakozott: 2017.05.16. 17:43

Re: Dpup Stretch

Hozzászólás Szerző: willy36 » 2017.12.03. 17:09

NTamás köszönöm a munkádat, mostmár nálam is rendben fent van a wine.

Azami-nak a problémájára írom, ahol azt írja, a VLC Player nem ment fel a S-kami féle verzióra, hogy ha a puppy package manager-ben a vlc-nox_2.2.6-1-et választja, szó nélkül feltelepült nálam, és működik. Nekem is a S-kami féle verzió van fent.

Firefox Quantumnál is volt gond a telepítéssel, ott tar.gz2 file-ból kitömörítve működik, Puppy Package Manager-ből készített sima telepítés után nem indult el.

https://ftp.mozilla.org/pub/firefox/rel ... x-i686/hu/

Remélem, jó helyre írtam, ha véletlen nem felelne meg, légyszíves szólj, törlöm vagy áthelyezem másik helyre a reagálásom, nem szeretném összekoszolni a munkád.

NTamas
Hozzászólások: 1424
Csatlakozott: 2014.06.19. 12:36

Re: Dpup Stretch

Hozzászólás Szerző: NTamas » 2017.12.03. 17:41

Örülök, hogy nálad is sikeresen lezajlott a wine telepítése!

azami
Hozzászólások: 935
Csatlakozott: 2014.06.20. 19:25

Re: Dpup Stretch

Hozzászólás Szerző: azami » 2017.12.03. 17:58

willy36 írta:
2017.12.03. 17:09
NTamás köszönöm a munkádat, mostmár nálam is rendben fent van a wine.

Azami-nak a problémájára írom, ahol azt írja, a VLC Player nem ment fel a S-kami féle verzióra, hogy ha a puppy package manager-ben a vlc-nox_2.2.6-1-et választja, szó nélkül feltelepült nálam, és működik. Nekem is a S-kami féle verzió van fent.
Az egyiken sem kép sem hang a másikon a Vlc jó, a Chromium beállítások menü nem látható vagyis nem tudok bejelentkezni sem többek közt :?

NTamas
Hozzászólások: 1424
Csatlakozott: 2014.06.19. 12:36

Re: Dpup Stretch

Hozzászólás Szerző: NTamas » 2017.12.23. 13:20

Sziasztok, ahogy a chaten is jeleztem, -némi betűhibával tarkítva- Radky egy újabb, Dpup Stretch 7.5 32-bit CE (RC) vevű verzióval jelentkezett, ebben eléggé sok hibajavítást eszközölt, ha jut rá idő, ünnepek alatt megnézem, már ha elindul egyáltalán a gépemen.
A hozzászólást 1 alkalommal szerkesztették, utoljára NTamas 2017.12.24. 03:11-kor.

NTamas
Hozzászólások: 1424
Csatlakozott: 2014.06.19. 12:36

Re: Dpup Stretch

Hozzászólás Szerző: NTamas » 2017.12.24. 03:08

Ahogy ígértem, egy kis beszámoló, hogy az újabb Dpup Stretch verzió hogyan is működik, mi javult benne, és mi az a változtatás új verzióban, ami viszont nem nyerte el a tetszésemet.
Frugall telepítésként tettem fel a merevlemezre, a mentés viszont már nem fájlba történt, mint régebben, hanem az újabb puppy verzióknak megfelelően egy könyvtárba mentette el a feltelepített, beállított dolgokat.
Hogy a végeredménnyel kezdjem, így néz ki most nálam az újabb -kissé felhízlalt- Dpup Stretch 7.5.
Kép

Az már szinte borítékolható volt, hogy a memória használat kijelzése ismét kívánnivalőt fog maga után hagyni.
Kép

A sysinfó egy részlete, pár fontos adattal.
Kép

Ja, igen, a fentebb már leírt módon ez a verzió is egészen sikeresen magyarítható ezzel a régi, bevált pet csomaggal: langpack_hu_120328.pet, nem lesz teljesen magyar nyelvű minden, de azért a végeredmény több, mint a semmi.
A puppy főmenüje legalább már nagyobbrészt magyar nyelven köszönt minket, ha nem is lett benne teljesen magyar mindegyik menűpont.
Kép

Érdekes módon most három filekezelő program van benne alapból, gyárilag!
Kép

A klf medialejátszó programok aránylag könnyen feltehetők rá, és jól működnek.(*)
Kép

(*) Igazából ebbe a témakörbe tartozik az általam kifogásolt, és itt már alkalmazott nemszeretem megoldás.

Nevezetesen ebben a Dpup-7.5 RC verzióban az előző radky-7.0.0a2 verzióval ellentétben már nincsen benne a megszokott Retrovol, hanem egy PNMixer nevű tálcaalkalmazás került a helyébe,
Kép

A megszokott, és jól működő alsa mixert itt sajnos összekutyulták egy Gnome Alsa mixer nevű szörnyre,
Kép
szerintem baromi ronda a kinézete, arról nem is beszélve, hogy a pontos beállítást semmi nem segíti, a beállító potméter csúszka mozgatására nem jelzi ki a mixerben a hangerő százalékos változását, ezt csak a tálcán lévő ikonra vitt egér esetében teszi meg, illetve akkor is, ha rákattintunk a PNMixer nevű tálcaalkalmazásra. Szóval a ronda Gnome mixer szörnyben jó szem szükséges ahhoz, hogy azonos hangerő szinteket tudj beállítani.
Elvileg be lehetne állítani, -nálam ez nem működött valamiért!- hogy a csatornánkénti beállító potméter dupla kijelzésű legyen az alap szingle kivitelhez képest, de mivel ezt a kunsztot nálam nem lehetett előcsalogatni sehogysem, így azt nem tudom, hogy ez mennyiben javítaná a kezelési konfortot. (már ha működne, egyáltalán)

Alapból azért ez is jól felismerte az integrált hangkártyámat, rögtön ugatott is a kiskutya, érdekes módon az integrált hangártyát itt már a beállításban csak defaultként jegyzi, és másodikként csak az Intel ICH5 választható ki a hangcard-nál, a retrovolnál megszokott bővebb hangeszköz lista itt már nincs meg. Azért az érdekes, hogy a feltelepített vlc-2.2.6-ban a hangeszköz lista jóval bővebb, és ott pl. nekem az Intel ICH5-öt kellett kiválasztani ahhoz, hogy legyen hangja a vlc-nek.(a vlc default hangeszközével -valami ismeretlen nevű beírás alapból az első sorban!- nálam nem volt hangja a lejátszónak)
Továbbá egy nagy hiba az, hogy a Multimédia menüben két mixer van, -lásd a képen- de a Generic mixer nevű bejegyzés is a Gnome Alsa mixert indítja el, érthetetlen módon, én azt reméltem, hogy legalább a Generic mixer a szokásos alsamixert hozza fel, hát tévedtem!

Egy módon azonban előhozható az igazi alsamixer, ezt pedig az Alsa Soundcard Varázsló menüjének a Multiple Sound Card beállítási részében tehetjük meg,
Kép
ahol is a képen látható, zöld pipával kiválasztott hangeszköz kijelölése után alul rábökünk a configure menüpontra, na, ekkor kapjuk csak meg a jól ismert alsamixert az alapbeállításhoz. Akinek valamiért nem ismeri fel a gépe a hangeszközét, vagy netán több hangcarddal bír a gépe, annak ebben a menüpontban lehet keresnivalója.

Még egy újítás, az alapból az összeállításban szereplő mplayer futtatható (/usr/bin/mplayer) fájl már nem a régi puppyknál megszokott, bevált stabil verzió, hanem egy jóval kisebb méretű, de már magasabb verziószámú mplayer, ami együtt tud működni az összeállításban gyárilag szereplő mpv médialejátszóval is.
Emiatt sajnos le kellet mondanom arról, hogy a Tahr puppykban bevált jó kis 18-19Megás mplayer bin fájlomat ide betegyem, de az mplayerhez tartozó codeck könyvtárat azt viszont komplett pótolnom kellett, mert még az alap codeck könyvtár sem szerepelt ebben a Dpup verzióban, kissé érthetetlen módon. Ennek ellenére a szintén magasabb verziószámú, és alapból az összeállításban lévő gnome-mplayer érdekes módon simán lejátszott standard médiafájlokat! Sajnos helyhiány miatt a wine-t már nem tudtam feltenni, kipróbálni, de valószínűsíthető, hogy az előző verzióban is sikerrel telepített wine csomag itt is működni fog.

A Dpup Stretch-7.5-ben lévő angol nyelvű Palemoon webböngészőt én lecseréltem a legújabb verziójú magyarra, és mellé még feldobtam a legújabb magyar nyelvű Seamonkey-t is, mindkét böngésző rendben teszi a dolgát.
Hát ennyi, egyenlőre...a retrovol hiányát leszámítva nagyobb hibával még nem találkoztam, szóval ez a verzió is mindenképp kipróbálandó kategória, noha a benne lévő kernelek már PAE-s kivitelűek.

Válasz küldése

Vissza: “Egyéb OS”