Pale Moon

Böngészők, üzenetküldők, levelezők, stb...
NTamas
Hozzászólások: 1499
Csatlakozott: 2014.06.19. 13:36

Re: Pale Moon v28-nincs h264...

Hozzászólás Szerző: NTamas » 2018.08.17. 12:35

Azért csak nem hagyott nyugodni az a dolog, amit a youtube html5 tesztoldal mutatott, nevezetesen a h-264 codeck hiányát. Az előbbi weboldalon közölt -lefotózott- Help megjegyzés indította be a kíváncsiságomat, és amúgy is bosszantott a dolog, nem létezik, hogy egy új verziójú Palemoon ne tudjon h-264-es videót megjeleníteni.

Nos, a Palemoon Help-je kitér arra, hogy a hibátlan Media Source Extensions-hoz telepített FFmpeg megléte feltétlen szükséges. Nos, ez nálam az említett, és a próbára használt tahrpup-6.0.5-ös puppyban adott, a csomagkezelőből elérhető ffmpeg-2.2.9-i686 csomag eleve már telepítve van a gépre, akárcsak a h-264-es, és a h-265-ös codeck is. Mégsem jó a dolog, lásd a fenti képen a középen lévő két piros hibaüzit.
Mi lehet a gond, rövid gondolkozás után leesett a tantusz, nemcsak az ffmpeg kell ide, hanem még más is.(kodeck hiány ugyi.....!)
Nekiestem a csomagkezelőnek, és ez lett a végeredmény, ezek kellenek még a tahrpuppyba. (de szerintem máshova is!)
Kép

Ezen hiányosságok telepítése után a youtube html5 tesztoldal már hibátlan képet mutat!
Kép

Na, ezt már szeretem!
És akkor gyerünk az ajánlott kísérletezős weboldalra, és ott jól látható, hogy már sokkal több a kiválasztható médialejátszási lehetőségünk.
Kép
Szóval néha jól jön -mint jelen esetben is- a hibaüzenet ablak figyelmes olvasgatása..... :D .....és mindjárt megvan a megoldás!

Kép

NTamas
Hozzászólások: 1499
Csatlakozott: 2014.06.19. 13:36

Re: Pale Moon új v28-as verzió.

Hozzászólás Szerző: NTamas » 2018.08.18. 13:11

Sajnos az új verziójú Palemoon webböngésző sokkal több erőforrást igényel magának, mint a régebbi, 27-es verziók, ez legjobban, leglátványosabban a html5-ös youtube lejátszáskor jön ki, a próbák alatt volt olyan eset is, hogy a webböngésző úgy kezdett el viselkedni, mintha megfagyott volna, nem reagált az egérrel beadott utasításokra, a html5-ös youtube lejátszón nem lehetett felbontást váltani, és bár mindeközben a megnyitott videó zavartalanul játszott, de azt se leállítani sem beletekerni nem lehetett. Ha néha sikerült is leállítani a videó lejátszást, csak akkor lehetett a felbontást, és a lejátszó beállítását változtatni, azt is csak nagyon nehezen. Először memóriahiányra gyanakodtam, de nem az volt a hiba, megfelelő fizikai és a puppyn belüli szabad memóriával is rendelkeztem, a processzort kb. 60%-ig terhelte le a htm5-ös youtube lejátszó, mindezek ellenére az említett hibajelenség többször is előjött, főleg, ha több youtube videó ablakot nyitottam meg.
Normál esetben, egy videó ablakban elindított lejátszás rendben működik, de ha a youtube lejátszón akarsz variálni, akkor már előjön(jöhet) az említett hiba.
Ez a régi, 27-es szériánál nem volt tapasztalható, pedig ott is html5-ös volt már a youtube lejátszó.
Ezen, szerintem eléggé fontos hiba miatt kénytelen voltam visszaállni a 27-es széria legutolsó, 27.9.4-es verziójára!
Itt legalább rendben működik minden.

Kép

Ez az új Palemoon verzió is már az erősebb, jobban felszerelt gépeknél fog jól tejesíteni, akinek gyengébb gépe van, -mint pl. nekem is- nos az szerintem jobban teszi, ha megmarad a 27-es szériánál, és azt használja addig, amíg lehet.

NTamas
Hozzászólások: 1499
Csatlakozott: 2014.06.19. 13:36

Re: Pale Moon

Hozzászólás Szerző: NTamas » 2018.09.03. 15:05

Na kérem, az új Palemoon verzió nem csak itt a puppy linuxosok körében verte ki a biztosítékot úgymond, hanem máshol, másnál is.
Nyilvánvalóan a korszerű, erős gépeken kevesebb a gond, gyakorlatilag csak elhanyagolható probémák jelentkeztek, de a régebbi, idősebb gépeknél viszont már adódtak gondok rendesen.

A hibák javítása, legalább is a fontosabbnak vélt javítások hamar megjöttek, erről a Palemoon fórumon adtak hírt.
Kép

A javított, v28.0.1-es verzió már letölthető, és kinn van már a linuxos javítás is! Onnan le tudjuk tölteni a tömörített új, javított verziót.
A javított változat feltételének előfeltétele a régi verzió teljes! lepucolása a gépünkről, a puppy verziónból.
Nem elég csak a palemoon könyvtárat kitörölni, a régi profilkönyvtárat is törölni kell!

A javított verzió telepítése előtt a régi verzióból mentsük el a könyvjelzőinket, a jelszavainkat, és jegyezzük fel, milyen addonok voltak telepítve a régi verzióra. Ezekből amúgy sem fogunk tudni mindent használni, de van olyan kiegészítő ami esetleg még használható az új verzión is. Ha ezek telepítője megvan, akkor jó, ha már nincs meg, akkor szerezzük be azokat a Netről a Palemoon verzió cseréje előtt.
Puppy linuxnál a /root-ban lévő .moonchild productions könyvtárat kompletten mentsük el magunknak, mert az új verzió másféle módon rögzíti a profilunkat. (mások a profilkönyvtárban létrejövő fájlok!)

Ha ezekkel megvagyunk, akkor a puppy csomagkezelőjével uninstalláljuk a régi Palemoon verziót, majd nézzünk utána, hogy minden a régi verzióhoz köthető bejegyzés, desktopfájl (az updater desktop fájlt is törölni kell!) profilkönyvtár törlődött e.
Ha igen, akkor jöhet a már előbb letöltött tömörített új verzió kicsomagolása, és a kézzel való telepítése.
Aki netán a Palemoon legutolsó, 0.24-es Linuxos telepítőjével próbálkozna, ne tegye! - mert nem fog menni! Az új verzióhoz még nincsen kész a Linuxos telepítő, így ezt az új verziót tartalmazó tömörített csomagot magunknak kell kézzel telepíteni.

A kibontott palemoon könyvtárat másoljuk be a puppyban az /opt-ba, (eddig is ott volt, elvileg) és az új desktop fájlt hozzuk létre a Palemoon weboldalán megadottak segítségével.

[Desktop Entry]
Version=1.0
Name=Pale Moon Web Browser
Comment=Browse the World Wide Web
Keywords=Internet;WWW;Browser;Web;Explorer
Exec=palemoon
Terminal=false
X-MultipleArgs=false
Type=Application
Icon=palemoon.png
Categories=X-Internet-browser
MimeType=text/html;text/xml;application/xhtml+xml;application/xml;application/rss+xml;application/rdf+xml;image/gif;image/jpeg;image/png;x-scheme-handler/http;x-scheme-handler/https;x-scheme-handler/ftp;x-scheme-handler/chrome;video/webm;application/x-xpinstall;
StartupNotify=true


Hozzunk létre egy symbolic linket az /usr/bin/ könyvtárba az új palemoon-hoz: (az /opt könyvtárhoz, ahová az előbb bemásoltuk a kibontott új Palemoon verziót)

ln -s /opt/palemoon/palemoon /usr/bin/palemoon

Ezután még az ikonképekhez is hozzunk létre symbolic linkeket:

ln -s /opt/palemoon/browser/chrome/icons/default/default16.png /usr/share/icons/hicolor/16x16/apps/palemoon.png
ln -s /opt/palemoon/browser/chrome/icons/default/default32.png /usr/share/icons/hicolor/32x32/apps/palemoon.png
ln -s /opt/palemoon/browser/chrome/icons/default/default48.png /usr/share/icons/hicolor/48x48/apps/palemoon.png
ln -s /opt/palemoon/browser/icons/mozicon128.png /usr/share/icons/hicolor/128x128/apps/palemoon.png

Kép

Ha ezekkel megvagyunk, indítsuk el az új Palemoon verziót. Töltsük le hozzá a magyar nyelvi fájlt, és állitsuk be a magyar nyelvet. Állítsuk be az új verziót, és töltsük vissza a lementett könyvjelzőinket.
A weboldalakhoz tartozó password-ökről se feletkezzünk el, azokat is tegyük vissza az írásos mentésünkből.
Ezután elvileg már semmi akadálya sincs az új verzió használatának.
Észre fogjuk venni, legalább is én észleltem, hogy az új verzió használhatóbb lett, az általam fentebb erősen kifogásolt youtube lejátszás is javult, már nem fagyokat, ha a youtube weboldalba beépített html5 lejátszón állítgatjuk annak config beállító részét.

Az újabb, javított Palemoon beállításában nem változott az MSE beállítása, maradt a már megismert beállító ablak.
Kép

A youtube videóknál viszont már látható a változás, a videó felbontás választásánál már újabb eddig még nem megszokott (p60) beállítások is elérhetővé váltak.

Kép
Kép
Kép

A youtube lejátszás érzésre kicsit javult, nálam már nem akadozik, mint a javítás előtti v28-as kiadás.
Szerintem most már érdemes kipróbálni ezt a javított verziót.
Én már egész délelőtt gyötörtem, de eddig komoly gond még nem jelentezett nálam.
A hozzászólást 1 alkalommal szerkesztették, utoljára NTamas 2018.09.03. 18:58-kor.

ticoo1
Hozzászólások: 258
Csatlakozott: 2014.10.21. 08:58

Re: Pale Moon

Hozzászólás Szerző: ticoo1 » 2018.09.03. 16:56

Kedves NTamas!

Köszönöm az információt, de egy apró kis észrevételem lenne. Ha már fent van a 28-as, akkor, ha kérem automatikusan elvégzi a frissítést és a szükségteleneket egy ...bak mappába dobja. Tartalma: profile-, updates mappa, stb. És igen, sokkal jobb.

NTamas
Hozzászólások: 1499
Csatlakozott: 2014.06.19. 13:36

Re: Pale Moon

Hozzászólás Szerző: NTamas » 2018.09.03. 18:39

De nem volt fenn a 28-as verzió, mert mint írtam feljebb, én a hibák miatt visszaléptem az előző verzióhoz és azt tettem vissza!
És én azt nem mertem megkockáztatni, hogy a v27.9.4-es verzióra ráfrissítsek, inkább maradtam a bevált tiszta telepítésnél.
A Palemoon weboldala is ezt ajánlja fel elsőnek, a lényeg az, hogy jobb lett, és javítottak benne pár nagyon idegesítő hibát.

Amúgy gyakorlatilag innentől -ahogy a Palemoon weboldala is írja- már nem beszélhetünk a hagyományos telepítésről.
A becsomagolt új verziót kibontva a webböngésző gyakorlatilag már működőképes. Persze az első (új) telepítéskor célszerű hozzá kialakítani a desktop fájlt a program menüből való indíthatóságához.

ticoo1
Hozzászólások: 258
Csatlakozott: 2014.10.21. 08:58

Re: Pale Moon

Hozzászólás Szerző: ticoo1 » 2018.09.04. 05:12

NTamas!

Tökéletesen igazad van! :!:

Az általad fellelt hibák miatt mindenki "dobta" a 28-ast, amiért igen hálásak vagyunk (egy-két bejegyzésben olvashattad is, hogy a megállapításaid miatt a használata egyelőre nem javasolt).

Igen és minden úgy van ahogy írtad és úgyis kell csinálni.

Én csak azért írtam a frissítőjét, mert már az is rendben működik. Mivel éppen portable böngészőket gyártok, "muszáj" volt kipróbálnom és ennek a tapasztalatát írtam le.

ticoo1
Hozzászólások: 258
Csatlakozott: 2014.10.21. 08:58

Re: Pale Moon

Hozzászólás Szerző: ticoo1 » 2018.09.05. 11:41

Készítettem egy palemoon28.0.1_hu.pet csomagot, az egyszerűség kedvéért. Mégsem...
A hozzászólást 1 alkalommal szerkesztették, utoljára ticoo1 2018.09.05. 13:15-kor.

NTamas
Hozzászólások: 1499
Csatlakozott: 2014.06.19. 13:36

Re: Pale Moon

Hozzászólás Szerző: NTamas » 2018.09.05. 12:29

Már nem azért, de a saját profilodat miért csomagoltad bele a pet csomagba? - én arra nem vagyok kíváncsi! - a magyarítása enélkül is lazán, és egyszerűbben is megodható, és nem kell a locale switch addonnal kínlódni.Eleve, ha teljesen magyart akarsz, nincs is szükség a locale switch addonra. az about:config használatával simán magyarra állítható a böngésző, ha előtte a 28-as nyelvi kiegészítést letöltöd hozzá.

ticoo1
Hozzászólások: 258
Csatlakozott: 2014.10.21. 08:58

Re: Pale Moon

Hozzászólás Szerző: ticoo1 » 2018.09.05. 13:09

Köszi, töröltem!

NTamas
Hozzászólások: 1499
Csatlakozott: 2014.06.19. 13:36

Re: Pale Moon

Hozzászólás Szerző: NTamas » 2018.09.05. 14:16

ticoo1 írta:
2018.09.05. 11:41
Mégsem...
Hogy emiatt ne maradjunk pet csomag nélkül.....igaz, ez a standard angol nyelvű pet csomag.
palemoon-28.0.1.en-US.linux-i686.pet

A telepített webböngésző az about:config használatával simán magyarra állítható, ha a telepítés után a 28-as nyelvi kiegészítést letöltöd hozzá a Palemoon weboldalától.
A hozzászólást 4 alkalommal szerkesztették, utoljára NTamas 2018.09.05. 20:19-kor.

Válasz küldése

Vissza: “Internet”