LX7 Puppy

Pupletek, Új puppy változatok, veruiók, ISO fájlok,
nocsak
Hozzászólások: 72
Csatlakozott: 2014.09.29. 15:01

LX7 Puppy

Hozzászólás Szerző: nocsak » 2017.02.05. 22:53

Üdvözlök mindenkit!

Hosszú-hosszú idő után elkészítettem ezt az LX7 Puppy remasztert, a release.htm fájlt megtekintve látható módosításokkal. Pár magyarázatra azért még szorul a produktum:

Sok belsőleges foltozgatás is van amit a release infóban nem taglaltam mert apróságok, mégis szükségesek voltak ezek általában valamely összetevő pl.: python kiegészítést jelentenek vagy szimbolikus linkeket a hiányos összetevőkhöz, vagy a repo valamennyire aktuálisnak tekinthető frissességét jelenti.

Kép: logo_nos.png

Aztán a flash is frissítésre került végül egy korábbi időpontban az angol tájékoztatásom ellenére amit most itt korrigálok.

A rendszer gyökerében található egy /smb/ mappa, ami a script asztali mappában található samba példa csatoló szkriptek nálam éles verzióinál volt célkönyvtár.

A root könyvtárban található továbbá egy jammer.zip állomány amelyben egy wifi jammer python alkalmazás lapul. Ezt első soron atheros chipek tesztelésére használtam, Githubról szereztem és a mellékelt függőségek is megtalálhatóak benne, bár én ezeket már feltelepítettem úgyhogy elég csak a python alkalmazást megfelelően használni. Ebből adódó károkért én nem vállalok felelősséget, ezt mindenki maga döntse el kell e nem kell e, és használja e.

Igyekeztem az alakítgatás hosszú ideje alatt nem zsákbamacskává hízlalni szegény kutyát és így fél-közép megalomán (CD méreten tartva azért) állapotában, valamint magamból kiindulva elsőként az általam élő rendszerhasználatnál fontos alkalmazásokkal felvértezni. Rendszerkövetelménye főként usbflash használata esetén 2gb ram-ra nőtt ahhoz, hogy az sfs cirka 635mb-os méretével a memóriából futhasson. Lehet 1gb is elég, de ha laptopokból indulok ki, ott az igp miatt lefoglal a memóriából alaphangon ~256mb-ot. Én szerencsére ezekkel a feltételekkel rendelkezem, így ismét magamból kiindulva mertem ekkorára hízlalni a rendszert. A LibreOffice alapból több mint 200mb emlékeim szerint plusz a többi kiegészítés miatt lett apránként ilyen nagy az sfs. Betölt és nagyjából legalábbis ami engem illet bevetésre kész. Ha valamit kihagytam volna a tájékoztatásból az a hosszú idő miatt lehet, de nem szándékosan. Maga a rendszer ugyanaz mint volt, csak kibővítettem-javítottam ott ahol kellőnek éreztem. Valamint ezúton is köszönöm az eredeti változat megalkotójának KuLuSznak az ez idő alatt nyújtott segítségét a megalkotáshoz!

Dropbox Link

RELEASE.HTM

nocsak
Hozzászólások: 72
Csatlakozott: 2014.09.29. 15:01

Re: LX7 Puppy

Hozzászólás Szerző: nocsak » 2017.02.09. 22:22

Időközben értesített a Dropbox, hogy a túl nagy adatforgalom miatt bekorlátozták a megosztásokat, ezt gondolom látta mindenki aki utóbb botlott bele a letöltési linkbe.
Remélem a következőkben ez nem lesz így, íme egy alternatív megoldás az eredmény 5 részletben az iso rar-ba csomagolva és külön a release.htm:

nos-lx7.splitted.part1.rar
nos-lx7.splitted.part2.rar
nos-lx7.splitted.part3.rar
nos-lx7.splitted.part4.rar
nos-lx7.splitted.part5.rar

RELEASE.HTM

nocsak
Hozzászólások: 72
Csatlakozott: 2014.09.29. 15:01

Re: LX7 Puppy

Hozzászólás Szerző: nocsak » 2017.06.04. 18:29

Új remaszter érhető el az LX7-es Puppy szintén legelső kiadásából eredeztetve. Ezúttal is mindent megkapott, de csak amit a legszükségesebbnek ítéltem van a rendszerben. Azokról egy rövid ismertetőt a RELEASE.HTM fájlban írtam ami megtalálható az iso-ban is. A végeredmény a NOS LX7 Trim kiadás nevet kapta, amely a töltőképernyőn látható lesz. Aki szeretné utólag felvértezni extrákkal, annak további csomagok sfs-ek lesznek elérhetőek ezen hozzászólás végén található linken. A kiadásban az éppen legújabb firefox kapott helyet az apulse módosítással, amit a a rendszeren teszteltem is. A flash-hez nem nyúltam. Vannak ugyanúgy járulékos függőség hozzáadások, illetve szimbolikus linkek amiket szükségesnek ítéltem de azokat nem részleteztem, mert nem akkora volumenűek. Ezt a fórumszálat figyelve utólagos kiegészítésekként esetleges módosításokról érdemes lehet követni. Az új iso és (majd) az extrák itt érhetőek el.

Avatar
KuLuSz
Hozzászólások: 385
Csatlakozott: 2014.06.17. 21:19

Re: LX7 Puppy

Hozzászólás Szerző: KuLuSz » 2017.12.03. 15:09

Kb 2-3 napja kipróbáltam az nvidia driver fordítását puppy alá, a nocsak féle videó szerint ( köszönjük ! ;) ). Nem is volt semmi gond , igaz a getnvidia nem ismerte fel a kártyát és nem töltötte le , de mint a videóból kiderül elég ha megkeresem a megfelelő linuxos forrás csomagot az nvidia honlapján , majd azt megeszi a getnvidia. Ennek kimenetele 3 fájl , amiből én most kettőt megosztok :
Az egyik az nvidia-glx-304.137-k3.2.32.pet és az nvidia-glx-304.137-k3.2.32.sfs csomag. A 3. csomag 1 doc csomag , szerintem nem szükséges ... A 2 csomagról még annyit érdemes tudni , hogy az Nvidia 7 series videókártyákhoz való .
A kártyák listája itt található !
Természetesen az Lx7_v2 puppy-n alkottam tehát ezzel biztosan müködik, amennyiben találtok más puppy-t ugyanezzel a kernel számmal ( 3.2.32 non pae ), akkor azon is müködni fog. Nyilván a nocsak féle trim verzión is müködik .

Mj.: Nálam annyi hiba volt hogy amikor próbáltam volna az új drájvert akkor a képernyő becsíkozódott , ami nem meglepő mert már a windows is ezt produkálta a drájver megléte esetén , mivel a kártyát valamelyik okos overclock-olta (túlhúzta). Tehát én maradok a mesa drájvernél. :D azzal még megy :P
-<(].K.u.L.u.S.z.[)>-
---------------------------------------
Általában megtalálható vagyok az Angol irc csevegőn vagy a Discordon KuLuSz néven.

Avatar
KuLuSz
Hozzászólások: 385
Csatlakozott: 2014.06.17. 21:19

Re: LX7 Puppy

Hozzászólás Szerző: KuLuSz » 2017.12.17. 22:25

No 1 rövidke kis videó az Lx7 v2 puppyról tőlem. Youtube LINK
-<(].K.u.L.u.S.z.[)>-
---------------------------------------
Általában megtalálható vagyok az Angol irc csevegőn vagy a Discordon KuLuSz néven.

nocsak
Hozzászólások: 72
Csatlakozott: 2014.09.29. 15:01

Re: LX7 Puppy

Hozzászólás Szerző: nocsak » 2017.12.29. 02:35

Üdv!

Valahol a forrásból fordítás és a sokadik remaszter között eljutottam oda, hogy szükséges lett 2 csomag, az openssl-1.0.2n valamint az openvpn-2.4.4 -re. Ezeket megelőzően szükséges puppy csomagkezelőből telepíteni a libssl és libssl-dev, valamint libpam és libpam-dev függőségeket.

Akit érdekel, annak a két csomag elérhetősége itt.
---

Jegyzem meg továbbá, hogy az LX7 alá tervezett mesa csomag meghiúsulása ellenére folyamatosan gyártok csomagokat ehhez a puplethez ahogy saját szükségem hozza. Akit érdekel a továbbiakban érdemes néha figyelni a fentebb írt elérhetőséget újdonságok után.

nocsak
Hozzászólások: 72
Csatlakozott: 2014.09.29. 15:01

Re: LX7 Puppy

Hozzászólás Szerző: nocsak » 2018.01.28. 00:31

Üdv mindenkinek!

Kellett exFAT csatolhatóságot varázsolni az LX7-be, így fordítottam egyet, nomeg hozzá a csatoló szkriptet ami samba-s volt eredetileg átírtam exFAT-osra, vagy FAT64-esre, kinek hogy tetszik. Amit tudni kell, hogy exFAT formázott meghajtó rácsatlakozásnál a Puppy alapból nekiiramodik, majd visszapattan sikertelenül és megjelenik egy ablak meghajtók csatolásáról. Namost azt szépen el kell felejteni - be kell zárni, cserébe viszont megmarad a PCmanFM-ben a /dev/ -beli elérési név. Ergo, ha van LABEL beállítva a meghajtónak akkor kb azzal és például (sdd) elérési névvel fog szerepelni.

Namost:

Ahhoz, hogy csatolni-lecsatolni-létrehozni tudjunk exFAT meghajtókat először telepítsük az általam 1.0 névvel valójában utólag kiderült, 1.2.7 verziójú pet csomagot, amit megtalálunk e hsz végén linkelve az LX7 Puppyhoz.


Aztán:

Átírtam rögtönözve a samba csatoló szkriptemet exFAT csatolóra, az is megtalálható a hsz végi linkkel. Az pedig egyértelműen működik. PCmanFM mutatja a /dev/ elérés nevét, mi pedig azt javítjuk ha kell a szkript példával is illsuztrált rubrikájában. A cél értelemszerűen amit megadunk, majd csatolásnál megjelenik egy másodlagos ablak, amivel a samba csatolónál megszokott módon tudunk eljárni a most épp exFAT meghajtónk ügyében.


Valamint még:

Kreálni így tudunk exFAT fájlrendszert terminálból: (Én mondjuk msdos táblával és törölt (GParted által) partícióra hajtottam végre)

Kód: Egész kijelölése

mkfs.exfat -n LABEL /dev/sdd
Ahol a LABEL a leendő címke, és az sdd a /dev/ elérése a meghajtónknak.

---

Időközben találtam fordítható exfat modult. Naná hogy elsőre nem sikerült, de átírtam a c fájlt és utána nyert ügynek tűnik. a nofuse csomag megtalálható szintúgy a hsz végi linkkel.

Telepítése után:

Kód: Egész kijelölése

modprobe exfat
majd

Kód: Egész kijelölése

cat /proc/filesystems
legalján ott kell szerepeljen és a csatolás a szkriptem nélkül is működni kell. (Köszönet KuLuSznak az ötletért, miszerint kellene modul legyen!)

Ellenőrizhető még:

Kód: Egész kijelölése

cat /proc/mounts

---

LINK

Avatar
KuLuSz
Hozzászólások: 385
Csatlakozott: 2014.06.17. 21:19

Re: LX7 Puppy

Hozzászólás Szerző: KuLuSz » 2018.03.09. 12:34

LX7 Puppy - Függőség vadászat FF48-hoz
Aki nem tudná hogy miről szól a "függőség vadászat" kifejezés. :D
-<(].K.u.L.u.S.z.[)>-
---------------------------------------
Általában megtalálható vagyok az Angol irc csevegőn vagy a Discordon KuLuSz néven.

NTamas
Hozzászólások: 1493
Csatlakozott: 2014.06.19. 13:36

Re: LX7 Puppy

Hozzászólás Szerző: NTamas » 2018.03.09. 14:28

Ez is egy megoldás, még ha ez kissé macerás megoldás is, de ennél van egy egyszerűbb megoldás is, és most maradjunk a libgtk3 témánál.
Elsőként szerintem a legjobb, legcélravezetőbb megoldás a hiányzó csomagra kompletten rákeresni a saját oprendszer csomagkezelőjében, és onnan telepíteni azt.
Még a már nem támogatott Precise 571 Pupy csomagkezelője is tartalmazza az újabb Firefoxhoz szükséges libgt3 csomagot, és azok egymáshoz viszonyított közvetlen függőségeit, szerencsére itt, ebben az esetben mindösszesen csak három .deb filét kell letölteni, és azt az oprendszerünkbe feltelepíteni. Ezen deb csomagok már tartalmazzák a videóban hiányolt lib...so.0 és a többi ilyen függőségi fájlt, amik szükségesek a teljes gtk3 rendes működéséhez.(és a Firefox helyes működéséhez)

Kép
Kép

(Nálam az jól látható, hogy a gtk3 már fenn van a rendszeren, és az újratelepítésre a rendszer csomagkezelője már nem kínálja fel az amúgy eleve szükséges függőségek megkeresését, és azok feltelepítését, simán csak a fő csomagfájlt ajánlja fel újratelepítésre.)

Látható, hogy nálam a régi Precise 571 lite puppy csomagkezelőjéből is még(szerencsére) elérhető a Firefox-hoz szükséges gtk3 főcsomag és annak függőségei, így onnan egyszerűen letölthető, és telepíthető minden fontos fájl. És ennyi, semmi felesleges ide-oda másolgatás, és ilyenkor abban is biztosak lehetünk, hogy az oprendszerünknek megfelelő gtk3 csomagot, és a függőséget szedtük le magunknak.
Ugyanis a gtk3 csomag több rendszerre is le lett fordítva, és az egyes rendszereken belüli fájlok eltérőek egymástól, és emiatt más rendszerre, pl. tahrpup, artful, xenial-ra való gtk3 csomagot(+ azok függőségeit) ne tegyük fel mondjuk a precise puppyra, még akkor sem, ha amúgy ugyan azt a célt szolgálnák, nevezetesen a gtk3 környezethez való illesztést, annak használatát.

Amennyiben az oprendszerünk csomagkezelőjéből már nem elérhető valami ok miatt a példánk tárgya, a gtk3 csomag és annak függőségei, úgy akkor azokat a netről kell levadásznunk, de itt is ügyeljünk arra, hogy a saját rendszerünkhöz valő fájlokat szedjük le, és telepítsük fel.

A példának említett Precise 571 Lite puppyn amúgy egy 52.6.0-s, 32 bites Firefox ESR verzió(ehhez már kell a gtk3) fut, ami simán képes a html videók, és azok netes streamjeinek lejátszására, hozzátéve azt, hogy ezen verzióhoz már szükség van a Pulseaudiós trükkre, a hanglejátszáshoz. Ezt én egy sima pet -pulseaudio-2.1-wheezy.pet- csomag telepítésével, és két, asztalra kitett ikonnal oldottam meg, utóbbiakkal indítom el, illetve állítom le a Pulseaudió emulációt.

Avatar
KuLuSz
Hozzászólások: 385
Csatlakozott: 2014.06.17. 21:19

Re: LX7 Puppy

Hozzászólás Szerző: KuLuSz » 2018.03.09. 17:14

A videó legfontosabb része , hogy terminálból indítom a programot hogy megtudjam mi a gond . Persze ezt már előre tudtam mert volt dolgom újabb firefoxokkal ... És a csomagkezelőből való letöltéshez csak annyit fűznék hozzá hogy , amíg nem futtatod le terminálból a programot , azt sem tudod meg mi a hiba konkrétan, itt most nem csak a firefox-ra kell gondolni . A másik dolog meg az hogy: oké letöltöd a csomagkezelőből az agyauristent is mire megtudod hogy melyik csomagban van az amit keresel egyátalán a programhoz . Tehát amíg terminálból indítod, és a neten összevadászott információkból rájösz hogy melyik csomagban van az a fájl amire neked szükséged van , az megint csak félóra szenvedés minimum (egy nem hozzáértőnek) . :D
Mj.: Ezért jó a forrásból való fordítás , mert ott minden függőségével együtt le tudod fordítani az adott programot az adott rendszerre ...
-<(].K.u.L.u.S.z.[)>-
---------------------------------------
Általában megtalálható vagyok az Angol irc csevegőn vagy a Discordon KuLuSz néven.

Válasz küldése

Vissza: “Pupletek”