Milyen/melyik program kell feltétlenül egy pupletbe?

Pupletek, Új puppy változatok, veruiók, ISO fájlok,
azami
Hozzászólások: 935
Csatlakozott: 2014.06.20. 20:25

Re: Milyen/melyik program kell feltétlenül egy pupletbe?

Hozzászólás Szerző: azami » 2015.04.28. 13:08

QuickPet-ben az Xnview parancsa is úgy van megírva hogy a hozzávaló függőségeket is letölti és telepít, vagyis nem bonyolult csak parancsikonokat tenni egy puppletbe ami majd lehozza a függőségeket is!

Nem tudom hogy működik pontosan a fentebb említett program, de szerintem a függőségekért csak a megadott, (és frissített) tárolókat nézi át, lehet nem jól tudom de olyan hogy a netten bárhol keressen és letöltsön szerintem nincs.

Nem bántani akarlak de nagyon sok dehaígy-dehaúgy gondolat jár a fejedben :D
Nem tudunk mindenki minden igényének megfelelni, fel kell állítani egy célt, azt így eltudom érni és kész.
Az meg elvárható egy fejlesztőtől hogyha ajánl egy szoftvert letöltésre az úgy legyen előkészítve hogy a megfelelő függőségek is lejöjjenek....sőt egy felugró ablakban a további fontosabb műveleteket is megjeleníteni :!:
Pl: "A szoftver eltávolítása más programok indítására hatással lehet!"

A Java-t meg azért ajánlom bele rakni egy adott puppletbe mert nem csak telepíteni nehéz sok esetben, de még további beállításokat is igényel !

Avatar
KuLuSz
Hozzászólások: 383
Csatlakozott: 2014.06.17. 21:19

Re: Milyen/melyik program kell feltétlenül egy pupletbe?

Hozzászólás Szerző: KuLuSz » 2016.05.01. 20:37

Emlékeim szerint a ppm is tud deb csomagot telepíteni , és függőségeket is leszed a puppy specifikus csomagokhoz .1kérdésem van : miért nem építik bele ezt a programot ?
-<(].K.u.L.u.S.z.[)>-
---------------------------------------
Általában megtalálható vagyok az Angol irc csevegőn vagy a Discordon KuLuSz néven.

NRLD181
Hozzászólások: 83
Csatlakozott: 2015.10.27. 18:37

Re: Milyen/melyik program kell feltétlenül egy pupletbe?

Hozzászólás Szerző: NRLD181 » 2016.05.02. 21:08

Nálam a LxPupTahr-15.12.1
viewtopic.php?f=7&t=288
Simán rá raktam a Geogebra i386 deb.
Letöltötem rá kikeltem majd feltelepült,a személyes menü pont allatt találtam meg.
Rendesen müködik rajta.
Mi tartalmaz ,nem tudom biztosan valami hasznosat.
A Puppy oktatás céljára kellene appokat bbele tenni.
Legyen benne Libre Officce,Gimp,Blender,Code Block,Android Studio,Stb

kros54
Hozzászólások: 348
Csatlakozott: 2014.06.17. 07:01
Kapcsolat:

Re: Milyen/melyik program kell feltétlenül egy pupletbe?

Hozzászólás Szerző: kros54 » 2018.07.02. 06:51

Szerintem ez lehet az a szál, ahol akkor folytatni lehet a Puppy-tartalmat.
Azaz: mi legyen benne, mit tudjon?
Szeretném az elején leszögezni, hogy nincs a zsebemben a bölcsek köve. Amit a linuxhoz "értek" az itt, ezen a fórumon szedtem össze az elmúlt évtizedben, s ez is gyakorlati észrevétel. Sajnos, időm sincs, hogy a fejlesztés manuális részében részt vegyek, ami, a fentieket is figyelembe véve, nem látszik hátránynak. Viszont van felhasználói észrevételem, s azokat írom ide.
Nem tudom, van-e még értelme, de azért azzal kezdem, ha a kicsit öregebb gépeket is célnak látjuk, akkor 32 bites legyen.
1. Miért tartom jobbnak a Precisét a mostaniaknál? Egyszerűen azért, mert az, amit most is használok, minden, általam próbált vason minden utólagos beavatkozás nélkül beindult, s elfogadhatóan gyors. Mindegyik más, Tahr, Xenail, akármi, vagy valamelyik próbagépen nem indult, vagy egyszerűen sokkal lassabb volt, mint a Precise. Tehát én ezt magamnak úgy foglaltam össze, hogy a Precise-ben megvan a kellő összhang, ami azért nagyon sok hardverkörnyezetben remekül bizonyított.
2. Kinézet. Nekem egy kívánalmam van: a tálcát, a gyorsindító szekciót, tudjam a magam használati szokásainak megfelelően átalakítani, átírni. S hogy ez JWM vagy Openbox, mindegy, talán az Openbox nekem finomabb, de ez ízlés dolga.
3. Programok. Ami nekem kell: böngésző, s akár kész is. Hajlok arra, hogy ez legyen a Pale Moon.
Nyilván kell bele notepad (szerintem a Geany) aztán komolyabbnak Abiword, Gnumeric, ami nyit MS Office x-végű tartalmakat. Sajnos, nem tudok linuxos alternatívát a ppt(x)-kre, hátha valaki tud. Ezek helyett - lehet, mellé - nekem megteszi egy jól működő, nem is biztos, hogy a legfrissebb, szóval nem túl nagyméretű Wine, ami alá a windowsban megszokott portable programjaiból "telepítek" - azaz másolok be. Ha van benne rádió, az jó, a puppy alattiakat mind ismerem, nem ragaszkodom egyhez. Szerintem bevált a régebbi gépeken különösen az smtube (lehet, van újabb is) szóval az az alkalmazás, ami böngésző nélkül hoz youtube-tartalmat., meg az a médialejátszó, ami azt megjeleníti, nem ragaszkodom a Vlc-hez.
nyilván szükséges fájlkezelő, nagyjából mindegy, amit szeretek az az mc, de már megszoktam a Roxot és többit is. Szeretem a htopot, de ha van más, ami hasonló, az is jó. Érdekes, win alatt eszembe sem jut ilyesmit használni.
4. Az összes Puppy televan még legalább 100 pici programocskával, jelszómenedzser, didiwiki, amiket az életben soha meg sem piszkáltam. Kiirtásuk hosszú idő, a méretnyereség minimális, erről is már sokat beszéltünk, van, amikor nekiálltam törölni, máskor nem foglalkoztam ezekkel, olyan is volt, hogy a menüben csak azok megjelentetését engedtem, aminek hasznát gondoltam, de a programot nem töröltem.

Talán látszik, hogy konkrét programot alig írtam.
@janugsa, köszönöm az ötletet, egyébként évtizede ezen küzdünk, hol ilyen, hol olyan megközelítéssel.
Biztonság. Szerintem a puppy a 2 %-os összes linuxos webre irányuló linuxok közül valami mérhetetlen töredékkel bírhat. Nem tolnám túl ezt a részt: ki az az őrölt hacker, aki a régi vason szarakodó felhasználókra ír programot, mikor ott az Android, az iOS meg a windows...? Ez a Puppy alatt egy hájp, amit tudni kell a saját helyén kezelni, azaz - @Kulusszal szólva -, érvényes legyen rá a lesz@rom fokozat mértékegysége a backup/6
S természetesen ez nem végső válasz, hanem csak egyetlen vélemény, hogy kb. merre menjünk.

nocsak
Hozzászólások: 71
Csatlakozott: 2014.09.29. 15:01

Re: Milyen/melyik program kell feltétlenül egy pupletbe?

Hozzászólás Szerző: nocsak » 2018.07.02. 10:44

A következő listát még valószínű, fogom módosítani:

Pale Moon böngésző
dir2sfs
gFTP kliens
Gpptp vagy openvpn VPN kliens
YASSM
htop az nagyon alap
zarfy is
hardinfo is
Clipit vagy glipper vagy parcellite
pAVrecord vagy simple screen recorder
mhwave edit
irc kliens
ffconvert
Geany
cifs-utils
(az alap beépített feleslegesnek mondott programokat nem bántanám, nem sok helyet foglalnak)

Opcionális csomagok (pet, sfs, szkriptek):

wine, wine-hoz: wine mono, wine gecko (wine uninstaller indításnál automatikusan rákérdez)
64 bit esetén 32 bites libek sfs-e (majd ldconfig parancs kiadása)
guvcview
vlc (online streamekhez, streameléshez)
qtlibrary
libre office
libgtk-3 + függőségei
firefox 61
apulse csomag
audacity
avidemux-gtk
pidgin
gimp
Double Commander

Ami ezeken kívül csak annyi, hogy feltelepítjük pet-ből vagy csatoljuk sfs-ből, azok
a 3. kategória, ezek bármikor pótolható részei a rendszernek.

Negyedik volna az amit én az LX7-nél rendszer szinten alkalmaztam, ilyen a python 2.6 - 2.7, scapy, openssl-bash patchek, plusz amiket nem dokumentáltam és PPM-ből telepítettem vagy fordítottam magam és függőségeik. De elvileg ha egy új pupletben működőképes a PPM onnan is a megfelelőeket lehet pótolni, bár hozzá teszem (szerintem) jobb volna mindent pet-ből és vagy sfs-ből.
---
Másik: Elolvastam ezt a fórumszálat, és nagyon sok hasznos tipp található benne. Arra viszont, hogy hogyan lehet olyan pupletet létre hozni ami mindig napra kész marad, azt így tudnám elképzelni:

Változással szemben csak változással lehet fellépni. Főként, ha követni szeretnénk fejlődő világunkat, magunknak is fejlődni kell. Kényelmi illetve automatizációs megoldásoknak ott lehetnek a szkriptek. Pl.: pet-be pinstall.sh és puninstall.sh vagy egyéb úton. Minden másnál a közösségre van szükség, akik adják a supportot. Mivel ahogy már Kulusszal ezt offolva átrágtuk, ezekhez M.I. szinten kéne lenniük a gépeknek, szkripteknek. Jelen pillanatban meg vagyunk kisbetűvel írva mi (magunk).
A hozzászólást 1 alkalommal szerkesztették, utoljára nocsak 2018.07.02. 14:01-kor.

NTamas
Hozzászólások: 1484
Csatlakozott: 2014.06.19. 13:36

Re: Milyen/melyik program kell feltétlenül egy pupletbe?

Hozzászólás Szerző: NTamas » 2018.07.02. 11:46

kros54 írta:
2018.07.02. 06:51
Szerintem bevált a régebbi gépeken különösen az smtube (lehet, van újabb is) szóval az az alkalmazás, ami böngésző nélkül hoz youtube-tartalmat., meg az a médialejátszó, ami azt megjeleníti, nem ragaszkodom a Vlc-hez.
Na, ez így nem teljesen igaz!
Ugyanis az SMTube program az nem más, mint egy minimál kialakítású, önállóan futtatható webböngésző kliens program, ami alapból a http://www.tonvid.com/index.php weboldalt nyitja meg neked abban az aktuális verziós SMTube webkliens-ben. Hogy az a Tonvid.com-os webtárhely kié, azt nem tudom, de nem is érdekel, a Tonvid.com-os webtárhelyet, illetve annak az kezdőoldalát, és a kategóriákat meg amúgy egy sima saját webböngészőből (Pl. Palemoon) is meg tudod nyitni, nem kell ehhez az SMTube program. A videókat is meg tudod nézni a megnyitott webböngésződből, ehhez nem kell egy másik, sok esetben újabb memóriafoglaló(zabáló) lejátszó programot megnyitni, és a videót(kat) is le lehet menteni az SMTube nélkül, Pl. a www.tubeninja.net-es weblapon keresztül, csak ésszerűen kell azt használni, és nem mindenhova kattintani, mert akkor simán kapni fogsz egy reklámoldalt, ha mindent ésszerűen csinálsz, egy letölteni kívánt videó link copy-paste-val, és két kattintással simán, gond nélkül leszedheted a Tonvid-com oldalra kitett videókat, míg ugyanezt a youtube oldalon sok esetben még kiegészítővel sem tudod megtenni. Ráadásul a keresés is működik a sima webböngésző oldalon, ehhez sem kell az SMTube. Szóval egy kis odafigyeléssel simán ki lehet váltani az SMTube programot, és nem kell bajlódni, a mindenkori verziófrissítéses problémával, meg a programhoz kellő függőségek telepítésével.(lásd az újabban szükséges Qt5 függőséget) Az SMTube egyetlen előnye az, hogy kiváltja a webböngészőkben mára már általánossá vált, és kissé erőforrás igényes html 5-ös videólejátszó programot - amit sok esetben a gyengébb gépek már nem tudtak-tudnak csak esetenként akadozva megjeleníteni(gyenge gép+technikailag elavult masina) - egy stream jellegű megoldással, de ehhez meg ugye kell a megfelelő lejátszó program.(de ehhez meg kellenek a függőségek, codekek, szóval...) De mivel az ilyen elavult gépek száma rohamosan csökkenni fog, technikai elavulás, tönkremenés okán, az SMTube jelentősége is ezzel együtt csökkenni, fog, főleg úgy, hogy már az újabb verziós SMTube-SMPlayer pároshoz is függőségként a QT5 kell, na, az meg önmagában is egy jókora méretű program, és akkor a többi függőségről még nem is beszéltünk. Ráadásul egyre kevesebb a letölthető statikus SMPlayer-SMTube csomag, amibe a készítő(norgo) belecsomagol minden szükséges függőséget, bár épp most adott ki egy ilyen csomagok, lásd a linkelt weboldalt, de rá is az jellemző, hogy inkább a shared jellegű csomagokat favorizálja, és pl. kimondottan a Precise Puppyhoz készült csomagokat az utóbbi időben már erősen hanyagolja.(az még külön egy szerencse, hogy a statikus xxx-s-i686.pet csomagok a Precise Puppykon is működnek!)
Szóval, ha mindent számításba veszünk, lehet, hogy a sima webböngészős youtube lejátszás, akár a Tonvid.com oldalról, akár a youtube weboldaláról a végső esetben sokkal kevésbé megterhelő, mintha ehhez külön programokat, és az azokhoz szükséges függőségeket telepítenénk fel az elavult, öreg gépünkre. De ez csak az én tapasztalatom, ráadásul az SMTube-s stream sem minden esetben mentsvár már, hiszen a 360p értéktől magasabb streameket a gyengébb gépek már szintén csak akadozva fogják megjeleníteni egy külső lejátszóval, ráadásul pl. a webböngészőbe belinkelt youtube lejátszón eleve régóta minőséget is tudsz váltani,(ezt mondjuk az SMTube is tudja) így a gépedhez igazíthatod a webes lejátszást, és nem kell emiatt külön médialejátszóval kínlódni. De mondom, ez csak az én véleményem.

Kép

kros54
Hozzászólások: 348
Csatlakozott: 2014.06.17. 07:01
Kapcsolat:

Re: Milyen/melyik program kell feltétlenül egy pupletbe?

Hozzászólás Szerző: kros54 » 2018.07.03. 07:22

@NTamas: OK, akkor nem szükséges az SMtube.
@nocsak: az alapprogramokat másként értelmezzük, ami nem baj.
Gpptp vagy openvpn VPN kliens
YASSM
Clipit vagy glipper vagy parcellite
pAVrecord vagy simple screen recorder

Ezeket inkább az alap+-ba javasolnám, van, amit sohasem használtam még ezek közül.
Persze a méret is számít, mert ha ezek elférnek 5-10 MB-ban, de talán majdnem mindegy is a méret, akkor fölösleges külön verziókat gyártani, max annyi van, hogy továbbra sem fogom használni, hasonlóan a még vagy 100 benne lévőhöz.
És az enyém csak egyetlen vélemény...

ticoo1
Hozzászólások: 221
Csatlakozott: 2014.10.21. 08:58

Re: Milyen/melyik program kell feltétlenül egy pupletbe?

Hozzászólás Szerző: ticoo1 » 2018.07.03. 07:54

Sziasztok!

Kedves Uraim! (esetleg Hölgyem mivel Ő is lehet közöttünk) örvendez a lelkem, mert végre előbbre léptünk!
Én egy-két variációnak már nekiláttam. Ha wine belekerül akkor a momo és a gecko kapásból 120 Mb csomagolva, vagyis remekül nő a méret.

Kros54, van Powerpoint néző deb csomagban is, ráadásul kicsi és jó is (a hang is), de wine alatt fut!

De van egy probléma!, ha nő a CD kép mérete, akkor frugálban pillanatok alatt megzabálja a RAM-ot!!! :twisted:

NTamas
Hozzászólások: 1484
Csatlakozott: 2014.06.19. 13:36

Re: Milyen/melyik program kell feltétlenül egy pupletbe?

Hozzászólás Szerző: NTamas » 2018.07.03. 11:12

ticoo1 írta:
2018.07.03. 07:54
Ha wine belekerül akkor a momo és a gecko kapásból 120 Mb csomagolva, vagyis remekül nő a méret.
De van egy probléma!, ha nő a CD kép mérete, akkor frugálban pillanatok alatt megzabálja a RAM-ot!!! :twisted:
Ez igaz, de....
El kéne már azt dönteni, hogy a Wine csomag egy puppy linux alaprendszerben feltétlenül alapszolgáltatásként legyen elérhető az oprendszerben, vagy csak utólag feltehető kiegészítésként, mert ezen áll vagy bukik a dolog.(lásd a méretproblémát)
Az pedig, hogy egy linux rendszerben csak azért legyen fenn egy wine, mert van egy-max. két olyan windowsos program, amit nagyon szeretek használni, lásd pl. a kros54 által favorizált RadioShure netes rádió programot, és a Softmaker FREE Office-t, szóval, talán inkább keressünk végre olyan linuxos progikat, akikkel ezek a windows-os programok kiválthatóak. Az Office jellegű csomagok meg amúgy sem az alaprendszer részei, ez még a Windows-nál sincs így, felesleges tehát ezt a mindenáron beépítem vonalat követni. És ez ugyanúgy vonatozik ám a Linuxos Libre Offfice-ra is, semmi keresnivalója egy alap Linux rendszerben. Viszont legyen meg az alap Linux rendszerben egy Get-jellegű menüpont(ok) -mint ahogy ezen dolgok pár más puppy linuxban is benne vannak- amiknek segítségével, azoknak, akiknek majd kellenek ezen kiegészítő szoftverek, az alap Linux oprendszerből is fel tudják azokat egy kattintással telepíteni.(lásd a Wine, és Office programok stb...)
Csak érdekességként, a 2018-as Softmaker Free Office csomag linuxos verziójának .deb telepítője 256MB méretű, és ez kibontva-feltelepítve ez csak nagyobb lesz. Azért fogjuk már vissza magunkat! Ezen csomag mérete például már vetekszik egy kisebbfajta Puppy Linux rendszer méretével!
Kép
Persze ez is csak egy vélemény.........

willy36
Hozzászólások: 101
Csatlakozott: 2017.05.16. 18:43

Re: Milyen/melyik program kell feltétlenül egy pupletbe?

Hozzászólás Szerző: willy36 » 2018.07.03. 12:47

Sziasztok !
Amiket használok, nagyjából leírtátok. A netbook-omat főleg utazáskor veszem elő, így ehhez igazítom az igényeimet.
Ami tetszik, a pontos puppy-t nem tudom, de a legtöbb programnak csak az install script file-ja volt betéve a start menübe, és ha kell csak klikk egyén igénye szerint, és már húzta a netről. lsd. palemoon, libre-office stb. tehát egy alap puppy-t tudok elképzelni, és ehhez csak az install lenne rajta, és ami kell, azt tedd fel. én pl. smplayer rajongó vagyok az utóbbi időben, mert a vlc több helyen elcsuklott nálam. Ahogy nézegettem a debian alapú puppy-k még elég gyorsak, ezen pl. nem szaggatott a videó sem, ami ugyanazon felbontáson más puppy-n igencsak köhögött, és a csomagok is frissebbek szerintem, és kevesebb függőségbe szaladtam bele. Hogy konkrét nevet is írjak, nálam most a legbátrabban használt puppy a stretch-7.5_k4.9.71. Ezenkívül a slacko603-ast veszem elő időnként, de én csak 32 biten gondolkodhatom az atom proci miatt. A devuan-t most fogom tesztelgetni, erről nem írnék még.
Konkrétan segítség képpen ezeket a programokat használom, generálként...
SmPlayer, Palemoon, Gimp, Double Commander vagy tesója, Audacity, Wine, Dosbox, Abiword, Geany, Virtual keyboard,
Esetleg, ha megoldható ötletként, mondjuk a skami vagy puppylinux oldalon lenne egy 20-30 programot tartalmazó kérdés, hogy Te mit használsz, és aki belépett regisztrálként az szavazhat, amit az oldal számolna, mire mennyi szavazat ment. Ebből lehetne látni, mire van igény. és lenne egy egyébb, ha ezenkívül mást is szeretnél.

Válasz küldése

Vissza: “Pupletek”