Milyen/melyik program kell feltétlenül egy pupletbe?

Pupletek, Új puppy változatok, veruiók, ISO fájlok,
kros54
Hozzászólások: 348
Csatlakozott: 2014.06.17. 07:01
Kapcsolat:

Milyen/melyik program kell feltétlenül egy pupletbe?

Hozzászólás Szerző: kros54 » 2015.04.25. 19:46

A méret miatt úgyis a Puppy győz...
Biztos, hogy más linux lelkivilágával nem kötök nagyobb barátságot. (Illetve, majdnem biztos, mert a puppykat úgy-ahogy, a magam módján, mégis kiismerni vélem.)
Vannak itt, akik szerint az a gond, hogy a Puppy baja, hogy nem lehet bele programokat tenni.
Ebben nyilván biztosan igazuk van, de mégis vannak Puppyk, amik meg program-túltengésben szenvednek.
Azután itt van Csipesz, aki aztán amit csak lát, belefarag a saját kreálmányába. (Jól teszi.)
Olyan puplet nincs, aki mindenkinek jó.
Mégis, jó lenne egy valamilyen iránytű, amely a legfontosabb paramétereket rögzítené.
Tudom előre, van, ami hitvita.
Ha ragaszkodunk a Puppyra jellemző kis mérethez, akkor vagy az általában beépített Seamonkey, vagy a Firefox jöhet számításba, mert a Google Chrome vagy bármelyik klónja eleve duplázza a puplet/ISO méretét. (És annyival meg nem jobb.)
Talán kéne még flash, esetleg java.
Zenelejátszó?
Video/média lejátszó?
Ez újabb hitvita, VLC/MPlayer (vagy klónja) között.
Azután: a legfrissebb vagy a legbeváltabb program-verzió? Én az utóbbi pártján állok, az MS Office 2003-mat sem cserélgettem évente...
Nem akarom sorolni, azt hiszen, világos, hogy ezek alapján időt álló és a közösség kívánalmainak megfelelő verzió hozható össze.
Jó lenne, ha bevált, működő alap-pupletet is írnátok.
Szerintem egyébként ilyen a korábbiak közül legalább kettő, a Precise5571 Lite, és az uPup383 is, ez utóbbi Azami kívánságainak eleget téve épült, sőt, és ezzel máris három, a slacko-sorozatból a gamechannelpuppy is.
És persze a korábbiak közül is akadnak, pl. a XP-sorozat darabjai, stb.
Egyből nem kéne valami más, vad-linux-világot túrni.

Avatar
S-kami
Adminisztrátor
Hozzászólások: 862
Csatlakozott: 2014.04.16. 12:54
Kapcsolat:

Re: Milyen/melyik program kell feltétlenül egy pupletbe?

Hozzászólás Szerző: S-kami » 2015.04.26. 08:00

Jó a felvetés!
A tahr puppy jó, mert friss, sok mindent felismer, új programok, scriptek vannak rá, viszont bizonyos szempontból meg már el is évült.

A slacko jó megoldásnak tűnik, mivel nem ilyen harmatvirág életű, nem cserélődik minden hónapban a kiadás, mint az ubuntu alapúak esetén és kis gépre telepíthető, ellentétben a legújabb April és unicorn pupletekkel.

A debian alapú pupletek meg talán még kicsit szokatlanok, másabbak kicsit, viszont abból is garantáltan a legújabb jessie kiadás is megjelent, de csöppet bonyolultabb lehet.
Nekem a slacko tűnik jelenleg a legstabilabb, fejleszett, építhető pupletnek, de sajnos annyit nem teszteltem még, hogy legyen rálátásom.
Java, Vlc, Double Commander és LibreOffice az én kívánalmam és esetleg még magyar skype, plusz talán egy mini-tube.
Puppy linux ! Mert megérdemlem !
Kép

Avatar
S-kami
Adminisztrátor
Hozzászólások: 862
Csatlakozott: 2014.04.16. 12:54
Kapcsolat:

Re: Milyen/melyik program kell feltétlenül egy pupletbe?

Hozzászólás Szerző: S-kami » 2015.04.26. 08:52

most kicsit belegondolva, a debian alapú lehetne a jó megoldás, mert van csomagkezelője, frissíthető, az újabb programok is elérhetőek, tetszetős és nekem 50 mb körül volt a fogyasztása, valamint többfelhasználóssá tehető, ezek komoly fegyvertények, valamint a debian egyike a legnagyobb, legrégebbi, stabil disztróknak és szerintem a saját programjaink, megoldásaink közül többet is könnyedén be lehet építeni.
:shock:
Puppy linux ! Mert megérdemlem !
Kép

ati5
Hozzászólások: 143
Csatlakozott: 2014.06.17. 11:14

Re: Milyen/melyik program kell feltétlenül egy pupletbe?

Hozzászólás Szerző: ati5 » 2015.04.26. 10:12

Mindkettőtökkel egyetértek ! Nekem is elég lenne annyi progi amit felsoroltatok , és a debian alapú puppykat is támogatnám . Ott biztosan megtalálom ami esetleg még kell . Már nem emlékszem melyik puppy volt az ami simán telepített deb. csomagokat , de azt szerettem nagyon . Ha valamit még kerestem deb csomagban általában megvolt . És igen nekem most fenn van az MX 14 is de mellette ott a puppy (onlineRP) , és többnyire ezt használom .
Szóval én örülnék egy alap puppletnek , olyasminek mint régebben az XP puppy volt .
ati5

Mert befagyott ablakot már láttam , de megfagyott pingvint még soha :D

azami
Hozzászólások: 935
Csatlakozott: 2014.06.20. 20:25

Re: Milyen/melyik program kell feltétlenül egy pupletbe?

Hozzászólás Szerző: azami » 2015.04.26. 11:18

Szerintem Java, flash legyen benne a többi Quickpet ből legyen telepíthető, de ne úgy mint most hogy sok program csak hivatkozás, hanem tényleg települjön az adott szoftver a megfelelő függőséggel együtt :!:
Jól használható még a Toutou szoftver telepítője melyben választhatsz hogy sfs vagy pet legyen telepítve.
A Debiandog csomagkezelése is jó, mivel sok szoftver nem érhető el csak deb vagy tömörített formában, én a Slax alapú rendszereket nem használom..
Esetleg parancsikon a fontosabb szoftverekhez (Firefox, Vlc..stb ) és az indítaná a letöltő scriptet.
Mivel úgysem tudom kinek mi kell én inkább a gyorsan elérhető, jól látható telepítésre tenném a hangsúlyt... ;)

NTamas
Hozzászólások: 1484
Csatlakozott: 2014.06.19. 13:36

Re: Milyen/melyik program kell feltétlenül egy pupletbe?

Hozzászólás Szerző: NTamas » 2015.04.26. 13:33

Szerintem meg java és flash pont ne legyen benne (a minimalista Puppy-s verzióban semmiképp!) alapból! - ugyanis ezek folyamatosan változnak, főleg az utóbbi idők eseményei jól példázzák ezt. Meg amúgy is, mindenki, aki a Puppy-t feltelepíti, saját, egyéni géppel rendelkezik, és ezek teljesen eltérő műszaki kialakításúak, így tehát a T. felhasználónak ezt minimálisan tudnia kell hogy az Ő saját gépe milyen műszaki paraméterekkel bír, és ezen pl. melyik webböngésző fog jól működni, -ezt már annyiszor, de annyiszor leírtuk, már a csapból is ez folyik- és ezen-ehhez a webböngészőhöz melyik flash-verzió a jó megoldás, illetve passzol hozzá. Amúgy meg, a legtöbb weboldalon, ha flash-tartalmat nézel, -márpedig ez ugye alapkövetelményé lett közfelkiáltással téve, youtobe,stb- akkor a normálisabb weboldalak, illetve inkább maguk a modern webböngészők úgyis figyelik azt, hogy a T. látogató milyen flash-verzióval lép fel az oldalra, és ha régivel, akkor letiltják biztonsági okokból, és nem jelenik meg a kívánt flash-tartalom, hanem csak egy figyelmeztetés, hogy biztonsági okokból frissítsd fel az oprendszered a legújabb flash-verzióra! Ha már kell a Flash, akkor csak a GetFlash-t lenne célszerű alapból beépíteni, szerintem.

A java-nál ugyanez a szitu, tehát emiatt mondom azt, hogy ebből a két szoftverből nem érdemes semmit feltenni, talán a java-ból az alap java verziót még fel lehet tenni, de itt megint belép az OpenJava, illetve a jre-s java, amiből épp most változott a verziószám a jre-8u45-re. Tehát ez megint kissé jitvita, hogy melyiket tegyük bele, van aki az OpenJava mellett dönt, van aki a másik verziót részesíti előnyben, így az a legjobb megoldás, ha az alap Puppy-ba egyiket sem tesszük bele, hanem a T.felhasználóra bízzuk, melyiket válassza, de ehhez ugye nem ártana egy kis segítség, mégpedig a Puppy telepítése után azonnal elinduló szöveges ablak példájára, hasonlóan, ahogy a Welcome Puppy megjelenik, és ebben a szöveges ablakban tájékoztatnánk a T. felhasználót - ha már nem olvasta el a telepített Puppy verzió mellé a készítője által ugye szépen mellékelt Readme állományt - amiben a Puppy készítője korrekten leírja, (le kéne írnia!!!) hogy a telepített Puppy verzió egy alap Puppy, ami a szokott alapprogramokat tartalmazza csak, ha egyéb kívánságod van, azt vagy a beépített csomagkezelő útján - ezt is érdemes lenne már gatyába rázni, ráférne!!! - tudod megtenni, ekkor valószínűleg a telepítendő programok függőségeit is le fogja hozni a jól elkészített csomagkezelő, vagy pedig külön, pet, deb és egyéb módon varázsolod a gépedre a kívánt újabb szoftvert, persze ehhez azt is tudnod kell, az éppen telepítendő szoftvernek mik is a függőségi követelményei, mert nem mindegyik pet-es csomag készítésekor írja ezt bele a pet-csomag készítője, és hiába megy fel a pet-csomag, a függőségvizsgálat, a követelmények nem leírása miatt nem fog függőségi hibát mutatni, de ennek ellenére a feltelepített szoftver nem fog működni a ténylegesen meglévő, de nem dokumentált függőségi hibák okán.

Azt meg szintén elvetette itt a fórum, -szerintem hibásan, mert nem gondolták végig, miért is lett a téma felvetve annó, hogy olyan alap Puppy-t hozzunk létre, amiben jó pár függőség eleve bele van építve, legalább is a közkedvelt programokhoz kellően, amiket amúgy is mindenki le kell hogy vadássza a Net-ről valamilyen formában, milyen jó lenne, ha ezek már az alap Puppy-ban eleve rendelkezésre állnának, erre jó példa a Csipesz által összeállított, és kros54 által mega-Puppy-nak becézett verziói.
A kellő függőségeket pefdig a csomagok kipróbálásakor, telepítésekor amúgy is vagy maga a csomagkezelő jelzi, egy felbukkanó ablakban, vagy pedig a telepítés után, ha az külső programként(pet-ből) lett telepítve, a beépített csomag ellenőrző fogja jelezni.(feltéve, ha a pet-csomagba bele van írva a fejlesztője által a kellő függőségek listája!!!)

Pont ezért nem jó megoldás a telepítendő szoftverekhez előre parancs-ikont generálni, mert abba bizony bele kell írni, honnan is szedje le a felhasználó a kívánt programot-melyik tárolóból, esetleg direct-web-es címről, de már a legritkább esetben van ide bemellékelve a scriptben a kellő függőségekhez való webcímek-tárolók címe is, így, ha ezek a függőségi címek hiányoznak, hiába tölti is le az a script a programot, az nem fog működni.

Számtalan ilyen direkt letöltő script-létezik, ahol csak maga a program töltődik le, a kellő függőségek meg nem. Arról meg már ne is beszéljünk, hogy az így letöltött programok szinte sohasem jó helyre kerülnek bele a Puppy-menübe, vagy rosszabb esetben bele sem kerülnek.

Amit talán érdemes lenne meglépnünk, az nem más lenne, mint elhatározni végre, milyen műszaki paraméterű gépekhez milyen alap Puppy-verziót készítsünk el, vagyis megállapítani végre azt a három kategóriát, amihez a megfelelő kernelszámú alap Puppy-t elkészítenénk, a bele való, a géptípusnak megfelelő, és azon biztonsággal működő alapprogramokkal egyetemben.

És hogy melyek uis lennének ezek az alapprogramok?
Sokat nem kellene gondolkodni ezen, hiszen már ezek régóta rendelkezésre állnak, és ahogy kros54 meg is írta, üzembiztosan működnek, és bevált termékek.
Nyilván, ha a három alap Puppy kategóriát nézzük, akkor a leggyengébb gépekre való minimális gépigényre méretezett alap Puppy-ban jobbára csak az egyszerű, sallangmentes, kevés erőforrással is beérő, minimális kinézettel(egyesek megfogalmazása szerint puritán kivitelben) bíró kisméretű programocskákat kell betenni, amik a feladatot ugyanúgy hibátlanul el tudják végezni, mint a flancosabb kinézettel bíró, nagyobb méretű, és nagyobb gépigényű szoftvertársaik.
Ebből adódik az is, hogy a követelménylépcső következő fokához ajánlható közepes kialakítású Puppy alapverzióba már az előzőekben leírt alapprogramok mellé feltehetnénk már másik, nagyobb gépigénnyel és jobb kinézettel, több szolgáltatással bíró programot(kat), persze csak módjával.

Szerintem azt a jó megközelítést kéne alkalmazni, hogy egy feladathoz az alap-gyenge gépekre csak egy -egy programot tennénk be, ezt a következő lépcsőben, az közepes gépigényhez méretezett, általam csak közepes alap--Puppy-nak hívott verzióban már az előbb leírt, jobb kinézettel, több szolgáltatással bíró programot(kat) is bele tehetnénk, de szigorúan tartanánk magunkat ahhoz, hogy a Puppy-verziók végső méretkorlátozása miatt egy egy feladathoz csak egy-egy alapprogramot, és egy-egy bővebb verziójú programot tennénk be a rendszerbe.
A legnagyobb gépigénnyel bíró harmadik, az erős alap Puppy-verzióba pedig már belekerülhetnek az eddigiekben leírtakon felül azok a programok is, amiket a szoftverek modernsége, és emiatt törvényszerűen eleve megnövekedett gépigénye, és a szoftver grafikai igényessége okán az erősebb gépet, géphasználatot követelő erőforrásigények miatt az előző kategóriákba nem tehetnénk bele.

Alap szoftverkategóriák, amik szerintem minden verzióban kellenek:(bár ezt mindenki jobban tudja rajtam kívül)
* rendszer beállító, és karbantartó programok
*telepítést, mentést elősegítő, valamint a remaster kszítést lehetővé tevő programok
*ablakkezelő program (programok, ha esetleg nem a tejesen minimal Puppy-verziót nézzük!)
*fájl, és állománykezelő, fájl-állomány író-olvasó programok
*grafikai, irodai programok, ezek esetleg a személyes kategóriába is besorolva
*webes feladatokhoz való és a kimondott webböngésző programok
*zenei, (multimedia) stream és filmlejátszó programok
*játékok(nem feltétlen kategória, de nem árt, ha létezik)

Ezen feladatok kielégítésére az általam említett klf. alap Puppy verziók is az alapesetben a már eddig megszokott, megszeretett, és bevált alapprogramokat tartalmaznák, természetesen, hogy melyiket, ez a hitvitán kívül azok használhatóságán a minimál programok minimális kialakítása folytán nyújtott kiegészítő szolgáltatásaikon és az erőforrások igénybevételén, vagy kevésbé erőforrás zabáló mivoltjuk alapján is múlhat.

azami
Hozzászólások: 935
Csatlakozott: 2014.06.20. 20:25

Re: Milyen/melyik program kell feltétlenül egy pupletbe?

Hozzászólás Szerző: azami » 2015.04.27. 21:30

A DebianDogban van 1 progi, meg adod a deb fájlt, ez meg leszedi ami kell hozzá függőség.

screenshot_2015_04_27_21_18_33.png
screenshot_2015_04_27_21_18_33.png (15.08 KiB) Megtekintve 2024 alkalommal

NTamas
Hozzászólások: 1484
Csatlakozott: 2014.06.19. 13:36

Re: Milyen/melyik program kell feltétlenül egy pupletbe?

Hozzászólás Szerző: NTamas » 2015.04.27. 23:34

Esetleg megadnád a program konkrét nevét, mert így csak az ablakfotóból nem derül i, hogyan is működik az a csoda_progi....

azami
Hozzászólások: 935
Csatlakozott: 2014.06.20. 20:25

Re: Milyen/melyik program kell feltétlenül egy pupletbe?

Hozzászólás Szerző: azami » 2015.04.28. 06:39

Menüben
sa.jpg
sa.jpg (76.59 KiB) Megtekintve 2014 alkalommal
A parancsikon...de a fájlt amire hivatkozik még nem leltem meg (ma talán lesz időm..)
ssa.jpg
ssa.jpg (41.16 KiB) Megtekintve 2014 alkalommal
A lényeg ha tudjuk miből áll a program parancssora, talán át lehet tenni más puppletbe is.. :!:
Kulusz jó lenne ha olvasná ezt.. ;)

NTamas
Hozzászólások: 1484
Csatlakozott: 2014.06.19. 13:36

Re: Milyen/melyik program kell feltétlenül egy pupletbe?

Hozzászólás Szerző: NTamas » 2015.04.28. 09:36

Az a fixdepinstall nevő bináris(exe) futtatható fájl, valószínűleg az /usr/bin könyvtárban tanyázhat, ha .bin file, ha meg .sh parancsfile, akkor az sh-ak tartalmazó alkönyvtárban lehet. Ennek a neve most nem ugrik be, sorry.

Köszönöm, a gyors reagálást, ez a parancs-file szerintem, -ha én jól értelmezem így a képek alapján - nem csinálhat mást, mint simán csak kiolvassa a minden deb filében meglévő controll fájlból a függőségek nevét, és ha a deb fájlt tartalmazó repistory-ban megtalálja őket, akkor elvileg le is hozza! De, csak akkor, ha a controll filében ezek a függőségek jegyezve vannak, mert volt már olyan deb csomagom, ahol nem voltak abban érthetetlen módon függőségi bejegyzések.

A controll filében általános esetben csak magának a függőségi file-nak a neve van beírva, tehát érthető, ha a deb+függőségvadász fájl ezeket először a saját repistory-jában keresi meg, és, ha megtalálja, akkor szüret, mert onnan lehozza. De, mi van akkor, ha nem? Akkor hogyan, mi módon szedi azt le a Net-ről, milyen net-címről, vagy egyáltalán milyen parancsfile alapján keresi meg a repistory-ban nem lévő függőségeket a Net-en? - engem egy ilyen parancsfile, script-file, és annak a tartalma érdekelne, de nagyon!
Az a fixdepinstall nevő bináris(exe) futtatható fájl, vagy script gondolom nem csinálhat mást elsőre, mint pl. az UExtract progi, vagyis szépen kibontja a deb-file tartalmát, ekkor elvileg egy szép könyvtárszerkezetet kap, amiben van pl. ilyen főkönyvtár, /usr - és ezen belül a megszokott alkönyvtárak, mint a share, meg azon belül a bin, lib, applications, pixmaps és satöbbi, attól függően, milyen fájlokat tartalmaz maga a deb-es program. Ezeket azután már szépen bemásolja a Puppy megfelelő könyvtárszerkezetébe, beállítja a futtathatóságot a megfelelő fájlokon, és ha van a csomagban külön menu file, akkor az szerint , ha nincs, akkor a .desktop filében magadott Categories besorolás szerint -pl. így: Categories=X-Multimedia-mediaplayer - beírja a telepített programot a Puppy menüszerkezetébe. Végül megírja a feltelepített programok listáját a .package fájlba, ahonnan a program későbbi eltávolításakor a csomagkezelő szépen kiolvassa, milyen filéket is kell neki a program eltávolításával kitörölnie a rendszerből. Csak ezt az eltávolítás olyan jól(?) végzi el, hogy olyan , egyébként a .package-ban bejegyzett függőségeket is kitöröl, amit más program is használ, és ebből szokott a gond lenni, általában a Puppy-nál, ezt a témát már kulusz-al feszegettük is nemrégen.

És ugye a deb kibontásakor elvileg ott a már említett contoll fájl, amiben szépen le van írva a program leírása, fejlesztő neve, fájlnév, függőségi lista, a progi rövid leírása. Ebből a fájlból olvassa ki a fixdepinstall bináris, hogy milyen nevű függőségeket kell leszednie, ha a programtárolóban ezeket megtalálja, akkor onnan szedile és telepíti fel. De, mi van akkor, ha ott nem talál függőségi filéket? - akkor hogyan, és honnan szerzi ezeket be? -ez érdekel engem nagyon, mert a puppy-ban, az újabbakban, a csomagkezelő már képes deb filék telepítésére is, -lásd a precise verziókat - de ehhez szerintem újabb kernel is szükséges, ha jól tudom, illetve az, hogy a tárolókban, a letöltött deb fájlok mellett megtalálhatóak legyenek a függőségi fájlok is. Mert én úgy vettem észre, hogy a Puppy csomagkezelője a Net-ről, nem szedi le , nem keresi meg név alapján ezeket a függőségi fájlokat. Mivel nem vagyok tanult programozó, csak egy lelkes 58 éves amatőr, aki az ismereteit csak tőletek, meg a net-ről, ha talál ilyet, szerzi be, és alkalmazza tanulja meg.Ezért valóban jó lenne, ha a csapatból a képzett programozók: skami, kulusz, kzprog, kros54, gjuhasz, és a többiek is foglalkozna ezzel, illetve választ adna ezekre a felmerült kérdésekre.

Válasz küldése

Vissza: “Pupletek”