Linux, régi gépekre

Egyéb operációs rendszerekkel kapcsolatos leírások, infók, hírek
kros54
Hozzászólások: 257
Csatlakozott: 2014.06.17. 06:01
Kapcsolat:

Re: Linux, régi gépekre

Hozzászólás Szerző: kros54 » 2016.12.17. 08:35

Kedves Csipesz, köszönöm.
Szerintem a szóban forgó gép nem alkalmas ezen puplet futtatására. Ez csak CD/DVD boot üzemmódban indítható, az összes többi - tucatnyi, ugyanazzal az eszközzel, programmal írt - hordozót olvasta. Gondolok még a PAE-problémára (nem néztem utána, de annak visszafelé kompatibilisnek kéne lennie a kis RAM-ú gépekkel) szóval egyszerűen nem megy.

NTamas
Hozzászólások: 1080
Csatlakozott: 2014.06.19. 12:36

Re: Linux, régi gépekre

Hozzászólás Szerző: NTamas » 2016.12.17. 11:23

... A hardver: Optiplex GX620 2xIntel P-4 2,8 GHz, 1,5 GB RAM - egy max 10e forintos, igazából komolyabb helyekről kidobott porfogó. ...

Az a gép talán egy ilyesféle masina lehet, a paraméterei alapján:
https://www.amazon.com/Dell-Optiplex-GX ... B00DLCYVQS

Nem is a pontos gép-egyezés itt a lényeg, hanem a Dell gépekben lévő alaplap, ami ebben a Dell szériában szinte mindegyik gépben azonos, ezt leszűkítve a lényeges dologra, minden gép SATA vezérlővel van szerelve, de ez a vezérlő működhet ide módban is, ha netán nem SATA merevlemez lenne abban a gépben. Az IDE -nél egy kicsit lassítsunk, ugye vannak a hagyományos IDE-vezérlők, illetve annak egy újabb, modernebb kialakítása, az IDE/ATAPI vezérlők, amit, mármint az ATAPI-vezérlőt néha tévesen SCSI-vezérlőnek ismerik fel egyes oprendszerek. Azután vannak olyan gépek is, mint pl. ebben a retró gépeket bemutató weboldalban -http://retropages.hu/theme_25.html- megemlített Compaq gép is, ahol az ide vezérlő kombinálva van a SCSI-vezérlővel, így kétfajta merevlemez is beletehető.(a példánkban ez 18 GB UWSCSI, 300 GB IDE merevlemez) Az is elképzelhető, hogy a Dell gépben lévő SATA vezérlő is egy kombinált vezérlő lehet, ezért az SCSI-felismerés, vagy, mint említettem, ez egy hibás merevlemez-vezérlő felismerés a Xenial Puppy részéről.
Az általad közölt kép pontosan ezt támasztja alá:
Kép
Jól látható, hogy a képen egy tipikus I/O-error hiba van, ami elsőre merevlemezvezérlő hibának, hibás felismerésből adódó problémának, hiányzó vezérlő drivernek tűnik.DE!
A Linux viszont pontosan ki is írja a hiba okát, lásd a bootinit.log alatti sort: nemlétező, vagy hiányzó SCSI-vezérlőhöz való lib, vagy annak a könyvtára, ami a puppy-ban lévő 4.1.31-es kernelben már nincsen benne!
Mivel én úgy tudom, hogy a SCSI-támogatás ezekben az újfajta kernelekben már nincs meg, így érthető, hogy vagy a vezérlő hiánya, vagy annak téves felismerése miatt, nem képes a puppy beolvasni az adatokat a cd/merevlemezről.
És ott van még az a megemlített zdrv_xenial_7.04.sfs file is, azzal is valami gond van.
Szóval talán arra a Dell gépre inkább egy régebbi kernelű puppy-t lenne célszerű feltenni, az előbbi próbák alapján látható, hogy a Precise-kben lévő 3.9.11-es kernelű puppy-k még működnek azon a régi gépen, szóval nem kéne erőltetni a modern kerneles puppy-kat, legalább is azon a Dell gépen semmiképp.

kros54
Hozzászólások: 257
Csatlakozott: 2014.06.17. 06:01
Kapcsolat:

Re: Linux, régi gépekre

Hozzászólás Szerző: kros54 » 2016.12.17. 11:52

Kedves Ntamas, köszönöm.
Remélem, kiderült, hogy nem a Csipesz-Xenail puppyval, hanem a gép és a xenial nem működésével van problémám.
Igen valószínűnek tartom (s magam is erre gondoltam) hogy van valahol egy hardverhatár, ameddig érdemes használni a régebbi (Precise az utolsó szerintem) Puppykat.
A Xenial meg már arra való, amire majdnem felmegy a win10 is.
(Ez nem valamiféle ökölszabály, a pontos okfejtést NTamas leírta).

janugsa
Hozzászólások: 304
Csatlakozott: 2014.06.27. 23:17

Re: Linux, régi gépekre

Hozzászólás Szerző: janugsa » 2016.12.17. 13:36

http://distro.ibiblio.org/puppylinux/huge_kernels/
Itt van 3.14.66-os xenial pae kernel.
Kibontani, mert tömöritett, az előzőt átnevezni,
az újakat az előző nevével átmásolni.
Nálam működik, igaz az előző is.

kros54
Hozzászólások: 257
Csatlakozott: 2014.06.17. 06:01
Kapcsolat:

Re: Linux, régi gépekre

Hozzászólás Szerző: kros54 » 2016.12.17. 19:08

Megpróbálom még egyszerűbben leírni.
A próbák sora arra irányult, hol és melyik az a linux, azon belül puppy, amely ezen a gépen (még) jól fut.
Ilyen egyértelműen a Lucid, majd a Precise, éspedig az 5.7.X körüli verziók.
Ennek azért nem öreg a kernele, a 3.9.X minden esetre jóval fiatalabb, mint mondjuk a win7.
Szerettem volna a határt odébb tolni, így a legfrissebb, tehát a Xenial-Puppyt is megnéztem, ennek a kernele 4.1.X - na, és ez már nem jó neki.
Mivel a korábbival megy, és a telepítendő gépek nemhogy frissebbek, inkább jóval öregebbek, mint a Dell, számomra teljesen világossá vált, hogy valóban valamelyik Precise-alapú puplet lehet a megoldás.
Mindenkinek köszönöm a segítségét és megfontolásra érdemes tanácsait.

NTamas
Hozzászólások: 1080
Csatlakozott: 2014.06.19. 12:36

Re: Linux, régi gépekre

Hozzászólás Szerző: NTamas » 2016.12.18. 12:13

janugsa írta:http://distro.ibiblio.org/puppylinux/huge_kernels/
Itt van 3.14.66-os xenial pae kernel.
Kibontani, mert tömöritett, az előzőt átnevezni,
az újakat az előző nevével átmásolni.
Nálam működik, igaz az előző is.
Ez oké, talán ki is próbálom, ha ebben a kernelben van rendes nvidia támogatás, értsd, rendesen fel fogja ismerni és helyes felbontásra, és működési frekvenciára is be tudja állítani, majd azt jól el is menti, egy helyes xorg.conf-ba, mert az eredeti Xenial-7.0.4-es iso-ban lévő kernel, a 4.1.31-es az ezt nem tette meg, lásd a csipesz féle xenial csomaghoz írt megjegyzésemet tegnap. A 4.1.31-es kernelhez legalább volt kernel_sources-4.1.31-xenial_PAE.sfs file, meg devx_xenial_7.0.4.sfs is, ehhez, amit most te belinkeltél, ilyen kernel_sources fájlt még nem találtam, így nemigen fogok tudni ehhez a 3.14.66-os kernelhez saját nvidia drivert legyártani, lehet, hogy rosszul gondolom, ha így van, kérlek javíts ki a tévedésemet. Előre is köszönöm a segítséget.

Utóirat.
Közben már találtam a 3.14.66-oshoz is egy kernel_sources-3.14.66-xenial_PAE.sfs fájt, most már csak a saját nvidia driver gyártáshoz egy olyan megfelelő nvidia driver.run fájl éne, ami jó lenne pl. az én öreg Nvidia Geforce FX 5200-as Agp-s videókártyámhoz.
Ez a kártya a Precise xPr571 k:3.9.11 alatt működik egy, a precise-hoz való legacy videódriver .pet csomaggal, ezzel: nvidia-legacy96-driver-96.43.23-k3.9.11.pet
Viszont ilyen nvidia-legacy96-driver-96.43.23-as pet csomagot még nem leltem a xenial puppy-hoz, (lehet, tán nincs is ilyen pet csomag készen legyártva) sem a 4.1.31-es, és az általad linkelt 3.14.66-os xenial kernelhez.Pedig jó lenne, mert akkor megúsznám a videó driver gyártást. Igaz, ezzel a legacy videó driverrel nincs jó 3D-s támogatás, de az nekem nem is kell, bár az is igaz, hogy néha azért jól jönne, lásd pl. a Kodi-is igényli ezt, enélkül nem telepszik fel.
A hozzászólást 2 alkalommal szerkesztették, utoljára NTamas 2016.12.18. 13:55-kor.

NTamas
Hozzászólások: 1080
Csatlakozott: 2014.06.19. 12:36

Re: Linux, régi gépekre

Hozzászólás Szerző: NTamas » 2016.12.18. 13:49

kros54 írta:... a telepítendő gépek nemhogy frissebbek, inkább jóval öregebbek, mint a Dell, ...
Hát igen!
DE!
A már fentebb valahol megemlített, és jelenleg általam kényszerűségből most használt MSI 865PE Neo2-P jelzésű alaplap kicsit öregebb, mint a Te Dell géped, a tied már egy újabb, Intel 945G chipsetes, míg az enyém még csak a régebbi, 865PE chipsetes,
Kép
és ezen már azért van az alap IDE mellett SATA csatlakozás is, igaz, még csak SATA-150-es, tehát ez még csak SATA-I-es szabványú. Viszont a kombinált IDE-SATA alaplapi vezérlő Bios-ban jól beállítható, több lépésben is. A fő dolgok, amiket a Bios enged beállítani a vezérlőnél, hogy lehet külön ATA, illetve SATA módot beállítani illetve van egy kombinált mód is.(kombinált onboard IDE-SATA vezérlőről van szó)
Tehát, az On Chip ATA Operate mode-nál ezek állíthatóak be:(PATA=IDE)
Disabled
P-ATAOnly - ez van nálam most alapként beállítva az IDE-ATA-s merevlemezhez!-
S-ATA Only
PATA+SATA
Ezen belül még lehet állítani, hogy az IDE vagy a SATA foglalatokba dugott merevlemez közül melyik legyen bootolható, ez nálam, mivel én csak egy P-ATA-s (IDE-s )merevlemezzel bírok ebben a gépen, értelemszerűen az IDE-0-as vezérlőkábelen lévő Primary Master-nek configolt merevlemez az.
A szintén IDE-s optikai egységem meg az IDE-1-es másik vezérlőkábelre lett bekötve, és ott Secondary Masternek lett beconfigolva. A Boot-sorrend meg változtatható az optikai egység, a merevlemez, és az usb-re kötött külső egység között.
Ami még ebben a Bios-ban érdekes, hogy a 4darab IDE egység mellet a kettő darab SATA-I-es foglalat is IDE-ként jelenik meg a Bios-ban, lásd a képen. Igaz kissé zavaró, hogy a kép alapján úgy tűnne, mintha 4db. sata foglalat lenne a gépben, holott csak kettő van fizikailag beépítve.De az a kettő SATA foglalatba dugott eszköz 4 féleképp configolható.
Kép
Ezen hardveres infó után csak annyi lenne a Xenial témához a megjegyzésem, hogy talán Te is megpróbálhatnád a Dell gépnél egy IDE merevlemezre telepíteni a xenial-7.0.4-es eredeti, angol nyelvű Puppy-t a gyári isó-ból, úgy ahogy én azt tegnap tettem, és a csipesz féle xenial puppynál megjegyzésben azt meg is írtam. Noha nekem is SCSI dikként jeleníti meg az IDE merevlemezt, lásd a két képet,
Kép
Kép
de azonosítani már ATA(PATA) driverként helyesen azonosította, lévén az alaplapom kombinált IDE(PATA)-SATA vezérlője nálam a már említett, P-ATAOnly módban leledzik, így a Te Dell gépednél látott hibaképpel én nem találkoztam.
Talán meg kéne azt próbálni neked is, hogy csak IDE egységeket tennél/hagynál benne abba a Dell gépbe, és az alaplapi vezérlőt csa IDE(PATA) módba tennéd. Talán akkor már nálad is elindulna a xenial puppy, én tegnap ezzel az iso-val -xenial-7.0.4.iso- próbálkoztam, felemás sikerrel.
A weboldal linkje meg ez volt: http://distro.ibiblio.org/puppylinux/test/xenialpup/
Itt egyébként van egy kernel_source file is a janugsa által ajánlott 3.14.66-os kernelhez is.

azami
Hozzászólások: 844
Csatlakozott: 2014.06.20. 19:25

Re: Linux, régi gépekre

Hozzászólás Szerző: azami » 2016.12.26. 10:48

Egy újabb érdekes próbálkozás régi gépekhez : http://www.hwsw.hu/hirek/56598/raspberr ... Feed:+HWSW

NTamas
Hozzászólások: 1080
Csatlakozott: 2014.06.19. 12:36

Re: Linux, régi gépekre

Hozzászólás Szerző: NTamas » 2016.12.26. 11:51

Az azért igenelgondolkodtató lehet, hogy a cikkben leírt iso linkje eleve Firefox-alatt használhatatlan a biztonsági beállítás miatt, na meg amiatt, hogy ez a nk eleve nem a Rasberry oldalára visz, hanem egy igen gyanús átirányítással van dolgunk, lásd a linket:
--http://www.hwsw.hu/iparagipletykak/down ... ssie.iso--
Szóval, emiatt, -/www.hwsw.hu/iparagipletykak/- eleve egy címátirányításos trükk jön/ugrik be elsőre, ráadásul ez a fajta webes cím-átirányítás az újabb Firefox-okban már eleve tiltott , nem engedélyezett alapból, és ezt adja ki, pl. nálam:
Kép
ha, meg netalán engedélyezem, felveszem a kivételek közé, akkor sem javul a helyzet, mert ezt kapom ilyenkor:
Kép
szóval a kedves cikkíró elmehet a 3.14-csába, a helytelen linkelésével, nem tudom, neked azami, erről a linkről jön le valami iso egyáltalán?

Arról meg nem is beszélve, hogy az usb-sd-re való íráshoz egy olyan hmm...programot ajánlanak ami eleve irdatlan nagy méretű valami,
Kép
Kép
ezt a feladatot amúgy a rufus kb.1 Megában simán megoldja, szóval kissé/nagyon furcsa itt minden.....
-------------------------------------------------------------------------------------------------------------------------
Ha a kedves cikíró már a Rasberry ooldalát említette, illetve a Mac-ra való, és a Pc-n is futtatható Linux verziót feszegette, akkor talán célszerűbb lett volna a közvetlen Rasberry-s oldalt belinkelni, ezt:
https://www.raspberrypi.org/blog/pixel-pc-mac/
és, ha nagyon ügyes lett volna a kedves fizetett firkász úr, akkor a letöltési linkként a jó linket is beírhatta volna, ennyi erővel, ez lenne az, egyébiránt:
http://downloads.raspberrypi.org/pixel_ ... jessie.iso

Kép

azonban az 1.3GB-méret kissé elgondolkodtató, főleg, hogy régi gépekre ajánlották, ez kibontva jóval több lehet, és mi lehet esetleg benne, -a méretét elnézve- ami a régi gépekre talán nem feltétlenül kell/szükséges......gondolok itt erre a cikkíró által említett belbecsre, ami gyengébb gépekre eleve, nem biztos hogy kell/jó dolog erőltetni.(lásd például a Libre Ofice szoftver beépítését,

Kép
minek is? - miért nem jó az, ha külön lehet mindig a legfrissebb verziót telepíteni, még akor is, ha netán a beépített Libre verzió képes frissülni esetleg. Egy oprendszer legyen egy jó alap, és ne akarjon azonnal irodai alkalmazásként is funkcionálni! A szoftverválasztás jogát illik a felhasználónak meghagyni, és nem önkényesen betenni valamit, amit esetleg a leendő felhasználó éppen nem akarna telepíteni, bizonyos okok miatt.)

...a repertoárban többek között a Chromium böngésző, illetve a notórius Adobe Flash is megtalálható ...
Az egy dolog, hogy, idézem:
... a szoftver 512 megabájt memóriával is elzakatol ...
de akkor még ott a Chromium böngésző memória igénye, és a Flash-t se felejtsük ki a memóriazabálók sorából, és azt se feledjük el, hogy a gyenge gépeket gyakori az 1GB Ram, vagy inkább ettől kevesebb a jellemző, szóval?
Vegyük már észre, és jusson már el végre mindenki oda, hogy megértse, a modern webböngészők és a modern Flash-player használata még az erősebb gépeket, mint pl. az én kétmagos, 3Ghz-es procival bíró, 1.5GB RAM-os, és saját, külön memóriás (ez nem alaplapi, integrált, a rendszermemóriát használó videórész!) videókártyás gépemet is képes jócskán belassítani, még akkor is, ha az oprendszer egy Linux, és nem a sokat szidott Windows.
A hozzászólást 3 alkalommal szerkesztették, utoljára NTamas 2016.12.26. 13:41-kor.

NTamas
Hozzászólások: 1080
Csatlakozott: 2014.06.19. 12:36

Re: Linux, régi gépekre

Hozzászólás Szerző: NTamas » 2016.12.26. 12:43

A legszebb az egész történetben az, -és ez ismét a hwsw-t, meg a cikk(í) írót is minősíti- hogy egy három éve lejárt tanúsítvánnyal üzemelnek, ez még pluszban hozzájön/rátesz az idióta címátirányításos link használathoz....szép egy banda!
Kép

Válasz küldése

Vissza: “Egyéb OS”

Ki van itt

Jelenlévő fórumozók: 1 valamint 0 vendég