Inkompatibilitási Frászkarikák

Totál hétköznapi témák, ötletek, tutira nem linux és nem PC
Avatar
csipesz
Hozzászólások: 520
Csatlakozott: 2014.06.24. 11:02
Tartózkodási hely: Isaszeg

Inkompatibilitási Frászkarikák

Hozzászólás Szerző: csipesz » 2017.05.01. 17:43

Egy iménti meg egy pár nappal ezelõtti frász: olvasom az elõbb a kros54 által indított videóformátum-átalakítgatós cikket, á, mondom, nézzük má' meg azt az mp4 videót, amit a yandex-re töltött fel; épp opera 36 volt elõttem, ami szerintem egy manapság még nagyon rendben lévõ verzió... - azt hiszitek, kinyílt rá a yandex-oldal? Dehogy. Yandex Õméltósága nem áll szóba holmi Operákkal - kapja be az a felhasználó, akinél épp nincs kéznél Firefox!(nálam persze volt kéznél, na de milyen ez már?!)
Másik: mikor nemrég beindítottam a Google Drive tárhelyemen a megújult szoftver-gyûjteményem, annak ugye van egy osztott linkje a Ti számotokra - kipróbáltam a minap ezt a linket egy Firefox 21-esen megnyitni, már csak úgy tesztféleképpen: Gugli úrnak ilyen alantas, régi verziójú Firefoxon esze ágában sem volt megnyitni a cuccost. FF40-essel már elõkínlódta a holmit.
Azért ezek elkeserítõ dolgok valahol...
Várom hasonló történeteiteket.

kros54
Hozzászólások: 348
Csatlakozott: 2014.06.17. 07:01
Kapcsolat:

Re: Inkompatibilitási Frászkarikák

Hozzászólás Szerző: kros54 » 2017.05.01. 18:11

Amikor arra gondoltunk (a honlap építésében és kitalálásában Watcherrel dolgoztunk össze) hogy viszonylag időtálló formátumot válasszunk, akkor a flash elég jónak tünt. S mivel az ilyen fotókból-videót típusú, s a végén flash-kimenetet adó programból többet is begyűjtöttem, éppen azért, hogy ne legyen mind hót-egyforma, hát hol ezt, hol azt használtam. Most a Firefox már bizonyosakat nem tud megnyitni... pedig ez csak 5 év...

NTamas
Hozzászólások: 1484
Csatlakozott: 2014.06.19. 13:36

Re: Inkompatibilitási Frászkarikák

Hozzászólás Szerző: NTamas » 2017.05.02. 15:27

Bizonyos inkompatibilitási hibák nemcsak webböngészőkben, hanem egyéb programok esetében is jelentkezhetnek, kezdve attól a közismert ténytől, hogy egyes, általunk kedvelt programok újabb verziói már csak magasabb verziószámú oprendszer alatt hajlandóak működni. Ezt még úgy -ahogy meg is emésztené az ember, ha nehezen is, de mi van akkor, ha egy eleve régebbi oprendszerre (XP-Vista) írt programot -ez jelen esetemben az ACDSee Pro2.5 progi- most újra elővettem, és az XP-t tartalmazó gépemre egy bizonyos okból újra fel kívánom telepíteni?

Az ember azt gondolná, semmi, arra a rendszerre íródott, simán fel fog rá menni, persze, csak éppen nem ez történt.
A telepítés elindult ugyan, de a vége felé egy szép kis hibaüzi ablakot dobott fel, amiben közli, hogy a msi telepítőnek gondja akadt az oprendszerben lévő advpack.dll-el, és ezért, az emiatt fellépő inkompatibilitás miatt a telepítés nem folytatható, lépjen kapcsolatba a szoftver gyártójával, vagy a rendszer üzemeltetőjével!

Mi van? -mi nem tetszik neked? Erre az XP-re már számtalanszor lettél feltelepítve, most mégis mi a bajod?
Azután kezdtem elgondolkodni azon, hogy az XP ugyan a legutolsó frissítéssel is el lett látva annó, mielőtt megszűnt a támogatása, lehet, akkor azokban a frissítésekben lehetett olyan, ami esetleg ezt az advpack.dll-t frissíthette volna újabbra, vagy javított e esetleg benne valamit, amiért ez a file -c:\windows\system32\advpack.dll- megorrolhat az msi telepítőket alkalmazó szoftverekre.
A telepítendő ACDSee szoftver kibontott msi telepítőjét próbáltam kézzel is elindítani, -amúgy maga szoftver telepítő fájlja egy exe file- és akkor is hasonló probléma jött elő, megjelent ugyanaz a hiba ablak, benne ugyanazon hibaüzenettel. Ekkor már derengett nekem, hogy az XP korszak vége felé az MS javította, illetve lecserélte, frissítette az XP-ben lévő msi telepítőt egy újabbra, állítólag biztonságosabb verzióra. Ebben lehet valami ugyanis a hibaüzenet némi memóriacímzési gondokat is megemlített, bizonyos memóriaterületre, címre való írást nem engedélyezett az ACDSee Pro2.5 progiban lévő, az exe filébe becsomagolt, gyári, valószínűleg régebbi verziójú msi telepítőnek. Mivel az XP-ben már az MS által frissített, újabb verziójú msi telepítő van, az advpack.dll-ből még ugyan tudtam elővarázsolni egy régebbi MS XP cd-ről egy régebbi dll verzió, (ennek a kicserélése sem oldotta meg egyébiránt a problémát) viszont a CD-n levő régebbi msi telepítőt nem lehetett már visszatenni az XP-be, ezt már nem engedte az oprendszer!

Csak azt nem értem, tavaly is feltettem ugyanerre az XP-re (majd később, amikor már nem kellett, leszedtem azt) ugyanezt az ACDSee programot, és ekkor már nem jöttek az XP-hez frissítések, ennek ellenére tavaly simán feltelepült a szoftver, minden hibaüzenet nélkül!
Ma, amikor szintén nem kap már frissítést az XP, maga az oprendszer meg ugyanaz, mint tavaly is volt, akkor ma miért is nem akar a tavaly még telepíthető szoftver újra feltelepülni?
Ugyanakkor, próbaképp egy másik, szintén msi telepítőfilét tartalmazó szoftver meg simán feltelepül az XP-re, így ki van zárva az XP-ben lévő msi telepítő esetleges fájl sérüléséből adódó hibaüzenet, mint olyan.

Azért az is nagyon bosszantó ám, hogy bár az oké, hogy egy bizonyos oprendszer fájlt frissítenek, állítólagos biztonság okán, de emiatt régebbi programokat már nem, vagy csak kerülő úton lehet újra telepíteni.

A kérdéses szoftvert azért akartam volna használni, mivel nagyon jó adatbázisa van, egy csomó kamerát tud fogadni, ismeri, és jól kezeli a RAW formátumot használó kamerák képeit, tudja azokat szerkeszteni is (bizonyos határon belül, persze) és azért is, mert ezt már ismertem, tudtam róla, jól működik az XP alatt, álmomban nem gondoltam volna, hogy a még tavaly is simán az XP-re feltett, és használt szoftvert az idén már telepíteni sem fogom tudni.

Végül a problémát egy másik szoftver feltelepítésével ugyan áthidaltam, megoldottam, de azért az ilyen inkompatibilis húzások igencsak fel tudják bosszantani az embert.

Avatar
csipesz
Hozzászólások: 520
Csatlakozott: 2014.06.24. 11:02
Tartózkodási hely: Isaszeg

Re: Inkompatibilitási Frászkarikák

Hozzászólás Szerző: csipesz » 2017.05.04. 00:04

szia, ntamas, ezt próbáld ki:
https://www.solidfiles.com/v/33xm6xZYYRemX
:)
Igaz, magyarítás nem létezik hozzá, de tizen-valahány éve megbízható, kedvenc...

NTamas
Hozzászólások: 1484
Csatlakozott: 2014.06.19. 13:36

Re: Inkompatibilitási Frászkarikák

Hozzászólás Szerző: NTamas » 2017.05.04. 09:59

Köszönöm szépen, de ez nekem is megvan, szintén régről, és szintén kedvenc cuccom nekem is.
Ami miatt mégis a magasabb Pro verziót kerestem, az a RAW kezelés, a jobb kamera adatbázis, illetve a jobb kamerafelismerés, emiatt végül is az ACDSee 8 került fel, és ezzel már simán tudtam dolgozni egy Nikon kamerával is, rendben felismerte a modernebb kamerát, az sd-n tárolt RAW formátumokat is simán kezelte, végül is ez volt a célom, így ez összejött, ha kerülő úton is. Az azért érdekes, hogy ennek a 8-as ACDSee verziónak is a tényleges telepítője ugyanúgy egy msi file, és ez viszont már nem balhézott össze az XP-vel, úgy látszik ebben a 8-as verzióban már módosított msi telepítő van, ezt mondjuk, jó tudni.

NTamas
Hozzászólások: 1484
Csatlakozott: 2014.06.19. 13:36

Re: Inkompatibilitási Frászkarikák

Hozzászólás Szerző: NTamas » 2017.12.20. 14:33

Más téma, de ez is inkompatibilis dolog, tehát ide írom a mai hírt:
Átmenetileg visszavonták az Ubuntu 17.10 letöltési linkjeit BIOS korrupciós hiba miatt.

Jelenleg még mindig nem elérhetők az Ubuntu 17.10 letöltési linkjei, mert egyes Lenovo (és más) laptop felhasználók arról számoltak be, hogy telepítés után gépük BIOS-a korrupttá vált. Az érintett gépeken egyebek mellett nem lehet elmenteni a megváltoztatott BIOS beállításokat, illetve nem lehet USB-ről bootolni. A bug nyomon követhető itt. Részletek itt.

Válasz küldése

Vissza: “Off Topic”